Bug 82109 - Firefox crashes Google Maps, likely related to graphics driver
Summary: Firefox crashes Google Maps, likely related to graphics driver
Status: RESOLVED DUPLICATE of bug 81680
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/Gallium/r600 (show other bugs)
Version: 10.1
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Default DRI bug account
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-08-04 02:33 UTC by Markus Popp
Modified: 2015-11-24 03:15 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Markus Popp 2014-08-04 02:33:37 UTC
My Firefox (31.0 release to 34.0 nightly) on Linux64 regularly crashes when accessing Google Maps. First time during a session it works fine, but going back to Google Maps at a later point during the same session crashes Firefox.

I filed a bug at Mozilla:

https://bugzilla.mozilla.org/show_bug.cgi?id=1022987

but since the crashes are apparently caused by the graphics driver, as developers told me, I was asked to file a bug report here.

Find a corresponding Firefox Crash Report at

https://crash-stats.mozilla.com/report/index/228c877e-9bdf-4a59-b043-e51592140616

Please let me know if I can assist with providing further information.
Comment 1 Michel Dänzer 2014-08-04 02:49:28 UTC
We need symbols for the r600_dri.so stack frames, see bug 81680.
Comment 2 Aaron B 2014-08-04 06:47:42 UTC
SOunds like, and probably is, the same bug I have in Bug 81644. And the other linked to, too.
Comment 3 Fabrizio Gennari 2014-10-19 09:24:31 UTC
Same problem with Firefox 33.0, on Ubuntu 14.10. This is a call stack, taken from Mozilla's crash report

1 	r600_dri.so 	r600_dri.so@0x168a34 	
2 	libgallium.so.0.0.0 	libgallium.so.0.0.0@0x327e3 	
3 	r600_dri.so 	r600_dri.so@0x5cba3f 	
4 	r600_dri.so 	r600_dri.so@0x5cbaa7 	
5 	r600_dri.so 	r600_dri.so@0x164a26 	
6 	r600_dri.so 	r600_dri.so@0x16b7fe 	
7 	r600_dri.so 	r600_dri.so@0xf73f3

Package: libgl1-mesa-dri
Architecture: amd64
Version: 10.1.3-0ubuntu0.1
Comment 4 Fabrizio Gennari 2014-10-19 09:26:00 UTC
Correction: Ubuntu 14.04
Comment 5 Michel Dänzer 2014-10-29 06:55:53 UTC
Let me point out bug 81680 again. It may be the same bug, but if the fix for it doesn't help for this problem, please resolve the symbols for the crash report as described there.
Comment 6 Christoph Brill 2015-11-17 09:49:22 UTC
This bug is about a year old. Could you please retest and see if bug 81680 fixed it?
Comment 7 Fabrizio Gennari 2015-11-23 22:01:02 UTC
It is not happening any more
Comment 8 Michel Dänzer 2015-11-24 03:15:52 UTC
Okay, let's assume it's a duplicate, thanks.

*** This bug has been marked as a duplicate of bug 81680 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.