Bug 82294 - No more logging information received from standard output of system services after systemd-journald is restarted
Summary: No more logging information received from standard output of system services ...
Status: RESOLVED DUPLICATE of bug 84923
Alias: None
Product: systemd
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Hardware: Other Linux (All)
: medium normal
Assignee: systemd-bugs
QA Contact: systemd-bugs
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-08-07 13:39 UTC by Georg Soffel
Modified: 2014-12-09 00:46 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Georg Soffel 2014-08-07 13:39:47 UTC
To reproduce do the following as root:

Create a service file for the wdg service at "/lib/systemd/system/wdg.service" with the following content:
--- % ---
[Unit]
Description=wdg service
[Service]
ExecStart=/wdg.sh
Restart=on-failure
[Install]
WantedBy=multi-user.target
--- % ---

Then create the file "/wdg.sh" with the following content:
--- % ---
#!/bin/sh
while true ; do
/bin/sleep 3
/usr/bin/logger -t wdg "log ok"
/bin/echo "cout ok"
/usr/bin/logger -t wdg "echo return: $?"
done
--- % ---

Make the file "/wdg.sh" executable:
chmod +x /wdg.sh

Start the wdg service:
systemctl start wdg

Monitoring the wdg service with journalctl delivers:
journalctl -u wdg -f
--- % ---
Aug 07 15:25:38 pc systemd[1]: Starting wdg service...
Aug 07 15:25:38 pc systemd[1]: Started wdg service.
Aug 07 15:25:41 pc wdg[2519]: log ok
Aug 07 15:25:41 pc wdg.sh[2509]: cout ok
Aug 07 15:25:41 pc wdg[2521]: echo return: 0
Aug 07 15:25:44 pc wdg[2523]: log ok
Aug 07 15:25:44 pc wdg.sh[2509]: cout ok
Aug 07 15:25:44 pc wdg[2525]: echo return: 0
Aug 07 15:25:47 pc wdg[2534]: log ok
Aug 07 15:25:47 pc wdg.sh[2509]: cout ok
Aug 07 15:25:47 pc wdg[2536]: echo return: 0
...
--- % ---

Now restart journald:
systemctl restart systemd-journald

Monitoring the wdg service with journalctl now delivers:
journalctl -u wdg -f
--- % ---
Aug 07 15:33:27 pc wdg[31836]: log ok
Aug 07 15:33:27 pc wdg[31838]: echo return: 1
Aug 07 15:33:30 pc wdg[31840]: log ok
Aug 07 15:33:30 pc wdg[31842]: echo return: 1
...
--- % ---


No more logging of services standard


This behavior was detected with
- Poky Linux on ARM systemd version 199 and 206
- Fedora Release 20 64bit x86 with systemd version 208
Comment 1 Georg Soffel 2014-08-08 09:18:00 UTC
The sentence "No more logging of services standard" is unfortunately not complete. It should be:

Nor more logging of systemd services standard output logging.

I did not find a way to fix the initial description.
Comment 2 Lennart Poettering 2014-12-09 00:46:13 UTC

*** This bug has been marked as a duplicate of bug 84923 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct.