Bug 82397 - some GLSL demo render badly on Radeon 7870
Summary: some GLSL demo render badly on Radeon 7870
Status: RESOLVED INVALID
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/Gallium/radeonsi (show other bugs)
Version: 10.1
Hardware: Other All
: medium normal
Assignee: Default DRI bug account
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-08-09 20:03 UTC by Damian Nowak
Modified: 2015-08-02 10:50 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Damian Nowak 2014-08-09 20:03:43 UTC
The demo doesn't render correctly on Radeon 7870 (glamoregl+radeonsi) on Mesa 10.1. I didn't try Mesa 10.2 because of critical bug #65963, so others are welcome to validate on Mesa 10.2.

Demo: http://glsl.heroku.com/e#18749.0
Rendered on my friend's blob: http://x.rushbase.net/62726ab9e439bc355ce7a4846ea1cafd67a5b628/glsl.mp4
How it looks for me: http://upload.nowaker.net/nwkr/1407613451_blah.png

I will soon check on Mesa 10.2.
Comment 1 Michel Dänzer 2014-08-10 03:29:26 UTC
Works fine for me in Iceweasel 31 on radeonsi from current Mesa Git master built against current LLVM trunk.
Comment 2 Damian Nowak 2014-08-13 02:59:26 UTC
Thanks for the info Michel. I'll bump my drivers soon and let you know.
Comment 3 Marek Olšák 2015-08-02 10:50:13 UTC
(In reply to Michel Dänzer from comment #1)
> Works fine for me in Iceweasel 31 on radeonsi from current Mesa Git master
> built against current LLVM trunk.

(In reply to Damian Nowak from comment #2)
> Thanks for the info Michel. I'll bump my drivers soon and let you know.

No feedback after 12 months. Closing.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.