Bug 82471 - [swrast] piglit fp-condition_codes-01 regression
Summary: [swrast] piglit fp-condition_codes-01 regression
Status: RESOLVED DUPLICATE of bug 82477
Alias: None
Product: Mesa
Classification: Unclassified
Component: Mesa core (show other bugs)
Version: git
Hardware: x86-64 (AMD64) All
: medium normal
Assignee: mesa-dev
QA Contact:
URL:
Whiteboard:
Keywords: bisected, regression
Depends on:
Blocks:
 
Reported: 2014-08-11 18:49 UTC by Vinson Lee
Modified: 2016-07-09 00:10 UTC (History)
2 users (show)

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Vinson Lee 2014-08-11 18:49:54 UTC
mesa: 23d782067ae834ad53522b46638ea21c62e94ca3 (master 10.3.0-devel)

$ ./bin/fp-condition_codes-01 -auto
Probe color at (26,26)
  Expected: 0.900000 0.500000 0.700000
  Observed: 0.200000 0.501961 0.698039
Probe color at (26,43)
  Expected: 0.900000 0.500000 0.700000
  Observed: 0.901961 0.200000 0.698039
Probe color at (26,60)
  Expected: 0.900000 0.500000 0.700000
  Observed: 0.200000 0.200000 0.698039
Probe color at (26,77)
  Expected: 0.900000 0.500000 0.700000
  Observed: 0.901961 0.501961 0.200000
Probe color at (26,94)
  Expected: 0.900000 0.500000 0.700000
  Observed: 0.200000 0.501961 0.200000
Probe color at (26,111)
  Expected: 0.900000 0.500000 0.700000
  Observed: 0.901961 0.200000 0.200000
Probe color at (26,128)
  Expected: 0.900000 0.500000 0.700000
  Observed: 0.200000 0.200000 0.200000
Probe color at (26,162)
  Expected: 0.900000 0.500000 0.700000
  Observed: 0.200000 0.501961 0.698039
Probe color at (26,179)
  Expected: 0.900000 0.500000 0.700000
  Observed: 0.901961 0.200000 0.698039
Probe color at (26,196)
  Expected: 0.900000 0.500000 0.700000
  Observed: 0.200000 0.200000 0.698039
Probe color at (26,213)
  Expected: 0.900000 0.500000 0.700000
  Observed: 0.901961 0.501961 0.200000
Probe color at (26,230)
  Expected: 0.900000 0.500000 0.700000
  Observed: 0.200000 0.501961 0.200000
Probe color at (26,247)
  Expected: 0.900000 0.500000 0.700000
  Observed: 0.901961 0.200000 0.200000
Probe color at (43,26)
  Expected: 0.900000 0.500000 0.700000
  Observed: 0.200000 0.501961 0.698039
Probe color at (43,43)
  Expected: 0.900000 0.500000 0.700000
  Observed: 0.901961 0.200000 0.698039
Probe color at (43,60)
  Expected: 0.900000 0.500000 0.700000
  Observed: 0.200000 0.200000 0.698039
Probe color at (43,77)
  Expected: 0.900000 0.500000 0.700000
  Observed: 0.901961 0.501961 0.200000
Probe color at (43,94)
  Expected: 0.900000 0.500000 0.700000
  Observed: 0.200000 0.501961 0.200000
Probe color at (43,111)
  Expected: 0.900000 0.500000 0.700000
  Observed: 0.901961 0.200000 0.200000
Probe color at (43,128)
  Expected: 0.900000 0.500000 0.700000
  Observed: 0.200000 0.200000 0.200000
Probe color at (43,162)
  Expected: 0.900000 0.500000 0.700000
  Observed: 0.200000 0.501961 0.698039
Probe color at (43,179)
  Expected: 0.900000 0.500000 0.700000
  Observed: 0.901961 0.200000 0.698039
Probe color at (43,196)
  Expected: 0.900000 0.500000 0.700000
  Observed: 0.200000 0.200000 0.698039
Probe color at (43,213)
  Expected: 0.900000 0.500000 0.700000
  Observed: 0.901961 0.501961 0.200000
Probe color at (43,230)
  Expected: 0.900000 0.500000 0.700000
  Observed: 0.200000 0.501961 0.200000
Probe color at (43,247)
  Expected: 0.900000 0.500000 0.700000
  Observed: 0.901961 0.200000 0.200000
Probe color at (60,9)
  Expected: 0.900000 0.500000 0.700000
  Observed: 0.901961 0.200000 0.200000
Probe color at (60,26)
  Expected: 0.900000 0.500000 0.700000
  Observed: 0.901961 0.200000 0.200000
Probe color at (60,43)
  Expected: 0.900000 0.500000 0.700000
  Observed: 0.901961 0.200000 0.200000
Probe color at (60,60)
  Expected: 0.900000 0.500000 0.700000
  Observed: 0.901961 0.200000 0.200000
Probe color at (60,77)
  Expected: 0.900000 0.500000 0.700000
  Observed: 0.901961 0.200000 0.200000
Probe color at (60,94)
  Expected: 0.900000 0.500000 0.700000
  Observed: 0.901961 0.200000 0.200000
Probe color at (60,111)
  Expected: 0.900000 0.500000 0.700000
  Observed: 0.901961 0.200000 0.200000
Probe color at (60,128)
  Expected: 0.900000 0.500000 0.700000
  Observed: 0.901961 0.200000 0.200000
Probe color at (60,145)
  Expected: 0.900000 0.500000 0.700000
  Observed: 0.901961 0.200000 0.200000
Probe color at (60,162)
  Expected: 0.900000 0.500000 0.700000
  Observed: 0.901961 0.200000 0.200000
Probe color at (60,179)
  Expected: 0.900000 0.500000 0.700000
  Observed: 0.901961 0.200000 0.200000
Probe color at (60,196)
  Expected: 0.900000 0.500000 0.700000
  Observed: 0.901961 0.200000 0.200000
Probe color at (60,213)
  Expected: 0.900000 0.500000 0.700000
  Observed: 0.901961 0.200000 0.200000
Probe color at (60,230)
  Expected: 0.900000 0.500000 0.700000
  Observed: 0.901961 0.200000 0.200000
Probe color at (60,247)
  Expected: 0.900000 0.500000 0.700000
  Observed: 0.901961 0.200000 0.200000
Probe color at (77,26)
  Expected: 0.900000 0.500000 0.700000
  Observed: 0.200000 0.501961 0.698039
Probe color at (77,43)
  Expected: 0.900000 0.500000 0.700000
  Observed: 0.901961 0.200000 0.698039
Probe color at (77,60)
  Expected: 0.900000 0.500000 0.700000
  Observed: 0.200000 0.200000 0.698039
Probe color at (77,77)
  Expected: 0.900000 0.500000 0.700000
  Observed: 0.901961 0.501961 0.200000
Probe color at (77,94)
  Expected: 0.900000 0.500000 0.700000
  Observed: 0.200000 0.501961 0.200000
Probe color at (77,111)
  Expected: 0.900000 0.500000 0.700000
  Observed: 0.901961 0.200000 0.200000
Probe color at (77,128)
  Expected: 0.900000 0.500000 0.700000
  Observed: 0.200000 0.200000 0.200000
Probe color at (77,162)
  Expected: 0.900000 0.500000 0.700000
  Observed: 0.200000 0.501961 0.698039
Probe color at (77,179)
  Expected: 0.900000 0.500000 0.700000
  Observed: 0.901961 0.200000 0.698039
Probe color at (77,196)
  Expected: 0.900000 0.500000 0.700000
  Observed: 0.200000 0.200000 0.698039
Probe color at (77,213)
  Expected: 0.900000 0.500000 0.700000
  Observed: 0.901961 0.501961 0.200000
Probe color at (77,230)
  Expected: 0.900000 0.500000 0.700000
  Observed: 0.200000 0.501961 0.200000
Probe color at (77,247)
  Expected: 0.900000 0.500000 0.700000
  Observed: 0.901961 0.200000 0.200000
Probe color at (94,9)
  Expected: 0.900000 0.500000 0.700000
  Observed: 0.901961 0.200000 0.200000
Probe color at (94,26)
  Expected: 0.900000 0.500000 0.700000
  Observed: 0.901961 0.200000 0.200000
Probe color at (94,43)
  Expected: 0.900000 0.500000 0.700000
  Observed: 0.901961 0.200000 0.200000
Probe color at (94,60)
  Expected: 0.900000 0.500000 0.700000
  Observed: 0.901961 0.200000 0.200000
Probe color at (94,77)
  Expected: 0.900000 0.500000 0.700000
  Observed: 0.901961 0.200000 0.200000
Probe color at (94,94)
  Expected: 0.900000 0.500000 0.700000
  Observed: 0.901961 0.200000 0.200000
Probe color at (94,111)
  Expected: 0.900000 0.500000 0.700000
  Observed: 0.901961 0.200000 0.200000
Probe color at (94,128)
  Expected: 0.900000 0.500000 0.700000
  Observed: 0.901961 0.200000 0.200000
Probe color at (94,145)
  Expected: 0.900000 0.500000 0.700000
  Observed: 0.901961 0.200000 0.200000
Probe color at (94,162)
  Expected: 0.900000 0.500000 0.700000
  Observed: 0.901961 0.200000 0.200000
Probe color at (94,179)
  Expected: 0.900000 0.500000 0.700000
  Observed: 0.901961 0.200000 0.200000
Probe color at (94,196)
  Expected: 0.900000 0.500000 0.700000
  Observed: 0.901961 0.200000 0.200000
Probe color at (94,213)
  Expected: 0.900000 0.500000 0.700000
  Observed: 0.901961 0.200000 0.200000
Probe color at (94,230)
  Expected: 0.900000 0.500000 0.700000
  Observed: 0.901961 0.200000 0.200000
Probe color at (94,247)
  Expected: 0.900000 0.500000 0.700000
  Observed: 0.901961 0.200000 0.200000
Probe color at (111,9)
  Expected: 0.900000 0.500000 0.700000
  Observed: 0.901961 0.200000 0.200000
Probe color at (111,26)
  Expected: 0.900000 0.500000 0.700000
  Observed: 0.901961 0.200000 0.200000
Probe color at (111,43)
  Expected: 0.900000 0.500000 0.700000
  Observed: 0.901961 0.200000 0.200000
Probe color at (111,60)
  Expected: 0.900000 0.500000 0.700000
  Observed: 0.901961 0.200000 0.200000
Probe color at (111,77)
  Expected: 0.900000 0.500000 0.700000
  Observed: 0.901961 0.200000 0.200000
Probe color at (111,94)
  Expected: 0.900000 0.500000 0.700000
  Observed: 0.901961 0.200000 0.200000
Probe color at (111,111)
  Expected: 0.900000 0.500000 0.700000
  Observed: 0.901961 0.200000 0.200000
Probe color at (111,128)
  Expected: 0.900000 0.500000 0.700000
  Observed: 0.901961 0.200000 0.200000
Probe color at (111,145)
  Expected: 0.900000 0.500000 0.700000
  Observed: 0.901961 0.200000 0.200000
Probe color at (111,162)
  Expected: 0.900000 0.500000 0.700000
  Observed: 0.901961 0.200000 0.200000
Probe color at (111,179)
  Expected: 0.900000 0.500000 0.700000
  Observed: 0.901961 0.200000 0.200000
Probe color at (111,196)
  Expected: 0.900000 0.500000 0.700000
  Observed: 0.901961 0.200000 0.200000
Probe color at (111,213)
  Expected: 0.900000 0.500000 0.700000
  Observed: 0.901961 0.200000 0.200000
Probe color at (111,230)
  Expected: 0.900000 0.500000 0.700000
  Observed: 0.901961 0.200000 0.200000
Probe color at (111,247)
  Expected: 0.900000 0.500000 0.700000
  Observed: 0.901961 0.200000 0.200000
PIGLIT: {"result": "fail" }


f82f2fb3dc770902f1657ab1c22e6004faa3afab is the first bad commit
commit f82f2fb3dc770902f1657ab1c22e6004faa3afab
Author: Kenneth Graunke <kenneth@whitecape.org>
Date:   Sat Aug 2 05:33:14 2014 -0700

    mesa: Actually use the Mesa IR optimizer for ARB programs.
    
    On Haswell, this cuts 1-3 instructions from 183 vertex shaders in
    "Shadowrun Returns", "Shatter", and "Trine 2."  It adds 2 instructions
    to a single fragment shader in "Closure."
    
    total instructions in shared programs: 278803 -> 278546 (-0.09%)
    instructions in affected programs:     41930 -> 41673 (-0.61%)
    
    Signed-off-by: Kenneth Graunke <kenneth@whitecape.org>
    Reviewed-by: Eric Anholt <eric@anholt.net>

:040000 040000 e36b3a25abfddfcd79865f73c885f3bd89af034b 9a18c67434a461b0d09cb3c6487f9606cd8786b8 M	src
bisect run success
Comment 1 Ian Romanick 2015-02-11 23:06:51 UTC

*** This bug has been marked as a duplicate of bug 82477 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.