Bug 82581 - Build fails on OSMesa stage, missing dlfcn.h.
Summary: Build fails on OSMesa stage, missing dlfcn.h.
Status: RESOLVED DUPLICATE of bug 82546
Alias: None
Product: Mesa
Classification: Unclassified
Component: Other (show other bugs)
Version: git
Hardware: x86-64 (AMD64) Linux (All)
: medium major
Assignee: mesa-dev
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-08-13 20:37 UTC by Aaron B
Modified: 2014-08-13 20:43 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Aaron B 2014-08-13 20:37:36 UTC
Tee didn't print all output apparently, but it looks like someone forgot to "#include <dlfcn.h>" and when attempting to link OSMesa, it fails to link. The files it complains about not having it are the s3tc compression and glapi_gentable.
Comment 1 Emil Velikov 2014-08-13 20:43:18 UTC
How would a missing header inclusion would cause a link issue ?
Either way thanks for reporting Aaron, but someone beat you to it :P Fix (revert) should be out shortly.

*** This bug has been marked as a duplicate of bug 82546 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct.