Bug 82592 - [IVB/BYT Bisected]etqw-demo/Lightsmarkv2008/warsowv1.0/Counter-Strike:source/Half-Life2/Portal/synmark2_v6/unigine-demos/GLbenchmarkv2.5.1/GLbenchmarkv2.7.0/3DMME2.0_taiji/3DMME2.0_hoverjet performance reduced 10%~90%
Summary: [IVB/BYT Bisected]etqw-demo/Lightsmarkv2008/warsowv1.0/Counter-Strike:source/...
Status: VERIFIED FIXED
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i965 (show other bugs)
Version: unspecified
Hardware: All Linux (All)
: high major
Assignee: Kenneth Graunke
QA Contact: Intel 3D Bugs Mailing List
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-08-14 02:43 UTC by zhoujian
Modified: 2014-09-01 08:02 UTC (History)
2 users (show)

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description zhoujian 2014-08-14 02:43:45 UTC
Platform: IVB/BYT/BDW
Libdrm: (master)libdrm-2.4.56-4-g07fead4462b2d537d0c3cae69a09272fc426c598
Mesa: (master)52901ec2615761390f5ef97b11516dae330d27d1
Xserver: (master)xorg-server-1.15.99.902-121-g2f5cf9ff9a0f713b7e038636484c77f
Xf86_video_intel: (master)2.99.914-46-gec10cef592b7a3d1dc3c4949778e72e8
Cairo: (master)c7ff9bb32e20679d6da4e8a2856be716e5bd9e12
Libva: (master)3fddb7f937df4e0e15391bd65ae3c7552ea5b3d7
Libva_intel_driver: (master)82d2ed8d7da3619c0ea467c06604f5626fc0b901
Kernel_version: drm-intel-nightly(git-723dbb)

Bug detailed description:
----------------------------------------------
etqw-demo/Lightsmarkv2008/warsowv1.0/Counter-Strike:source/Half-Life2/Portal/synmark2_v6(OglBatch0-Oglbatch7/OglDrvRes/OglDrvShCom/OglDrvState/OglGeomPoint/OglGeomTriList/OglGeomTristrip/OglHdrBloom/OglVSDiffuse1/OglVSDiffuse8/OglVSlnstancing/OglVSTangent)unigine-demos/GLbenchmarkv2.5.1/GLbenchmarkv2.7.0/3DMME2.0 taiji/hoverjet performance reduced 10%~90% on IVB/BDW/BYT, this problem doesn't exist on HSW, The problem exists both on gnome-session and Raw X.

It’s Mesa regression, bisecting show that the first bad commit is:	
af13cf609f4257768ad8b80be8cec7f2e6ca8c81
Author:     Kenneth Graunke <kenneth@whitecape.org>
AuthorDate: Sun Aug 10 20:06:44 2014 -0700
Commit:     Kenneth Graunke <kenneth@whitecape.org>
CommitDate: Tue Aug 12 13:39:25 2014 -0700
    i965/vec4: Use MOV, not OR, to set URB write channel mask bits.

Reproduce steps:
---------------------------------------------
1.   xinit&
2.  ./synmark2 OglBatch0
Comment 1 Eero Tamminen 2014-08-14 08:09:39 UTC
Looking at the automated test numbers, drop between 13th & 11th August is most visible on IVB (and almost as large on BYT).

Of the tests, it's most visible in:
- Terrain instancing (-90%)
- Vertex processing/instancing (-90%)
- Geometry processing (-90%)
- Batching (-85%)
- EgyptHD (-85%)
- T-Rex (-80%)
- Heaven v3 (-80%)
- Tropics (-75%)
- TF2 (-65%)

Zhoujian, does the indicated commit cause all of this drop?
Comment 2 Matt Turner 2014-08-14 18:46:03 UTC
Does reverting the patch solve the problem?
Comment 3 Kenneth Graunke 2014-08-14 19:00:55 UTC
Broadwell cannot have a performance regression due to this commit, as that commit only changes Gen4-7 code generation.  Gen8+ was completely unaffected.

According to QA's performance tracking page, Synmark OglBatch0 performance actually increased by 8% between 8/06 and 8/13 on Broadwell.  Which is very different than a 10-90% performance regression as reported.
Comment 4 zhoujian 2014-08-15 00:46:09 UTC
(In reply to comment #1)
> Zhoujian, does the indicated commit cause all of this drop?
Yes,many 3D cases was reduced.
Comment 5 Kenneth Graunke 2014-08-15 00:48:15 UTC
Reverted on master.
Comment 6 zhoujian 2014-08-15 00:57:10 UTC
(In reply to comment #3)
> Broadwell cannot have a performance regression due to this commit, as that
> commit only changes Gen4-7 code generation.  Gen8+ was completely unaffected.
> 
> According to QA's performance tracking page, Synmark OglBatch0 performance
> actually increased by 8% between 8/06 and 8/13 on Broadwell.  Which is very
> different than a 10-90% performance regression as reported.
I mistake,this issue doesn't exists on BDW.
Comment 7 zhoujian 2014-08-18 02:16:45 UTC
Verified the latest commit :"git-ef130b6", this issue disappear.
Comment 8 zhoujian 2014-09-01 08:02:47 UTC
this issue also exit on Mesa:(10.3)git-627d31d release.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.