Bug 82596 - [IVB/BYT]Many Ogles3conform cases fail
Summary: [IVB/BYT]Many Ogles3conform cases fail
Status: VERIFIED FIXED
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i965 (show other bugs)
Version: unspecified
Hardware: All Linux (All)
: high normal
Assignee: Kenneth Graunke
QA Contact: Intel 3D Bugs Mailing List
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-08-14 05:27 UTC by lu hua
Modified: 2014-08-18 02:32 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description lu hua 2014-08-14 05:27:56 UTC
System Environment:
--------------------------
Platform: BYT/IVB
Libdrm:		(master)libdrm-2.4.56-4-g07fead4462b2d537d0c3cae69a09272fc426c598
Mesa:		(master)52901ec2615761390f5ef97b11516dae330d27d1
Xserver:	(master)xorg-server-1.15.99.902-121-g2f5cf9ff9a0f713b7e038636484c77f113a5f10a
Xf86_video_intel:(master)2.99.914-46-gec10cef592b7a3d1dc3c4949778e72e8cd156245
Libva:		(master)3fddb7f937df4e0e15391bd65ae3c7552ea5b3d7
Libva_intel_driver:(master)82d2ed8d7da3619c0ea467c06604f5626fc0b901
Kernel:   (drm-intel-nightly)723dbbfb6ce02b5662c0c4cac9be3bcdfbb11d35

Bug detailed description:
---------------------------
They fail on BYT/IVB mesa master branch, work well on 10.2 branch.
ES3-CTS.shaders.indexing.matrix_subscript.mat2x3_static_write_dynamic_loop_read_vertex
ES3-CTS.shaders.indexing.matrix_subscript.mat2x4_static_write_dynamic_loop_read_vertex
ES3-CTS.shaders.indexing.matrix_subscript.mat2x4_static_write_dynamic_read_vertex
ES3-CTS.shaders.indexing.matrix_subscript.mat2_dynamic_write_static_read_vertex
ES3-CTS.shaders.indexing.matrix_subscript.mat2_static_write_dynamic_loop_read_vertex
ES3-CTS.shaders.indexing.matrix_subscript.mat3x2_dynamic_loop_write_static_read_vertex
ES3-CTS.shaders.indexing.matrix_subscript.mat3x2_dynamic_write_static_read_vertex
ES3-CTS.shaders.indexing.matrix_subscript.mat3x2_static_write_dynamic_loop_read_vertex
ES3-CTS.shaders.indexing.matrix_subscript.mat3x2_static_write_dynamic_read_vertex
ES3-CTS.shaders.indexing.matrix_subscript.mat3x4_dynamic_write_static_read_vertex
ES3-CTS.shaders.indexing.matrix_subscript.mat3x4_static_write_dynamic_loop_read_vertex
ES3-CTS.shaders.indexing.matrix_subscript.mat3x4_static_write_dynamic_read_vertex
ES3-CTS.shaders.indexing.matrix_subscript.mat3_dynamic_loop_write_static_read_vertex
ES3-CTS.shaders.indexing.matrix_subscript.mat3_dynamic_write_static_read_vertex
ES3-CTS.shaders.indexing.matrix_subscript.mat3_static_write_dynamic_loop_read_vertex
ES3-CTS.shaders.indexing.matrix_subscript.mat3_static_write_dynamic_read_vertex
ES3-CTS.shaders.indexing.matrix_subscript.mat4x2_dynamic_loop_write_static_read_vertex
ES3-CTS.shaders.indexing.matrix_subscript.mat4x2_dynamic_write_static_read_vertex
ES3-CTS.shaders.indexing.matrix_subscript.mat4x2_static_write_dynamic_loop_read_vertex
ES3-CTS.shaders.indexing.matrix_subscript.mat4x2_static_write_dynamic_read_vertex
ES3-CTS.shaders.indexing.matrix_subscript.mat4x3_dynamic_loop_write_static_read_vertex
ES3-CTS.shaders.indexing.matrix_subscript.mat4x3_dynamic_write_static_read_vertex
ES3-CTS.shaders.indexing.matrix_subscript.mat4x3_static_write_dynamic_loop_read_vertex
ES3-CTS.shaders.indexing.matrix_subscript.mat4x3_static_write_dynamic_read_vertex
ES3-CTS.shaders.indexing.matrix_subscript.mat4_dynamic_write_static_read_vertex
ES3-CTS.shaders.indexing.matrix_subscript.mat4_static_write_dynamic_loop_read_vertex
ES3-CTS.shaders.indexing.matrix_subscript.mat4_static_write_dynamic_read_vertex
ES3-CTS.shaders.indexing.tmp_array.float_dynamic_write_static_read_vertex
ES3-CTS.shaders.indexing.tmp_array.float_static_write_dynamic_loop_read_vertex
ES3-CTS.shaders.indexing.tmp_array.float_static_write_dynamic_read_vertex
ES3-CTS.shaders.indexing.tmp_array.vec2_dynamic_write_static_read_vertex
ES3-CTS.shaders.indexing.tmp_array.vec2_static_write_dynamic_loop_read_vertex
ES3-CTS.shaders.indexing.tmp_array.vec3_static_write_dynamic_loop_read_vertex
ES3-CTS.shaders.indexing.tmp_array.vec4_static_write_dynamic_loop_read_vertex
ES3-CTS.shaders.indexing.varying_array.float_dynamic_loop_write_dynamic_loop_read
ES3-CTS.shaders.indexing.varying_array.float_dynamic_loop_write_dynamic_read
ES3-CTS.shaders.indexing.varying_array.float_dynamic_loop_write_static_loop_read
ES3-CTS.shaders.indexing.varying_array.float_dynamic_write_dynamic_loop_read
ES3-CTS.shaders.indexing.varying_array.float_dynamic_write_dynamic_read
ES3-CTS.shaders.indexing.varying_array.float_dynamic_write_static_loop_read
ES3-CTS.shaders.indexing.varying_array.float_dynamic_write_static_read
ES3-CTS.shaders.indexing.varying_array.vec2_dynamic_loop_write_dynamic_loop_read
ES3-CTS.shaders.indexing.varying_array.vec2_dynamic_loop_write_dynamic_read
ES3-CTS.shaders.indexing.varying_array.vec2_dynamic_loop_write_static_loop_read
ES3-CTS.shaders.indexing.varying_array.vec2_dynamic_loop_write_static_read
ES3-CTS.shaders.indexing.varying_array.vec2_dynamic_write_dynamic_loop_read
ES3-CTS.shaders.indexing.varying_array.vec2_dynamic_write_dynamic_read
ES3-CTS.shaders.indexing.varying_array.vec2_dynamic_write_static_loop_read
ES3-CTS.shaders.indexing.varying_array.vec2_dynamic_write_static_read
ES3-CTS.shaders.indexing.varying_array.vec3_dynamic_loop_write_dynamic_loop_read
ES3-CTS.shaders.indexing.varying_array.vec3_dynamic_loop_write_dynamic_read
ES3-CTS.shaders.indexing.varying_array.vec3_dynamic_loop_write_static_loop_read
ES3-CTS.shaders.indexing.varying_array.vec3_dynamic_loop_write_static_read
ES3-CTS.shaders.indexing.varying_array.vec3_dynamic_write_dynamic_loop_read
ES3-CTS.shaders.indexing.varying_array.vec3_dynamic_write_dynamic_read
ES3-CTS.shaders.indexing.varying_array.vec3_dynamic_write_static_loop_read
ES3-CTS.shaders.indexing.varying_array.vec3_dynamic_write_static_read
ES3-CTS.shaders.indexing.varying_array.vec4_dynamic_loop_write_dynamic_loop_read
ES3-CTS.shaders.indexing.varying_array.vec4_dynamic_loop_write_dynamic_read
ES3-CTS.shaders.indexing.varying_array.vec4_dynamic_loop_write_static_loop_read
ES3-CTS.shaders.indexing.varying_array.vec4_dynamic_loop_write_static_read
ES3-CTS.shaders.indexing.varying_array.vec4_dynamic_write_dynamic_loop_read
ES3-CTS.shaders.indexing.varying_array.vec4_dynamic_write_dynamic_read
ES3-CTS.shaders.indexing.varying_array.vec4_dynamic_write_static_loop_read
ES3-CTS.shaders.indexing.varying_array.vec4_dynamic_write_static_read
ES3-CTS.shaders.struct.local.array_member_dynamic_index_vertex
ES3-CTS.shaders.struct.local.dynamic_loop_nested_struct_array_vertex
ES3-CTS.shaders.struct.local.dynamic_loop_struct_array_vertex
ES3-CTS.shaders.struct.local.nested_struct_array_dynamic_index_vertex
ES3-CTS.shaders.struct.local.struct_array_dynamic_index_vertex

Bisect shows:af13cf609f4257768ad8b80be8cec7f2e6ca8c81 is the first bad commit
commit af13cf609f4257768ad8b80be8cec7f2e6ca8c81
Author:     Kenneth Graunke <kenneth@whitecape.org>
AuthorDate: Sun Aug 10 20:06:44 2014 -0700
Commit:     Kenneth Graunke <kenneth@whitecape.org>
CommitDate: Tue Aug 12 13:39:25 2014 -0700

    i965/vec4: Use MOV, not OR, to set URB write channel mask bits.

    g0.5 has nothing of value to contribute to m0.5.  In both the VS and GS
    payload, g0.5 contains the scratch space pointer - which is definitely
    not of any use.  The GS payload also contains FFTID, but the URB write
    message header doesn't want FFTID.

    The only reason I used OR was because Eric originally requested it.
    On Broadwell, I used MOV, and that's worked out fine.

    Signed-off-by: Kenneth Graunke <kenneth@whitecape.org>
    Reviewed-by: Chris Forbes <chrisf@ijw.co.nz>
    Reviewed-by: Matt Turner <mattst88@gmail.com>

run  ./glcts --deqp-case=ES3-CTS.shaders.indexing.matrix_subscript.mat2x4_static_write_dynamic_loop_read_vertex
output:
dEQP Core GL-CTS-2.0 (0x0052484b) starting..
  target implementation = 'X11'

Test case 'ES3-CTS.shaders.indexing.matrix_subscript.mat2x4_static_write_dynamic_loop_read_vertex'..
Vertex compile time = 0.413000 ms
Fragment compile time = 0.156000 ms
Link time = 0.556000 ms
  Fail (Fail)

DONE!

Test run totals:
  Passed:        0/1 (0.00%)
  Failed:        1/1 (100.00%)
  Not supported: 0/1 (0.00%)
  Warnings:      0/1 (0.00%)


Reproduce steps:
-------------------------
1. xinit
2. ./glcts --deqp-case=ES3-CTS.shaders.indexing.matrix_subscript.mat2x4_static_write_dynamic_loop_read_vertex
Comment 1 Kenneth Graunke 2014-08-15 00:48:57 UTC
Reverted on master.
Comment 2 Matt Turner 2014-08-15 05:02:47 UTC
(In reply to comment #1)
> Reverted on master.

Forgot to push?
Comment 3 Kenneth Graunke 2014-08-15 06:21:28 UTC
Yep, sorry.  Pushed for real now.
Comment 4 lu hua 2014-08-18 02:32:36 UTC
Verified.Fixed.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.