Bug 82852 - Segfault with Mesa 10.3.0-devel (git-cd765cf)
Summary: Segfault with Mesa 10.3.0-devel (git-cd765cf)
Status: RESOLVED DUPLICATE of bug 82828
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/Gallium/r300 (show other bugs)
Version: git
Hardware: x86 (IA32) Linux (All)
: medium normal
Assignee: Default DRI bug account
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-08-20 08:56 UTC by Piero Finizio
Modified: 2014-08-20 17:01 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Piero Finizio 2014-08-20 08:56:22 UTC
I get segfault with some OpenGL applications, Second Life, Ipers, Racer but not with others as Gears, Quake III demo...
For example this is the backtrace of Second life viewer:

Program received signal SIGSEGV, Segmentation fault.
0xb328ec5b in ra_allocate () from /usr/local/lib/dri/r300_dri.so
Missing separate debuginfos, use: debuginfo-install atk-2.10.0-1.fc20.i686 cairo-1.13.1-0.1.git337ab1f.fc20.i686 dbus-glib-0.100.2-2.fc20.i686 dbus-libs-1.6.12-9.fc20.i686 fontconfig-2.11.0-2.fc20.i686 freetype-freeworld-2.5.0.1-4.fc20.i686 gdk-pixbuf2-2.30.3-1.fc20.i686 glib2-2.38.2-2.fc20.i686 glibc-2.18-12.fc20.i686 gtk2-2.24.22-2.fc20.i686 harfbuzz-0.9.27-1.fc20.i686 json-c-0.11-6.fc20.i686 libICE-1.0.8-6.fc20.i686 libSM-1.2.1-6.fc20.i686 libX11-1.6.1-1.fc20.i686 libXau-1.0.8-2.fc20.i686 libXcomposite-0.4.4-4.fc20.i686 libXcursor-1.1.14-2.fc20.i686 libXdamage-1.1.4-4.fc20.i686 libXext-1.3.2-2.fc20.i686 libXfixes-5.0.1-2.fc20.i686 libXi-1.7.4-1.fc20.i686 libXinerama-1.1.3-2.fc20.i686 libXrandr-1.4.1-2.fc20.i686 libXrender-0.9.8-2.fc20.i686 libXtst-1.2.2-2.fc20.i686 libXxf86vm-1.1.3-2.fc20.i686 libasyncns-0.8-6.fc20.i686 libattr-2.4.47-3.fc20.i686 libcap-2.22-7.fc20.i686 libffi-3.0.13-5.fc20.i686 libgcc-4.8.3-1.fc20.i686 libgcrypt-1.5.3-2.fc20.i686 libgpg-error-1.12-1.fc20.i686 libpng-1.6.6-3.fc20.i686 libselinux-2.2.1-6.fc20.i686 libstdc++-4.8.3-1.fc20.i686 libtxc_dxtn-1.0.0-3.fc19.i686 libuuid-2.24.2-1.fc20.i686 libxcb-1.9.1-3.fc20.i686 llvm-libs-3.4-6.fc20.i686 mesa-libGLU-9.0.0-5.fc20.i686 ncurses-libs-5.9-12.20130511.fc20.i686 nss-softokn-freebl-3.16.2-1.fc20.i686 pango-1.36.1-3.fc20.i686 pcre-8.33-6.fc20.i686 pixman-0.30.0-5.fc20.i686 pulseaudio-libs-5.0-7.fc20.i686 systemd-libs-208-21.fc20.i686 tcp_wrappers-libs-7.6-76.fc20.i686 xz-libs-5.1.2-12alpha.fc20.i686 zlib-1.2.8-3.fc20.i686
(gdb) bt
#0  0xb328ec5b in ra_allocate () from /usr/local/lib/dri/r300_dri.so
#1  0xb347c66e in rc_pair_regalloc () from /usr/local/lib/dri/r300_dri.so
#2  0xb346fa80 in rc_run_compiler_passes () from /usr/local/lib/dri/r300_dri.so
#3  0xb346fb44 in rc_run_compiler () from /usr/local/lib/dri/r300_dri.so
#4  0xb3483581 in r3xx_compile_fragment_program () from /usr/local/lib/dri/r300_dri.so
#5  0xb345b2e1 in r300_translate_fragment_shader () from /usr/local/lib/dri/r300_dri.so
#6  0xb345c332 in r300_pick_fragment_shader () from /usr/local/lib/dri/r300_dri.so
#7  0xb34678d0 in r300_update_derived_state () from /usr/local/lib/dri/r300_dri.so
#8  0xb345e0cc in r300_draw_vbo () from /usr/local/lib/dri/r300_dri.so
#9  0xb33a7f92 in u_vbuf_draw_vbo () from /usr/local/lib/dri/r300_dri.so
#10 0xb333577a in cso_draw_vbo () from /usr/local/lib/dri/r300_dri.so
#11 0xb324bb0a in st_draw_vbo () from /usr/local/lib/dri/r300_dri.so
#12 0xb321bcc0 in vbo_handle_primitive_restart () from /usr/local/lib/dri/r300_dri.so
#13 0xb321d4ac in vbo_validated_drawrangeelements () from /usr/local/lib/dri/r300_dri.so
#14 0xb321d8fb in vbo_exec_DrawRangeElementsBaseVertex ()
   from /usr/local/lib/dri/r300_dri.so
#15 0xb321d9ff in vbo_exec_DrawRangeElements () from /usr/local/lib/dri/r300_dri.so
#16 0x096fe641 in LLVertexBuffer::drawRange(unsigned int, unsigned int, unsigned int, unsigned int, unsigned int) const ()
#17 0x086b425c in LLDrawPoolBump::pushBatch(LLDrawInfo&, unsigned int, int, int) ()
#18 0x086bbc7f in LLDrawPoolBump::renderBump(unsigned int, unsigned int) ()
#19 0x086bbe1c in LLDrawPoolBump::renderBump(unsigned int) ()
#20 0x086bc1d2 in LLDrawPoolBump::render(int) ()
#21 0x091d3cc2 in LLPipeline::renderGeom(LLCamera&, int) ()
#22 0x08f17f5d in display(int, float, int, int) ()
#23 0x0855743f in LLAppViewer::mainLoop() ()
#24 0x0846ec0c in main ()

Hardware:
Processor: Intel Core Duo T2350 @ 1.86GHz (2 Cores), Motherboard: ASUS F3JP v1.0, Chipset: Intel Mobile 945GM/PM/GMS + ICH7-M, Memory: 2 x 1024 MB SDRAM, Disk: 120GB Hitachi HTS54161, Graphics: ASUS AMD Mobility Radeon X1700 256MB, Audio: Intel NM10/ICH7, Network: Realtek RTL8111/8168/8411 + Intel PRO/Wireless

Software:
OS: Fedora 20, Kernel: 3.15.10-200.fc20.i686 (i686), Desktop: KDE 4.13.3, Display Server: X Server 1.14.4, Display Driver: radeon 7.4.99, OpenGL: 2.1 Mesa 10.3.0-devel (git-cd765cf) Gallium 0.4, Compiler: GCC 4.8.3 20140624 + LLVM 3.4, File-System: ext4, Screen Resolution: 1280x800

Hardware:
Processor: Intel Core Duo T2350 @ 1.86GHz (2 Cores), Motherboard: ASUS F3JP v1.0, Chipset: Intel Mobile 945GM/PM/GMS + ICH7-M, Memory: 2 x 1024 MB SDRAM, Disk: 120GB Hitachi HTS54161, Graphics: ASUS AMD Mobility Radeon X1700 256MB, Audio: Intel NM10/ICH7, Network: Realtek RTL8111/8168/8411 + Intel PRO/Wireless

Software:
OS: Fedora 20, Kernel: 3.15.10-200.fc20.i686 (i686), Desktop: KDE 4.13.3, Display Server: X Server 1.14.4, Display Driver: radeon 7.4.99, OpenGL: 2.1 Mesa 10.3.0-devel (git-cd765cf) Gallium 0.4, Compiler: GCC 4.8.3 20140624 + LLVM 3.4, File-System: ext4, Screen Resolution: 1280x800
Comment 1 Alex Deucher 2014-08-20 13:47:18 UTC
Is this a regression?  If so, can you bisect?
Comment 2 Piero Finizio 2014-08-20 16:18:54 UTC
Yes it is a regression, on 2.1 Mesa 10.3.0-devel (git-3b48f6a) all works as expected but this was compiled against kernel-3.15.9-200.fc20. Now I will try with this kernel and in case to bisect.
Thanks.
Comment 3 Tom Stellard 2014-08-20 17:01:25 UTC

*** This bug has been marked as a duplicate of bug 82828 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.