Bug 82912 - radeon doesn't detect R 5 kaveri chipset
Summary: radeon doesn't detect R 5 kaveri chipset
Status: RESOLVED FIXED
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/Radeon (show other bugs)
Version: unspecified
Hardware: x86-64 (AMD64) Linux (All)
: medium major
Assignee: Default DRI bug account
QA Contact:
URL:
Whiteboard:
Keywords:
: 83630 (view as bug list)
Depends on:
Blocks:
 
Reported: 2014-08-21 14:24 UTC by sean darcy
Modified: 2014-09-08 21:28 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
Xorg.0.log (34.82 KB, text/plain)
2014-08-21 14:24 UTC, sean darcy
no flags Details
dmesg (75.32 KB, text/plain)
2014-08-21 15:52 UTC, sean darcy
no flags Details
lspci -nn (2.95 KB, text/plain)
2014-08-21 15:53 UTC, sean darcy
no flags Details

Description sean darcy 2014-08-21 14:24:52 UTC
Created attachment 105046 [details]
Xorg.0.log

I'm on an Acer Aspire laptop, AMD A8-7100 Radeon R 5. Fedora 20.

xorg-x11-drv-ati-7.2.0-3.20131101git3b38701.fc20.x86_64

All the firmware seems to be installed:

BONAIRE_ce.bin
BONAIRE_mc2.bin
BONAIRE_mc.bin
BONAIRE_me.bin
BONAIRE_mec.bin
BONAIRE_pfp.bin
BONAIRE_rlc.bin
BONAIRE_sdma.bin
BONAIRE_smc.bin
BONAIRE_uvd.bin
BONAIRE_vce.bin
KAVERI_ce.bin
KAVERI_me.bin
KAVERI_mec.bin
KAVERI_pfp.bin
KAVERI_rlc.bin
KAVERI_sdma.bin


00:01.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Kaveri [Radeon R5 Graphics]

All the modules are loaded:

drm_kms_helper         52500  1 radeon
drm                   289961  3 ttm,drm_kms_helper,radeon
i2c_core               55486  6 drm,i2c_piix4,drm_kms_helper,i2c_algo_bit,radeon,videodev

But I can't load dri since /dev/dri/card0 isn't created. And /class/sys/drm/card0 doesn't exist.

X falls back to the framebuffer.

It seems like the driver/module just doesn't recognize the chipset!

sean
Comment 1 Alex Deucher 2014-08-21 14:27:17 UTC
Please attach your dmesg output and lspci -nn output.
Comment 2 sean darcy 2014-08-21 15:52:22 UTC
Created attachment 105052 [details]
dmesg
Comment 3 sean darcy 2014-08-21 15:53:23 UTC
Created attachment 105053 [details]
lspci -nn
Comment 5 sean darcy 2014-08-23 17:16:53 UTC
Thanks. 

Now I hope Fedora picks it up for an F20 kernel and not wait for 3.17 !
Comment 6 Alex Deucher 2014-09-08 21:26:46 UTC
*** Bug 83630 has been marked as a duplicate of this bug. ***
Comment 7 Alex Deucher 2014-09-08 21:28:05 UTC
All patches are committed.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.