Bug 83031 - [IVB/BDW]Piglit spec_ARB_buffer_storage_bufferstorage-persistent_read_coherent_client-storage sporadically fail
Summary: [IVB/BDW]Piglit spec_ARB_buffer_storage_bufferstorage-persistent_read_coheren...
Status: RESOLVED FIXED
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i965 (show other bugs)
Version: unspecified
Hardware: All Linux (All)
: medium normal
Assignee: Ian Romanick
QA Contact: Intel 3D Bugs Mailing List
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-08-25 02:43 UTC by lu hua
Modified: 2015-07-31 09:56 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description lu hua 2014-08-25 02:43:49 UTC
System Environment:
--------------------------
Platform: IVB
Libdrm:		(master)libdrm-2.4.56-10-g22b995d8cbf1059535c5de5ba1869c1623ae5b08
Mesa:		(master)8d8a5eb792c662a8def7c9ab65d2df67972cf659
Xserver:	(master)xorg-server-1.15.99.902-121-g2f5cf9ff9a0f713b7e038636484c77f113a5f10a
Xf86_video_intel:(master)2.99.914-67-g12c051d5c673d79c16a3a1478c0977799484ca95
Libva:		(master)acfcd5f0637a951d50c5112c7dfbd46f1d0dcdb3
Libva_intel_driver:(master)f3f49f2f0e6b3669d9b09341a11cf0b96e138674
Kernel:   (drm-intel-nightly)257d90d13794c2eb545ab0d6c708f21e2a0378b6

Bug detailed description:
---------------------------
It sporadically fails on IVB with mesa master and 10.3 branch. fail rate:4/5

output:
[root@x-ivb9 piglit]# bin/bufferstorage-persistent read coherent client-storage -fbo -auto
Probe [0] failed. Expected: 17.000000  Observed: 0.000000
Probe [1] failed. Expected: 13.000000  Observed: 0.000000
Probe [3] failed. Expected: 17.000000  Observed: 0.000000
Probe [4] failed. Expected: 18.000000  Observed: 0.000000
Probe [6] failed. Expected: 12.000000  Observed: 0.000000
Probe [7] failed. Expected: 13.000000  Observed: 0.000000
Probe [9] failed. Expected: 12.000000  Observed: 0.000000
Probe [10] failed. Expected: 18.000000  Observed: 0.000000
Probe [12] failed. Expected: 27.000000  Observed: 0.000000
Probe [13] failed. Expected: 13.000000  Observed: 0.000000
PIGLIT: {"result": "fail" }
[root@x-ivb9 piglit]# bin/bufferstorage-persistent read coherent client-storage -fbo -auto
PIGLIT: {"result": "pass" }
[root@x-ivb9 piglit]# bin/bufferstorage-persistent read coherent client-storage -fbo -auto
Probe [0] failed. Expected: 17.000000  Observed: 0.000000
Probe [1] failed. Expected: 13.000000  Observed: 0.000000
Probe [3] failed. Expected: 17.000000  Observed: 0.000000
Probe [4] failed. Expected: 18.000000  Observed: 0.000000
Probe [6] failed. Expected: 12.000000  Observed: 0.000000
Probe [7] failed. Expected: 13.000000  Observed: 0.000000
Probe [9] failed. Expected: 12.000000  Observed: 0.000000
Probe [10] failed. Expected: 18.000000  Observed: 0.000000
Probe [12] failed. Expected: 27.000000  Observed: 0.000000
PIGLIT: {"result": "fail" }
[root@x-ivb9 piglit]# bin/bufferstorage-persistent read coherent client-storage -fbo -auto
Probe [0] failed. Expected: 17.000000  Observed: 0.000000
Probe [1] failed. Expected: 13.000000  Observed: 0.000000
Probe [3] failed. Expected: 17.000000  Observed: 0.000000
Probe [4] failed. Expected: 18.000000  Observed: 0.000000
Probe [6] failed. Expected: 12.000000  Observed: 0.000000
Probe [7] failed. Expected: 13.000000  Observed: 0.000000
Probe [9] failed. Expected: 12.000000  Observed: 0.000000
Probe [10] failed. Expected: 18.000000  Observed: 0.000000
Probe [12] failed. Expected: 27.000000  Observed: 0.000000
PIGLIT: {"result": "fail" }
[root@x-ivb9 piglit]# bin/bufferstorage-persistent read coherent client-storage -fbo -auto
Probe [0] failed. Expected: 17.000000  Observed: 0.000000
Probe [1] failed. Expected: 13.000000  Observed: 0.000000
Probe [3] failed. Expected: 17.000000  Observed: 0.000000
PIGLIT: {"result": "fail" }


Reproduce steps:
-------------------------
1. xinit
2. bin/bufferstorage-persistent read coherent client-storage -fbo -auto
Comment 1 lu hua 2014-08-25 07:30:17 UTC
spec_ARB_buffer_storage_bufferstorage-persistent_read_coherent also sporadically fails.
Comment 2 lu hua 2014-08-26 02:02:42 UTC
spec_ARB_buffer_storage_bufferstorage-persistent_read_coherent and 
spec_ARB_buffer_storage_bufferstorage-persistent_read_coherent_client-storage also sporadically fail on BDW.
Comment 3 Samuel Iglesias Gonsálvez 2015-06-29 07:59:00 UTC
I cannot reproduce it on my IVB laptop and mesa master branch. I am running the piglit test inside a infinite loop in bash for several minutes but the test always passes.

Mesa master branch HEAD: 6218c68bece0cea671f2940a651119a87ab8b24e
OpenGL vendor string: Intel Open Source Technology Center
OpenGL renderer string: Mesa DRI Intel(R) Ivybridge Mobile 
OpenGL core profile version string: 3.3 (Core Profile) Mesa 10.7.0-devel (git-6218c68)
OpenGL core profile shading language version string: 3.30

Is it still reproducible on your systems?
Comment 4 Iago Toral 2015-07-13 13:31:05 UTC
(In reply to Samuel Iglesias from comment #3)
> I cannot reproduce it on my IVB laptop and mesa master branch. I am running
> the piglit test inside a infinite loop in bash for several minutes but the
> test always passes.
> 
> Mesa master branch HEAD: 6218c68bece0cea671f2940a651119a87ab8b24e
> OpenGL vendor string: Intel Open Source Technology Center
> OpenGL renderer string: Mesa DRI Intel(R) Ivybridge Mobile 
> OpenGL core profile version string: 3.3 (Core Profile) Mesa 10.7.0-devel
> (git-6218c68)
> OpenGL core profile shading language version string: 3.30
> 
> Is it still reproducible on your systems?

Same here, also with an IvyBridge laptop: 100% pass ratio after 30 attempts for both tests with current master.
Comment 5 lu hua 2015-07-15 05:48:11 UTC
Christophe, 
Does this issue still happens on your machines?
Comment 6 Tapani Pälli 2015-07-31 09:56:05 UTC
I also run this in a loop for 3000 times on IVB (mesa git-fdb8487), passes consistently. Therefore marking as fixed.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.