Bug 83046 - [BDW bisected]] Warsow v1.0/Xonotic v0.7/Gputest v0.5_triangle_fullscreen/synmark2_v6/GLBenchmark v2.5.0/GLBenchmark v2.7.0/Ungine-demos performance reduced 30%~60%
Summary: [BDW bisected]] Warsow v1.0/Xonotic v0.7/Gputest v0.5_triangle_fullscreen/syn...
Status: VERIFIED FIXED
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i965 (show other bugs)
Version: unspecified
Hardware: All Linux (All)
: high major
Assignee: Kristian Høgsberg
QA Contact: Intel 3D Bugs Mailing List
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-08-25 08:56 UTC by zhoujian
Modified: 2014-09-09 06:50 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments
Attempt to fix the scaledown rectangle (873 bytes, patch)
2014-09-05 05:41 UTC, Kenneth Graunke
Details | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description zhoujian 2014-08-25 08:56:14 UTC
Platform: BDW
----------------------------------------------
Libdrm: (master)libdrm-2.4.56-10-g22b995d8cbf1059535c5de5ba1869c1623ae5b08
Mesa: (master)8d8a5eb792c662a8def7c9ab65d2df67972cf659
Xserver: (master)xorg-server-1.15.99.902-121-g2f5cf9ff9a0f713b7e038636484c77f113a5f10a
Xf86_video_intel: (master)2.99.914-67-g12c051d5c673d79c16a3a1478c0977799484ca95
Cairo: (master)13a09526d2120c244471e03b6ae979016ef88e83
Libva: (master)acfcd5f0637a951d50c5112c7dfbd46f1d0dcdb3
Libva_intel_driver: (master)f3f49f2f0e6b3669d9b09341a11cf0b96e138674
Kernel: (drm-intel-nightly)257d90d13794c2eb545ab0d6c708f21e2a0378b6

Bug detailed description:
-----------------------------------------------
Warsow v1.0/Xonotic v0.7/Gputest v0.5_triangle_fullscreen/synmark2_v6(OglBatch0-OglBatch7/OglGeomPoint) performance reduced 30%~60% on BDW, This issue only exist on BDW, this issue exist both on Raw X and gnome-session.
It’s Mesa regression, bisecting show that the first bad commit is:
commit 2f28a0dc23165123cf1e8b5942acad37878edd8a
Author:     Kristian Høgsberg <krh@bitplanet.net>
AuthorDate: Mon Jul 7 16:44:58 2014 -0700
Commit:     Kristian Høgsberg <krh@bitplanet.net>
CommitDate: Fri Aug 15 11:25:47 2014 -0700
    i965: Implement fast color clears using meta operations


Reproduce steps:
---------------------------------------------
1. xinit&
2. ./synmark2 OglBatch0
Comment 1 zhoujian 2014-09-04 05:30:45 UTC
This first bad commit(git-2f28a0d) also effect GLBenchmark v2.5.0/GLBenchmark v2.7.0/Ungine-demos performance reduced on BDW.
Comment 2 Eero Tamminen 2014-09-04 08:45:28 UTC
According to the test data, the performance drop was largest for GLbenchmark 2.7 T-Rex & Egypt tests, nearly 60% for onscreen tests, nearly 70% for offscreen tests.

Note: data isn't very accurate because X DRI3 was broken around that time so the gap between useful numbers was over week, i.e. there might be also other changes included to that.
Comment 3 Kenneth Graunke 2014-09-05 05:41:03 UTC
Created attachment 105777 [details] [review]
Attempt to fix the scaledown rectangle

The resolve rectangle scaledown factor appears to be wrong.  (The fast clear rectangle looks fine - just the resolve is wrong.)  See 3D > Pixel > Pixel Backend [IVB+] > Render Target Resolve [IVB+].

The attached patch tries to work around it.  With that patch, EgyptHD performance goes up by 2.75x to the expected speed (the one I see when using repdata clears only).

Unfortunately, I'm not physically in the same location as my Broadwell machine's monitor right now, so I can't watch and see if the rendering is correct or not.  But it does pass Piglit.
Comment 4 Kristian Høgsberg 2014-09-06 03:51:16 UTC
Patch reviewed, double checked the spec and pushed as 2d6d3461d307636b61d0f483677aaad11d1fd42a.
Comment 5 zhoujian 2014-09-09 06:50:04 UTC
Verified it,Verified the commit is git-dc0bd79


bug/show.html.tmpl processed on Feb 24, 2017 at 15:06:29.
(provided by the Example extension).