Bug 83124 - [IVB+]Piglit spec_ARB_explicit_uniform_location_linker_set-location-to-sampler fails
Summary: [IVB+]Piglit spec_ARB_explicit_uniform_location_linker_set-location-to-sample...
Status: VERIFIED DUPLICATE of bug 82921
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i965 (show other bugs)
Version: unspecified
Hardware: All Linux (All)
: medium normal
Assignee: Tapani Pälli
QA Contact: Intel 3D Bugs Mailing List
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-08-27 05:48 UTC by lu hua
Modified: 2015-06-16 08:38 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description lu hua 2014-08-27 05:48:07 UTC
System Environment:
--------------------------
Platform: BYT
Libdrm:		(master)libdrm-2.4.56-11-g391bba9c4cd2825eadaa648df10e3d1c99c66e80
Mesa:		(master)01887593a424824426eda75ff90b5e2a49876e86
Xserver:(master)xorg-server-1.15.99.902-121-g2f5cf9ff9a0f713b7e038636484c77f113a5f10a
Xf86_video_intel:(master)2.99.914-68-gd209b03915e4d12ce445d72ac09bb4fe664ba664
Libva:		(master)acfcd5f0637a951d50c5112c7dfbd46f1d0dcdb3
Libva_intel_driver:(master)f3f49f2f0e6b3669d9b09341a11cf0b96e138674
Kernel:   (drm-intel-nightly)d82af52b1766594ece621e427f1604194ca2b415

bug detailed description:
---------------------------
It fails on IVB+ platforms with mesa master and 10.3 branch. It's new case.

output:
Failed to compile FS: 0:3(1): error: location(s) consumed by uniform tex >= MAX_UNIFORM_LOCATIONS (65536)

PIGLIT: {"result": "fail" }

Reproduce steps:
----------------------------
1. xinit
2. bin/shader_runner tests/spec/arb_explicit_uniform_location/linker/set-location-to-sampler.shader_test -auto
Comment 1 Tapani Pälli 2014-08-28 08:07:13 UTC
this is the same as bug #82921
Comment 2 Tapani Pälli 2014-09-17 08:32:35 UTC

*** This bug has been marked as a duplicate of bug 82921 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.