Bug 83234 - Opening Steam crashes X session
Summary: Opening Steam crashes X session
Status: RESOLVED FIXED
Alias: None
Product: xorg
Classification: Unclassified
Component: Server/Ext/GLX (show other bugs)
Version: git
Hardware: x86-64 (AMD64) Linux (All)
: medium major
Assignee: Xorg Project Team
QA Contact: Xorg Project Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-08-29 08:52 UTC by Maciej
Modified: 2014-09-01 01:24 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
dmesg (60.98 KB, text/plain)
2014-08-29 08:52 UTC, Maciej
no flags Details
Xorg.0.log (70.61 KB, text/plain)
2014-08-29 08:52 UTC, Maciej
no flags Details

Description Maciej 2014-08-29 08:52:22 UTC
Created attachment 105418 [details]
dmesg

Instantly after opening Steam X crashes. OpenGL apps work fine, tested with Unigine Heaven (64 bit) and Xonotic (32 and 64bit).
Comment 1 Maciej 2014-08-29 08:52:42 UTC
Created attachment 105419 [details]
Xorg.0.log
Comment 2 Maciej 2014-08-29 08:53:40 UTC
Forgot to add, system is Ubuntu 14.10.
Comment 3 smoki 2014-08-29 10:16:21 UTC
 Just a guess but this might be duplicate of bug 78604 as xserver 1.15 can crash with gcc libraries steam provide.
Comment 4 Maciej 2014-08-30 16:55:50 UTC
Yep, update to xserver 1.16 solved this. Hopefully xserver update will and in 14.10 before release.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.