Bug 83384 - [PNV Bisected]Piglit glslparsertest_CorrectFunction.vert timeout
Summary: [PNV Bisected]Piglit glslparsertest_CorrectFunction.vert timeout
Status: VERIFIED DUPLICATE of bug 83463
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i915 (show other bugs)
Version: unspecified
Hardware: x86 (IA32) Linux (All)
: high normal
Assignee: Ian Romanick
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on: 83463
Blocks:
  Show dependency treegraph
 
Reported: 2014-09-02 06:36 UTC by lu hua
Modified: 2015-06-16 08:40 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description lu hua 2014-09-02 06:36:43 UTC
System Environment:
--------------------------
Platform: PNV
Libdrm:	(master)libdrm-2.4.56-11-g391bba9c4cd2825eadaa648df10e3d1c99c66e80
Mesa:	(master)70691f0c283ec4e03523f3a4690d9b897b36872e
Xserver:(master)xorg-server-1.16.0-152-g3a51418b2db353519a1779cf3cebbcc9afba2520
Xf86_video_intel:(master)2.99.914-80-g2c564c04bcde88d730ca111acfb6798bdf0d66da
Libva:	(master)c356638098e55453d2fac8bbb92eafc8cc32d6f4
Libva_intel_driver:(master)f3f49f2f0e6b3669d9b09341a11cf0b96e138674
Kernel:   (drm-intel-nightly)6e9c5b9d428bb075293ec865ba58f90931187a48

Bug detailed description:
---------------------------
Run it on PNV with mesa master branch 20 minutes, it doesn't exit testing. It happens on Mesa master branch, doesn't happen on 10.3 branch.
Bisect shows: 8f890b119eaff88a7fad64abbf183cbcc22edc7a is the first bad commit
commit 8f890b119eaff88a7fad64abbf183cbcc22edc7a
Author:     Abdiel Janulgue <abdiel.janulgue@linux.intel.com>
AuthorDate: Thu Jun 19 22:15:14 2014 -0700
Commit:     Abdiel Janulgue <abdiel.janulgue@linux.intel.com>
CommitDate: Sun Aug 31 21:04:08 2014 +0300

    glsl: Optimize clamp(x, 0, 1) as saturate(x)

    v2: - Check that the base type is float (Ian Romanick)
    v3: - Make sure comments reflect that we are doing a commutative operation
        - Add missing condition where the inner constant is 1.0 and outer consta
        - Make indexing of operands easier to read (Matt Turner)

    Reviewed-by: Matt Turner <mattst88@gmail.com>
    Reviewed-by: Ian Romanick <ian.d.romanick@intel.com>
    Signed-off-by: Abdiel Janulgue <abdiel.janulgue@linux.intel.com>

output:
# time bin/glslparsertest /GFX/Test/Piglit/piglit/tests/glslparsertest/shaders/CorrectFunction.vert pass 1.10
libGL error: Version 4 or later of flush extension not found
libGL error: failed to load driver: i915
^C

real    20m48.107s
user    20m45.785s
sys     0m1.962s

Reproduce steps:
-------------------------
1. xinit
2. bin/glslparsertest tests/glslparsertest/shaders/CorrectFunction.vert pass 1.10
Comment 1 lu hua 2014-09-02 08:01:56 UTC
Following cases also have this issue due to same bisect commit.
shaders_glsl-vs-clamp-1
shaders_glsl-vs-inline-explosion
shaders_glsl-vs-raytrace-bug26691
spec_glsl-1.10_execution_built-in-functions_vs-smoothstep-float-float-float
spec_glsl-1.10_execution_built-in-functions_vs-smoothstep-float-float-vec2
spec_glsl-1.10_execution_built-in-functions_vs-smoothstep-float-float-vec3
spec_glsl-1.10_execution_built-in-functions_vs-smoothstep-float-float-vec4
spec_glsl-1.10_execution_built-in-functions_vs-smoothstep-vec2-vec2-vec2
spec_glsl-1.10_execution_built-in-functions_vs-smoothstep-vec3-vec3-vec3
spec_glsl-1.10_execution_built-in-functions_vs-smoothstep-vec4-vec4-vec4
spec_glsl-1.10_execution_vs-saturate-exp2
spec_glsl-1.10_execution_vs-saturate-pow
spec_glsl-1.10_execution_vs-saturate-sqrt
Comment 2 lu hua 2014-09-15 06:26:51 UTC
Following ES2 cases also are timeout with same bisect commit:
ES2-CTS.gtf.GL.smoothstep.smoothstep_float_vert_xvary_edgeconstquarter
ES2-CTS.gtf.GL.smoothstep.smoothstep_vec2_vert_xvary_edgeconstquarter
ES2-CTS.gtf.GL.smoothstep.smoothstep_vec3_vert_xvary_edgeconstquarter
ES2-CTS.gtf.GL2FixedTests.buffer_objects.buffer_objects
ES2-CTS.gtf.GL2FixedTests.lighting_diffuse.lighting_diffuse
Comment 3 Abdiel Janulgue 2014-10-30 10:27:04 UTC
This issue the same as https://bugs.freedesktop.org/show_bug.cgi?id=83463. I've got a fix for it, I'll post it on the list as soon as I tidy it up a bit.
Comment 4 Abdiel Janulgue 2014-11-28 09:30:20 UTC

*** This bug has been marked as a duplicate of bug 83463 ***
Comment 5 lu hua 2014-12-10 01:15:32 UTC
It works well on latest mesa master branch, still happens on mesa 10.4 branch.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.