Bug 83580 - Blender game engine "Motion Blur" filter doesn't work
Summary: Blender game engine "Motion Blur" filter doesn't work
Status: RESOLVED MOVED
Alias: None
Product: Mesa
Classification: Unclassified
Component: Other (show other bugs)
Version: 10.2
Hardware: x86-64 (AMD64) Linux (All)
: medium major
Assignee: mesa-dev
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-09-07 09:35 UTC by khalidsrri
Modified: 2019-09-18 20:17 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments
Test file with Motion Blur (480.21 KB, text/plain)
2014-09-07 09:35 UTC, khalidsrri
Details
apitrace (154.68 KB, application/x-xz)
2014-09-07 15:03 UTC, Benjamin Bellec
Details

Note You need to log in before you can comment on or make changes to this bug.
Description khalidsrri 2014-09-07 09:35:57 UTC
Created attachment 105854 [details]
Test file with Motion Blur

Hi ,

I use both Windows 7 and Ubuntu 14.04
I have a problem with "Motion blur" in the Blender game engine

After I asked Blender Community they told me that may be there are a problem with Accumulation buffer (glAccum function) , Which necessary for this feature to work

I tested it in three different Blender version , but doesn't work .

it worked very well in Win7 and in another computer with Linux Mint and different Graphical card

GPU : Intel HD
CPU : Intel Celeron P4600

There are a .blend file attached with Motion Blur filter
To test it open the file and press P
Comment 1 Benjamin Bellec 2014-09-07 15:03:10 UTC
Created attachment 105860 [details]
apitrace

I attached an apitrace for easier debugging purpose.
Comment 2 Kenneth Graunke 2014-09-07 21:45:00 UTC
Looks like Blender picked a visual with no accumulation buffer for some reason, then tried to use it.  We advertise a few with accumulation buffers, so I'm not sure why it didn't pick one of those.

That said, accumulation buffers are going to be terribly slow (software rasterized, IIRC) on i965, and that's not likely to be fixed any time soon.

It would be great if Blender would move away from these legacy GL features...
Comment 3 GitLab Migration User 2019-09-18 20:17:34 UTC
-- GitLab Migration Automatic Message --

This bug has been migrated to freedesktop.org's GitLab instance and has been closed from further activity.

You can subscribe and participate further through the new bug through this link to our GitLab instance: https://gitlab.freedesktop.org/mesa/mesa/issues/907.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.