Bug 83704 - Xorg crashes on OpenGL applications like Chromium/Gwenview on Ivybridge Mobile
Summary: Xorg crashes on OpenGL applications like Chromium/Gwenview on Ivybridge Mobile
Status: RESOLVED INVALID
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i965 (show other bugs)
Version: 10.2
Hardware: x86-64 (AMD64) All
: medium critical
Assignee: Intel 3D Bugs Mailing List
QA Contact: Intel 3D Bugs Mailing List
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-09-10 09:36 UTC by exi+freedesktop
Modified: 2017-02-10 22:38 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments
gpu crash dump (2.19 MB, text/plain)
2014-09-10 09:36 UTC, exi+freedesktop
Details

Note You need to log in before you can comment on or make changes to this bug.
Description exi+freedesktop 2014-09-10 09:36:25 UTC
Created attachment 106035 [details]
gpu crash dump

When i start Chromium, sometimes Xorg crashes, sometimes Chromium crashes.
Same goes for other OpenGL applications like Steam or Gwenview.

Linux laptop1638 3.16.2-1-ARCH #1 SMP PREEMPT Sat Sep 6 13:12:51 CEST 2014 x86_64 GNU/Linux

Arch Linux Driver:
testing/xf86-video-intel 2.99.916-1 (xorg-drivers xorg) [installed]
    X.org Intel i810/i830/i915/945G/G965+ video drivers

OpenGL vendor string: Intel Open Source Technology Center
OpenGL renderer string: Mesa DRI Intel(R) Ivybridge Mobile 
OpenGL core profile version string: 3.3 (Core Profile) Mesa 10.2.7
OpenGL core profile shading language version string: 3.30
OpenGL core profile context flags: (none)
OpenGL core profile profile mask: core profile
OpenGL core profile extensions:
OpenGL version string: 3.0 Mesa 10.2.7
OpenGL shading language version string: 1.30
OpenGL context flags: (none)
OpenGL extensions:
OpenGL ES profile version string: OpenGL ES 3.0 Mesa 10.2.7
OpenGL ES profile shading language version string: OpenGL ES GLSL ES 3.0
OpenGL ES profile extensions:

GL_VERSION: 3.0 Mesa 10.2.7
GL_RENDERER: Mesa DRI Intel(R) Ivybridge Mobile

lspci:
00:02.0 VGA compatible controller: Intel Corporation 3rd Gen Core processor Graphics Controller (rev 09) (prog-if 00 [VGA controller])
        Subsystem: Lenovo Device 21f5
        Flags: bus master, fast devsel, latency 0, IRQ 45
        Memory at f0000000 (64-bit, non-prefetchable) [size=4M]
        Memory at e0000000 (64-bit, prefetchable) [size=256M]
        I/O ports at 6000 [size=64]
        Expansion ROM at <unassigned> [disabled]
        Capabilities: <access denied>
        Kernel driver in use: i915
        Kernel modules: i915

dmesg output on crash:
[ 7380.337430] [drm] stuck on render ring
[ 7380.338005] [drm] GPU HANG: ecode 0:0x85ffbffa, in chromium [2909], reason: Ring hung, action: reset
[ 7380.338008] [drm] GPU hangs can indicate a bug anywhere in the entire gfx stack, including userspace.
[ 7380.338009] [drm] Please file a _new_ bug report on bugs.freedesktop.org against DRI -> DRM/Intel
[ 7380.338010] [drm] drm/i915 developers can then reassign to the right component if it's not a kernel issue.
[ 7380.338011] [drm] The gpu crash dump is required to analyze gpu hangs, so please always attach it.
[ 7380.338012] [drm] GPU crash dump saved to /sys/class/drm/card0/error
[ 7382.339125] [drm] Enabling RC6 states: RC6 on, RC6p on, RC6pp off
[ 7386.315840] [drm] stuck on render ring
[ 7386.316422] [drm] GPU HANG: ecode 0:0x85ffbffa, in chromium [2909], reason: Ring hung, action: reset
[ 7388.317585] [drm] Enabling RC6 states: RC6 on, RC6p on, RC6pp off
Comment 1 exi+freedesktop 2014-09-10 09:47:31 UTC
I downgraded my Intel driver to 

xf86-video-intel 2.99.914-4

but the problem persists.
Sadly i am unable to downgrade my mesa package because ArchLinux does not hold old repository versions of it.
Comment 2 Matt Turner 2016-11-04 00:25:04 UTC
Please test a new version of Mesa (12 or 13) and mark as REOPENED
if you can reproduce and RESOLVED/* if you cannot reproduce.
Comment 3 Annie 2017-02-10 22:38:42 UTC
Dear Reporter,

This Mesa bug has been in the "NEEDINFO" status for over 60 days. I am closing this bug based on lack of response but feel free to reopen if resolution is still needed. Please ensure you're supplying the correct information as requested.

Thank you.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.