Bug 83807 - [965g] GPU hang in chrome
Summary: [965g] GPU hang in chrome
Status: RESOLVED DUPLICATE of bug 80568
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i965 (show other bugs)
Version: unspecified
Hardware: x86-64 (AMD64) Linux (All)
: medium blocker
Assignee: Ian Romanick
QA Contact: Intel 3D Bugs Mailing List
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-09-12 19:09 UTC by Annejan Jager
Modified: 2014-11-14 19:34 UTC (History)
2 users (show)

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Annejan Jager 2014-09-12 19:09:11 UTC
I'm running a stock Ubuntu14.04LTS on a Dell Inspiron laptop with Intel G965 graphics (resolution 1440 x 900).

What I found in /var/log/kern.log:
Sep  4 00:04:13 andries-Inspiron-1525 kernel: [10453.804218] [drm] stuck on render ring
Sep  4 00:04:13 andries-Inspiron-1525 kernel: [10453.804229] [drm] GPU crash dump saved to /sys/class/drm/card0/error
Sep  4 00:04:13 andries-Inspiron-1525 kernel: [10453.804232] [drm] GPU hangs can indicate a bug anywhere in the entire gfx stack, including userspace.
Sep  4 00:04:13 andries-Inspiron-1525 kernel: [10453.804234] [drm] Please file a _new_ bug report on bugs.freedesktop.org against DRI -> DRM/Intel
Sep  4 00:04:13 andries-Inspiron-1525 kernel: [10453.804237] [drm] drm/i915 developers can then reassign to the right component if it's not a kernel issu
e.
Sep  4 00:04:13 andries-Inspiron-1525 kernel: [10453.804239] [drm] The gpu crash dump is required to analyze gpu hangs, so please always attach it.
Sep  4 00:04:13 andries-Inspiron-1525 kernel: [10453.805253] [drm:i915_set_reset_status] *ERROR* render ring hung inside bo (0x3682000 ctx 0) at 0x36827f
c
Sep  4 00:04:13 andries-Inspiron-1525 kernel: [10454.316221] [drm:i915_reset] *ERROR* Failed to reset chip.
Sep  4 00:04:19 andries-Inspiron-1525 kernel: [10459.484984] Watchdog[2537]: segfault at 0 ip 00007f46261f69de sp 00007f4615ab7670 error 6 in chrome[7f46
220a0000+547d000]
Sep  4 00:04:23 andries-Inspiron-1525 kernel: [10464.252164] [drm:i915_gem_wait_for_error] *ERROR* Timed out waiting for the gpu reset to complete
Sep  4 00:04:23 andries-Inspiron-1525 kernel: [10464.320071] [drm] GMBUS [i915 gmbus vga] timed out, falling back to bit banging on pin 2
Sep  4 00:04:24 andries-Inspiron-1525 kernel: [10464.359285] ------------[ cut here ]------------
Sep  4 00:04:24 andries-Inspiron-1525 kernel: [10464.359345] WARNING: CPU: 0 PID: 1383 at /build/buildd/linux-3.13.0/drivers/gpu/drm/i915/intel_display.c
:922 assert_pll+0x68/0x70 [i915]()
Sep  4 00:04:24 andries-Inspiron-1525 kernel: [10464.359349] PLL state assertion failure (expected on, current off)
Sep  4 00:04:24 andries-Inspiron-1525 kernel: [10464.359351] Modules linked in: bnep rfcomm bluetooth snd_hda_codec_idt snd_hda_codec_hdmi binfmt_misc nf
sd auth_rpcgss nfs_acl nfs lockd sunrpc fscache hid_generic snd_hda_intel snd_hda_codec snd_hwdep snd_pcm usbhid r852 snd_page_alloc snd_seq_midi sm_comm
on snd_seq_midi_event lib80211_crypt_tkip snd_rawmidi i915 hid nand snd_seq dell_laptop dell_wmi wl(POF) sparse_keymap gpio_ich dcdbas parport_pc snd_seq
_device snd_timer nand_ecc coretemp joydev nand_bch bch nand_ids lib80211 drm_kms_helper drm cfg80211 snd mtd ppdev soundcore lp serio_raw i2c_algo_bit r
592 mac_hid lpc_ich wmi memstick parport video psmouse ahci libahci firewire_ohci sdhci_pci firewire_core sdhci crc_itu_t sky2
Sep  4 00:04:24 andries-Inspiron-1525 kernel: [10464.359412] CPU: 0 PID: 1383 Comm: upowerd Tainted: PF       W  O 3.13.0-35-generic #62-Ubuntu
Sep  4 00:04:24 andries-Inspiron-1525 kernel: [10464.359414] Hardware name: Dell Inc. Inspiron 1525                   /0U990C, BIOS A16 10/16/2008
Sep  4 00:04:24 andries-Inspiron-1525 kernel: [10464.359416]  0000000000000009 ffff880063aada00 ffffffff8171e320 ffff880063aada48
Sep  4 00:04:24 andries-Inspiron-1525 kernel: [10464.359421]  ffff880063aada38 ffffffff8106775d 0000000000000001 ffff8800694e0000
Sep  4 00:04:24 andries-Inspiron-1525 kernel: [10464.359425]  ffff880035e3e000 0000000000000001 0000000000000000 ffff880063aada98
Sep  4 00:04:24 andries-Inspiron-1525 kernel: [10464.359428] Call Trace:
Sep  4 00:04:24 andries-Inspiron-1525 kernel: [10464.359438]  [<ffffffff8171e320>] dump_stack+0x45/0x56

If you need more/different logs or data please let me know.
Comment 1 Matt Turner 2014-11-14 19:34:18 UTC

*** This bug has been marked as a duplicate of bug 80568 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct.