Bug 83871 - [SNB dri3] Football manager 2014 crashes on Steam
Summary: [SNB dri3] Football manager 2014 crashes on Steam
Status: RESOLVED FIXED
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i965 (show other bugs)
Version: unspecified
Hardware: All Linux (All)
: medium enhancement
Assignee: Intel 3D Bugs Mailing List
QA Contact: Intel 3D Bugs Mailing List
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-09-15 07:05 UTC by zhoujian
Modified: 2016-12-01 11:17 UTC (History)
5 users (show)

See Also:
i915 platform:
i915 features:


Attachments
dmesg.log (116.21 KB, text/plain)
2014-09-15 07:08 UTC, zhoujian
Details
football_output.log (78.68 KB, text/plain)
2014-09-15 07:08 UTC, zhoujian
Details
Xorg.0.log (15.15 KB, text/plain)
2014-09-15 07:09 UTC, zhoujian
Details

Note You need to log in before you can comment on or make changes to this bug.
Description zhoujian 2014-09-15 07:05:57 UTC
Platform:SNB
Libdrm:(master)libdrm-2.4.56-21-g8c2ae1695913990cbe6c6a8aa294f354eba33bd0
Mesa:(master)ca29c4c3b0e779909467c0739fc176c64a829142
Xserver:(master)xorg-server-1.16.0-176-gd3427717f2c6a473dc3d20631dff653e4e37228e
Xf86_video_intel:(master)2.99.916-39-g11444619457aa8121efc937291f1d944ac42265d
Cairo:(master)e691d242d592a8556e25659fb091a2031abee4c9
Libva:(master)e0d25ece01e7aba819c910e98c4fb4706cdab055
Libva_intel_driver:(master)238d8077705711036d62a6d536311def3ef35035
Kernel:(drm-intel-nightly)43df30da20447e2856b2761215ff274886a9f931

Bug detail description:
-------------------------------------
Steam Football manager 2014 crashes on SNB,This issue also exist on 2014Q3 release testing.
It's RAW X regression,because i have tried Mesa/Xserver/Xf86 branch,but can not found detail branch,so can't bisect it.
The fail log,you can see dmesg.log and Xorg.0.log and football_output.log.

Reproduce step:
-------------------------------------
1. xinit&
2. start steam
3. Click "PLAY"
Comment 1 zhoujian 2014-09-15 07:08:29 UTC
Created attachment 106301 [details]
dmesg.log
Comment 2 zhoujian 2014-09-15 07:08:56 UTC
Created attachment 106302 [details]
football_output.log
Comment 3 zhoujian 2014-09-15 07:09:25 UTC
Created attachment 106303 [details]
Xorg.0.log
Comment 4 meng 2014-11-26 04:25:40 UTC
The issue also exists on Mesa-10.4-rc1 testing.
Comment 5 meng 2014-11-26 04:31:04 UTC
The issue isn't a regression and it could be reproduced on 2014Q2 RC.
Comment 6 Eero Tamminen 2014-12-29 16:10:42 UTC
You seem to be testing with DRI3, does the issue happen also with DRI2?
Comment 7 meng 2014-12-30 02:29:59 UTC
(In reply to Eero Tamminen from comment #6)
> You seem to be testing with DRI3, does the issue happen also with DRI2?

Yes, after double check, it's DIR3 issue. Without dri3, the game work fine.
Comment 8 meng 2014-12-30 02:30:59 UTC
As dri3 is disable by default in Xf86_video_intel, so close it.
Comment 9 Gordon Jin 2014-12-30 03:25:10 UTC
Let's keep it open as DRI3 bug, and use Enhancement to show it's a disabled feature.
Comment 10 Eero Tamminen 2016-11-09 10:44:41 UTC
This is so old bug that it's likely been fixed in the meanwhile by fixes in multiple places in the graphics stack.  Or can it still be reproduced?
Comment 11 Jani Saarinen 2016-12-01 11:17:38 UTC
Lets close and re-open if still issue.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.