Bug 83990 - Use toytoolkit in a test for interactive window move
Summary: Use toytoolkit in a test for interactive window move
Status: RESOLVED MOVED
Alias: None
Product: Wayland
Classification: Unclassified
Component: weston (show other bugs)
Version: unspecified
Hardware: All All
: medium enhancement
Assignee: Wayland bug list
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: 83980
  Show dependency treegraph
 
Reported: 2014-09-17 12:58 UTC by Pekka Paalanen
Modified: 2018-06-08 23:53 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Pekka Paalanen 2014-09-17 12:58:03 UTC
Write a test, that:
1. creates a window with normal decorations using toytoolkit
2. check the window position via the test extension
3. sends fake input events
3.1. move the pointer over the window title bar
3.2. button down
3.3. move the pointer to another place
3.4. button up
4. check the window position via the test extension, that it moved correctly

This sounds simple, but requires one to write the infrastructure for using toytoolkit in tests, maybe change how wl_test pointer events are done, and add a way to query surface location.

For examples, see https://github.com/01org/wayland-fits for the test protocol and the weston plugin.

If bug #83987 is implemented, can also add screenshot based verification, which would make sure that toytoolkit draws decorations properly. But that opens a whole new road for adding tests.
Comment 1 Marek Chalupa 2014-10-24 16:09:19 UTC
Hi,

I noticed this bug a week ago. I have some patches for weston to use xdg-shell in tests. On these (well, on two of them xD) I built new patches that are using toytoolkit to create a test client.

It works, but from time to time some of the tests fails and I'm not sure if it is a bug in test-suite or somewhere else, so I'm not sending them to the list yet. For anyone who is interested the code is here:

https://github.com/mchalupa/weston/commits/ttkt

Will send it to the list when I know where the problem is.

Regards,
Marek
Comment 2 GitLab Migration User 2018-06-08 23:53:09 UTC
-- GitLab Migration Automatic Message --

This bug has been migrated to freedesktop.org's GitLab instance and has been closed from further activity.

You can subscribe and participate further through the new bug through this link to our GitLab instance: https://gitlab.freedesktop.org/wayland/weston/issues/53.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.