Bug 84221 - [BSW]Piglit spec_ARB_shader_atomic_counters_semantics fails
Summary: [BSW]Piglit spec_ARB_shader_atomic_counters_semantics fails
Status: VERIFIED DUPLICATE of bug 84777
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i965 (show other bugs)
Version: unspecified
Hardware: All Linux (All)
: medium normal
Assignee: Ian Romanick
QA Contact: Intel 3D Bugs Mailing List
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-09-23 06:11 UTC by lu hua
Modified: 2014-12-16 06:17 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description lu hua 2014-09-23 06:11:01 UTC
Bug detailed description:
---------------------------
It fails on BSW with mesa master branch, works well on BDW.
spec_ARB_shader_atomic_counters_unused-result also fails

output:
PIGLIT: {"subtest": {"Fragment shader atomic built-in semantics" : "pass"}}
PIGLIT: {"subtest": {"Vertex shader atomic built-in semantics" : "pass"}}
Probe color at (0,0)
  Expected: 4294967294 4294967294 4294967295 0
  Observed: 1056964608 1056964608 1056964608 1056964608
PIGLIT: {"subtest": {"Geometry shader atomic built-in semantics" : "fail"}}
PIGLIT: {"subtest": {"Tessellation control shader atomic built-in semantics" : "skip"}}
PIGLIT: {"subtest": {"Tessellation evaluation shader atomic built-in semantics" : "skip"}}
PIGLIT: {"result": "fail" }

Reproduce steps:
-------------------------
1. xinit
2. bin/arb_shader_atomic_counters-semantics -fbo -auto
Comment 1 Ben Widawsky 2014-11-24 18:40:09 UTC
Please retest with latest mesa master.
Comment 2 Ben Widawsky 2014-11-24 18:42:35 UTC
Please retest with latest master
Comment 3 lu hua 2014-11-25 06:21:17 UTC
Test on the latest Mesa master(commit: c88385603ae8d983314b736a9459bbf7d002cf11), it works well.

[root@x-bsw01 piglit]# bin/arb_shader_atomic_counters-semantics -fbo -auto
PIGLIT: {"subtest": {"Fragment shader atomic built-in semantics" : "pass"}}
PIGLIT: {"subtest": {"Vertex shader atomic built-in semantics" : "pass"}}
PIGLIT: {"subtest": {"Geometry shader atomic built-in semantics" : "pass"}}
PIGLIT: {"subtest": {"Tessellation control shader atomic built-in semantics" : "skip"}}
PIGLIT: {"subtest": {"Tessellation evaluation shader atomic built-in semantics" : "skip"}}
PIGLIT: {"result": "pass" }
Comment 4 lu hua 2014-11-25 06:21:34 UTC
Verified.Fixed.
Comment 5 lu hua 2014-11-26 07:40:58 UTC
Reopen it, retest on latest mesa master or mesa master c88385603ae8d9833, Run 10 cycles, it always fails. 
On automation testing, the result it unstable. 

[root@x-bsw01 piglit]# bin/arb_shader_atomic_counters-semantics -fbo -auto
PIGLIT: {"subtest": {"Fragment shader atomic built-in semantics" : "pass"}}
PIGLIT: {"subtest": {"Vertex shader atomic built-in semantics" : "pass"}}
Probe color at (0,0)
  Expected: 4294967294 4294967294 4294967295 0
  Observed: 1056964608 1056964608 1056964608 1056964608
PIGLIT: {"subtest": {"Geometry shader atomic built-in semantics" : "fail"}}
PIGLIT: {"subtest": {"Tessellation control shader atomic built-in semantics" : "skip"}}
PIGLIT: {"subtest": {"Tessellation evaluation shader atomic built-in semantics" : "skip"}}
PIGLIT: {"result": "fail" }
Comment 6 Ben Widawsky 2014-11-26 18:26:40 UTC
Are you certain nothing else has changed? It still passes for me, 10/10 times. Can you please retest, and make sure you haven't changed anything else.

bwidawsk@momoa ~/intel-gfx/piglit (master)$ for i in {1..10}; do
> ./bin/arb_shader_atomic_counters-semantics -fbo -auto | grep result
> done
PIGLIT: {"result": "pass" }
PIGLIT: {"result": "pass" }
PIGLIT: {"result": "pass" }
PIGLIT: {"result": "pass" }
PIGLIT: {"result": "pass" }
PIGLIT: {"result": "pass" }
PIGLIT: {"result": "pass" }
PIGLIT: {"result": "pass" }
PIGLIT: {"result": "pass" }
PIGLIT: {"result": "pass" }

bwidawsk@momoa ~/intel-gfx/piglit (master)$ glxinfo | grep version | grep git
OpenGL core profile version string: 3.3 (Core Profile) Mesa 10.5.0-devel (git-c883856)
OpenGL version string: 3.0 Mesa 10.5.0-devel (git-c883856)
OpenGL ES profile version string: OpenGL ES 3.0 Mesa 10.5.0-devel (git-c883856)
Comment 7 lu hua 2014-11-27 07:55:43 UTC
I am unable reproduce the pass now even though set same system environment. 
Test mesa c883856 or latest mesa 531feec9dc4.
Piglit commit: e878d7ea0b05e453b8dea2d16aecc368ad4e92a3

[root@x-bsw01 piglit]# glxinfo | grep version | grep git
OpenGL core profile version string: 3.3 (Core Profile) Mesa 10.5.0-devel (git-531feec)
OpenGL version string: 3.0 Mesa 10.5.0-devel (git-531feec)
OpenGL ES profile version string: OpenGL ES 3.0 Mesa 10.5.0-devel (git-531feec)

[root@x-bsw01 piglit]# bin/arb_shader_atomic_counters-semantics -fbo -auto
PIGLIT: {"subtest": {"Fragment shader atomic built-in semantics" : "pass"}}
PIGLIT: {"subtest": {"Vertex shader atomic built-in semantics" : "pass"}}
Probe color at (0,0)
  Expected: 4294967294 4294967294 4294967295 0
  Observed: 1056964608 1056964608 1056964608 1056964608
PIGLIT: {"subtest": {"Geometry shader atomic built-in semantics" : "fail"}}
PIGLIT: {"subtest": {"Tessellation control shader atomic built-in semantics" : "skip"}}
PIGLIT: {"subtest": {"Tessellation evaluation shader atomic built-in semantics" : "skip"}}
PIGLIT: {"result": "fail" }
Comment 8 Ben Widawsky 2014-12-04 04:09:08 UTC

*** This bug has been marked as a duplicate of bug 84777 ***
Comment 9 lu hua 2014-12-16 06:17:12 UTC
On latest Mesa master branch, it has bug 87258, test on commit 0d4272cd8e7c451, it works well. Close it.

root@x-bsw01:/GFX/Test/Piglit/piglit# bin/arb_shader_atomic_counters-semantics -fbo -auto
libGL: OpenDriver: trying /opt/X11R7/lib/dri/tls/i965_dri.so
libGL: OpenDriver: trying /opt/X11R7/lib/dri/i965_dri.so
PIGLIT: {"subtest": {"Fragment shader atomic built-in semantics" : "pass"}}
PIGLIT: {"subtest": {"Vertex shader atomic built-in semantics" : "pass"}}
PIGLIT: {"subtest": {"Geometry shader atomic built-in semantics" : "pass"}}
PIGLIT: {"subtest": {"Tessellation control shader atomic built-in semantics" : "skip"}}
PIGLIT: {"subtest": {"Tessellation evaluation shader atomic built-in semantics" : "skip"}}
PIGLIT: {"result": "pass" }


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.