Bug 84372 - [G965 OpenGL Video Playback] crash during opengl video playback
Summary: [G965 OpenGL Video Playback] crash during opengl video playback
Status: RESOLVED FIXED
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i965 (show other bugs)
Version: unspecified
Hardware: Other All
: medium normal
Assignee: Ian Romanick
QA Contact: Intel 3D Bugs Mailing List
URL:
Whiteboard:
Keywords:
: 85456 (view as bug list)
Depends on:
Blocks:
 
Reported: 2014-09-26 13:29 UTC by Ondrej Sury
Modified: 2015-08-22 19:39 UTC (History)
6 users (show)

See Also:
i915 platform:
i915 features:


Attachments
Xorg old log (34.50 KB, text/plain)
2014-09-26 13:29 UTC, Ondrej Sury
Details
Current Xorg.0.log after a crash (34.88 KB, text/plain)
2014-09-26 13:32 UTC, Ondrej Sury
Details
intel_reg_dumper output after a crash (180 bytes, text/plain)
2014-09-26 13:32 UTC, Ondrej Sury
Details
dmesg with boot debugging flag after a crash (123.22 KB, text/plain)
2014-09-26 13:39 UTC, Ondrej Sury
Details
Mpv stdout, Syslog and Dmesg info related to my crash 01052015 (4.39 KB, text/plain)
2015-05-01 21:09 UTC, Damiox
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ondrej Sury 2014-09-26 13:29:22 UTC
Created attachment 106921 [details]
Xorg old log

[Just a side note: I am filling this for second time since this bug can take whole xserver down if reproduced for second time]

Original reference: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=762809

2) System environment:
-- chipset: G965
-- system architecture: x86_64
-- xf86-video-intel/xserver/mesa/libdrm version: 2:2.21.15-2+b2/2:1.16.1-1/10.2.6-1/2.4.56-1
-- kernel version: 3.16-2-amd64
-- Linux distribution: Debian unstable
-- Machine or mobo model: ASUS Zenbook UX301LA
-- Display connector: miniDVI and internal display
3) Reproduce steps.

mpv -vo=opengl <anyvideo>.mp4

seek there and back and wait a while

VO: [opengl] 1920x1080 => 1920x1080 yuv420p

Failed to open BO for returned DRI2 buffer (1920x1200, dri2 back buffer, named 3).
This is likely a bug in the X Server that will lead to a crash soon.

Program received signal SIGSEGV, Segmentation fault.
0x00007fffdb3922c2 in ?? () from /usr/lib/x86_64-linux-gnu/dri/i965_dri.so

This usually takes gnome-shell down as well just after the crash
(but running mpv under gdb saves the gnome-shell):

[ 1275.925420] mpv[4877]: segfault at 24 ip 00007fb7cd4362c2 sp 00007fff2d8e70a8 error 4 in i965_dri.so[7fb7cd16e000+509000]
[ 1276.221832] gnome-shell[3713]: segfault at 3c ip 00007f51c06a0dab sp 00007fff8159cd10 error 4 in i965_dri.so[7f51c0338000+509000]

[ 5304.840249] mpv[8556]: segfault at 24 ip 00007f4f602fa2c2 sp 00007fff892874c8 error 4 in i965_dri.so[7f4f60032000+509000]
[ 5307.309253] gnome-shell[4939]: segfault at 3c ip 00007f5d9bc33dab sp 00007ffffcef4490 error 4 in i965_dri.so[7f5d9b8cb000+509000]

[10733.668937] mpv[24002]: segfault at 24 ip 00007f523676c2c2 sp 00007fffeb1a1a58 error 4 in i965_dri.so[7f52364a4000+509000]
[10734.277346] gnome-shell[8634]: segfault at 3c ip 00007fb8e572cdab sp 00007fffe1e60780 error 4 in i965_dri.so[7fb8e53c4000+509000]

[10864.277396] mpv[24354]: segfault at 24 ip 00007fd0fda8d2c2 sp 00007fffbd414988 error 4 in i965_dri.so[7fd0fd7c5000+509000]

If this bug is triggered for a second time it takes whole gnome down (only the Logout screen appears)

Full gdb trace with debugging symbols is attached to ref. debian bug: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=762809
Comment 1 Ondrej Sury 2014-09-26 13:32:25 UTC
Created attachment 106922 [details]
Current Xorg.0.log after a crash
Comment 2 Ondrej Sury 2014-09-26 13:32:46 UTC
Created attachment 106923 [details]
intel_reg_dumper output after a crash
Comment 3 Ondrej Sury 2014-09-26 13:39:43 UTC
Created attachment 106924 [details]
dmesg with boot debugging flag after a crash
Comment 4 Charles Lahaine 2014-10-15 06:52:49 UTC
I confirm the same bug happens on my laptop with Manjaro Linux installed.

1) System environment:
-- chipset: Intel 965GM
-- system architecture: x86_64
-- Software packages:
     xf86-video-intel 2.99.916-3
     xorg-server 1.16.1-1
     mesa 10.3.0-3
     libdrm 2.4.58-1
-- kernel version: 3.14.20-1-MANJARO
-- Linux distribution: Manjaro 0.8.10 UP11
-- Machine or mobo model: Gateway M-6804m
-- Display connector: HDMI and internal display
2) Reproduce steps:
   mpv -vo=opengl <anyvideo>.mkv
   Seek video playback.

DE is Gnome 3.12.2 and UXA accel method is enabled.

This bug should be considered severe as it makes the whole X.org server crash. I even had to power the machine off abruptly.
Comment 5 Charles Lahaine 2014-10-16 22:22:30 UTC
I checked and this bug only occurs on UXA acceleration method. It doesn't happen on SNA but SNA doesn't work well with my hardware. I haven't tested glamor yet.

This problem started after updating to

-- xorg-server v1.16.1
-- xf86-video-intel v2.99.916
-- mesa v10.3.0
Comment 6 Guillaume 2014-10-19 00:10:15 UTC
Hello,

Same issue with my laptop's intel card on debian testing:

unvanquished (ie a 3d game) crashes on 1st startup. the whole X server crashes on 2nd server.
logs show the following error:
Failed to open BO for returned DRI2 buffer (1366x768, dri2 back buffer, named 9).

- linux 3.16-2-amd64
- mesa 10.2.8-1
- libdrm 2.4.58-2
- xserver-xorg-core 1.16.1-1
- xserver-xorg-video-intel 2.21.15-2+b2
- gnome-shell 3.14.0
- unvanquished 0.32.0

Guillame
Comment 7 Guillaume 2014-10-19 00:11:38 UTC
Also, enabling SNA as follows prevent the crash for me:

# cat /etc/X11/xorg.conf.d/20-intel.conf 
Section "Device"
    Identifier  "Intel Graphics"
    Driver      "intel"
    Option      "AccelMethod"  "sna"
    Option      "TearFree"    "true"
EndSection
Comment 8 Jonathan 2014-11-01 03:51:19 UTC
*** Bug 85456 has been marked as a duplicate of this bug. ***
Comment 9 Charles Lahaine 2015-01-23 09:41:46 UTC
Problem still happens on

- linux 3.17.8-1
- mesa 10.4.2-1
- libdrm 2.4.58-1
- xorg-server 1.16.3-2
- xf86-video-intel 2.99.917-1
- gnome-shell 3.14.3-2

I found out something strange though: there is *no* crash when using external monitor via HDMI, even with UXA enabled.
Comment 10 Charles Lahaine 2015-01-23 11:44:23 UTC
(In reply to Charles Lahaine from comment #9)
> I found out something strange though: there is *no* crash when using
> external monitor via HDMI, even with UXA enabled.

CORRECTION: mpv doesn't crash only if external monitor is set to max HD resolution 1920x1080. If using a lower res like 1280x720, crash happens again.
Comment 11 Charles Lahaine 2015-01-23 13:18:16 UTC
(In reply to Charles Lahaine from comment #10)
> CORRECTION: mpv doesn't crash only if external monitor is set to max HD
> resolution 1920x1080. If using a lower res like 1280x720, crash happens
> again.

Forget about it, it still crashes no matter what.
Comment 12 Charles Lahaine 2015-01-24 20:52:19 UTC
I confirm X server also crashes with mplayer -vo gl <somevideo>.mkv
Comment 13 varlesh 2015-03-14 01:03:13 UTC
Problem not solved. Segfault with UXA when playng any file in MPV. Also problem with game Urban Terror.
OS: Manjaro Gnome-Shell x86_64
Kernel: Linux 3.16.7
GPU: Intel HD4000
MPV 0.8.2.3
xf86-video-intel2.99.917
mesa  10.4.6

DMESG:
[ 1003.997288] mpv/vo[1579]: segfault at 3c ip 00007ff345ad6fcc sp 00007ff34668d8a0 error 4 in i965_dri.so[7ff345725000+53e000]
[ 1004.677577] gnome-shell[764]: segfault at 208 ip 00007fca2381326d sp 00007fff1172b270 error 4 in i965_dri.so[7fca234a4000+53e000]
[ 1142.475611] mpv/vo[1820]: segfault at 3c ip 00007efee6fa6fcc sp 00007efee7b5d8a0 error 4 in i965_dri.so[7efee6bf5000+53e000]
[ 1143.120250] gnome-shell[1599]: segfault at 208 ip 00007fd86bc0626d sp 00007ffe503819c0 error 4 in i965_dri.so[7fd86b897000+53e000]

If use SNA or GLAMOR Gnome working bad. System braking - animation, response applications etc! UXA working better, but crashing :(
Sorry my English.
Comment 14 Damiox 2015-05-01 21:09:32 UTC
Created attachment 115505 [details]
Mpv stdout, Syslog and Dmesg info related to my crash 01052015
Comment 15 Damiox 2015-05-01 21:11:52 UTC
Hi. I'm experiencing the same issue. Attached you'll find the mpv stdout, syslog and dmesg info.
I'm using Gnome 3.14.2 with Debian Jessie (current updated stable).
Linux 3.16.0-4-amd64 
Processor i5-3320M 
Intel HD 4000 Graphics

It's happening in Gnome3. I can't reproduce it with XFCE.
Comment 16 Charles Lahaine 2015-05-20 09:13:18 UTC
I filled a new bug report here:

https://bugzilla.gnome.org/show_bug.cgi?id=749621
Comment 17 Charles Lahaine 2015-05-20 09:28:56 UTC
Problem persists with

- linux 4.0.3-1-MANJARO
- mesa 10.5.5-1
- libdrm 2.4.61-1
- xorg-server 1.17.1-5
- xf86-video-intel 2.99.917-5
- gnome-shell 3.16.2-1
Comment 18 Guillaume 2015-05-20 20:13:09 UTC
unvanquished no longer crashes on my machine, following a fix done by the unvanquished developers:

https://github.com/Unvanquished/Unvanquished/issues/591

However I still observe crashes on the same machine while playing a 720p video using mpv.
Comment 19 Charles Lahaine 2015-07-13 01:26:28 UTC
Problem seems to be fixed with:

- linux 4.0.6-1
- xf86-video-intel 2.99.917+364+gb24e758-1
- xorg-server 1.17.2-1
- mesa 10.6.0-1
- libdrm 2.4.61-1

Can anyone else confirm this?
Comment 20 saintger 2015-08-22 18:48:46 UTC
On Debian Jessie, I can confirm that upgrading xserver-xorg-video-intel from the version in stable (2.21.15-2+b2) to the version in backports (2.21.15-2+b2) is solving the problem.
Comment 21 saintger 2015-08-22 18:49:45 UTC
Sorry, copy-paste mistake :

On Debian Jessie, I can confirm that upgrading xserver-xorg-video-intel from the version in stable (2.21.15-2+b2) to the version in backports (2.99.917-2~bpo8+1 0) is solving the problem.
Comment 22 Matt Turner 2015-08-22 19:39:24 UTC
Thanks for testing!


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.