Bug 84529 - [IVB bisected] glean fragProg1 CMP test failed
Summary: [IVB bisected] glean fragProg1 CMP test failed
Status: RESOLVED FIXED
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i965 (show other bugs)
Version: git
Hardware: Other All
: medium normal
Assignee: Jason Ekstrand
QA Contact: Intel 3D Bugs Mailing List
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-09-30 20:32 UTC by Ian Romanick
Modified: 2014-10-27 17:25 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ian Romanick 2014-09-30 20:32:57 UTC
On my IVB system,

$ bin/glean -o -v -v -v -t +fragProg1 --quick 
----------------------------------------------------------------------
Fragment Program test 1: test a specific set of fragment programs.

FAILURE:
  Program: CMP test
  Expected color: 0, 0.25, 1, 0
  Observed color: 0.501961, 0.25098, 1, 0.501961
fragProg1:  FAIL rgba8, db, z24, s8, win+pmap, id 33
	52 tests passed, 1 tests failed.


git-bisect says:

2999f83bd987fd53e2348ceb887dc2d40096c813 is the first bad commit
commit 2999f83bd987fd53e2348ceb887dc2d40096c813
Author: Jason Ekstrand <jason.ekstrand@intel.com>
Date:   Sat Aug 16 11:38:07 2014 -0700

    i965/fs: Derive force_uncompressed from instruction exec_size
    
    Signed-off-by: Jason Ekstrand <jason.ekstrand@intel.com>
    Reviewed-by: Matt Turner <mattst88@gmail.com>

:040000 040000 9c30b7bc6ea456e2943cf98e823f77675b0d0585 d1bd4f70e1fc027455e0ef8ee2317786206c5ee9 M	src
Comment 1 Jason Ekstrand 2014-09-30 21:41:59 UTC
How about latest master?  There were some bugs in the first push that I fixed a couple hours later.
Comment 2 Ian Romanick 2014-09-30 22:19:49 UTC
I was testing on 408aa46c.  There are a couple commits since then on master, but both are in the freedreno driver.  Re-testing at cc355f1c had no change.
Comment 3 Jason Ekstrand 2014-10-01 00:50:37 UTC
I think I found the bug and sent a patch to the list that should fix it.  Let me know if it does.
Comment 4 lu hua 2014-10-08 03:03:32 UTC
I can reproduce it on (master)16b53005a7df4249fecb6641af0934c32181fdea
FAILURE:
  Program: CMP test
  Expected color: 0, 0.25, 1, 0
  Observed color: 0, 0, 0, 0
fragProg1:  FAIL rgba8, db, z24, s8, win+pmap, id 32
        0 tests passed, 1 tests failed.
Comment 5 Matt Turner 2014-10-26 04:57:08 UTC
Perhaps fixed now?
Comment 6 Ian Romanick 2014-10-27 17:25:31 UTC
Works here.


bug/show.html.tmpl processed on Mar 25, 2017 at 07:47:40.
(provided by the Example extension).