Bug 8458 - nv driver doesn't support multiple outputs on a single device
Summary: nv driver doesn't support multiple outputs on a single device
Status: RESOLVED DUPLICATE of bug 5190
Alias: None
Product: xorg
Classification: Unclassified
Component: Driver/nVidia (open) (show other bugs)
Version: 7.1 (2006.05)
Hardware: x86 (IA32) Linux (All)
: high normal
Assignee: Xorg Project Team
QA Contact: Xorg Project Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-09-29 05:13 UTC by Marijn Schouten
Modified: 2007-03-09 13:07 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Marijn Schouten 2006-09-29 05:13:45 UTC
When I tried to set up my xinerama xorg.conf it would fail when using the nv 
driver but work fine with nvidia proprietary driver. The error message 
generated is not very helpful at all. From what I've glanced here and there nv 
doesn't support xinerama on a single device.
Comment 1 Alan Coopersmith 2006-09-29 10:06:58 UTC
Do you mean that it doesn't support multiple outputs on a single device?
That's not Xinerama - Xinerama is merely a mechanism for making multiple
screens act as one logical screen, so "doesn't support xinerama on a single 
device" doesn't make sense. 
Comment 2 Marijn Schouten 2006-09-29 10:08:51 UTC
>Do you mean that it doesn't support multiple outputs on a single device?

yes, that is what I meant.
Comment 3 Marijn Schouten 2006-10-17 03:39:54 UTC
as the proprietary nvidia driver probably suffers from unacceptable security 
holes(http://kerneltrap.org/node/7228) I'd really like to use the free software 
driver. But because the free software driver doesn't support the two outputs on 
my 7900GT I cannot use both my screens. I want to know if anyone is working on 
this or how difficult it would be to add such support myself.

PS. Please change the NEEDINFO status
Comment 4 Alan Coopersmith 2006-10-17 08:28:58 UTC
Clearing the NEEDINFO since the questions from comment #1 were answered in #2.
(This will mark the bug as ASSIGNED even though I doubt anyone is actually 
 working on this since I don't think anyone outside nVidia has the necessary 
 information to do so without reverse engineering.)
Comment 5 Marijn Schouten 2006-10-17 09:11:04 UTC
I've already sent a complaint to nvidia.

What kind of info is needed for making the nv driver multihead capable?
Comment 6 Daniel Stone 2007-02-27 01:33:46 UTC
Sorry about the phenomenal bug spam, guys.  Adding xorg-team@ to the QA contact so bugs don't get lost in future.
Comment 7 Aaron Plattner 2007-03-09 13:07:17 UTC

*** This bug has been marked as a duplicate of bug 5190 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.