Bug 84596 - [hsw] mpv GPU hang
Summary: [hsw] mpv GPU hang
Status: RESOLVED FIXED
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i965 (show other bugs)
Version: unspecified
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Intel 3D Bugs Mailing List
QA Contact: Intel 3D Bugs Mailing List
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-10-02 13:05 UTC by Christian Benke
Modified: 2018-06-06 10:08 UTC (History)
2 users (show)

See Also:
i915 platform:
i915 features:


Attachments
[drm] GPU crash dump saved to /sys/class/drm/card0/error (2.81 MB, text/plain)
2014-10-02 13:05 UTC, Christian Benke
Details
GPU HANG in google-chrome (2.89 MB, text/plain)
2014-11-04 19:59 UTC, Christian Benke
Details
GPU crash dump - Ring hung, action: reset (2.69 MB, text/plain)
2015-07-23 11:50 UTC, Christian Benke
Details
Crash dump (GPU HANG: ecode 7:0:0x85dffffc, in factorio [15259], reason: Ring hung, action: reset) (3.08 MB, text/plain)
2017-04-24 21:51 UTC, Christian Benke
Details
GPU crash dump (3.08 MB, text/plain)
2017-07-13 12:50 UTC, Christian Benke
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Christian Benke 2014-10-02 13:05:44 UTC
Created attachment 107224 [details]
[drm] GPU crash dump saved to /sys/class/drm/card0/error

On my new Zotac ID92 i experience frequent freezes of the graphic output which last for a few seconds, usually when the GPU is under a bit of load, like playing a movie, using Chrome (Particulary when using the integrated flashplayer) or playing a game. 

The problem is reproducable and i can provide additional crash dumps if necessary.

Intel Haswell with HD Graphics 4600

# uname -ri
3.13.0-36-generic x86_64

# lsb_release -dc
Description:	Ubuntu 14.04.1 LTS
Codename:	trusty


# Xorg -version

X.Org X Server 1.15.1
Release Date: 2014-04-13
X Protocol Version 11, Revision 0
Build Operating System: Linux 3.2.0-61-generic x86_64 Ubuntu
Current Operating System: Linux id92 3.13.0-36-generic #63-Ubuntu SMP Wed Sep 3 21:30:07 UTC 2014 x86_64
Kernel command line: BOOT_IMAGE=/boot/vmlinuz-3.13.0-36-generic root=UUID=a49242bd-0ee4-4268-9f63-27622f3dee59 ro quiet splash vt.handoff=7
Build Date: 30 July 2014  12:21:54AM
xorg-server 2:1.15.1-0ubuntu2.1 (For technical support please see http://www.ubuntu.com/support) 
Current version of pixman: 0.30.2


From for the latest crash /var/log/syslog, the crash dump is attached:

Oct  2 14:35:06 id92 kernel: [18996.039017] [drm] stuck on render ring
Oct  2 14:35:06 id92 kernel: [18996.039689] [drm] GPU HANG: ecode 0:0x85dffffd, in mpv [11864], reason: Ring hung, action: reset
Oct  2 14:35:06 id92 kernel: [18996.039691] [drm] GPU hangs can indicate a bug anywhere in the entire gfx stack, including userspace.
Oct  2 14:35:06 id92 kernel: [18996.039691] [drm] Please file a _new_ bug report on bugs.freedesktop.org against DRI -> DRM/Intel
Oct  2 14:35:06 id92 kernel: [18996.039692] [drm] drm/i915 developers can then reassign to the right component if it's not a kernel issue.
Oct  2 14:35:06 id92 kernel: [18996.039693] [drm] The gpu crash dump is required to analyze gpu hangs, so please always attach it.
Oct  2 14:35:06 id92 kernel: [18996.039694] [drm] GPU crash dump saved to /sys/class/drm/card0/error
Oct  2 14:35:08 id92 kernel: [18998.039562] [drm] Enabling RC6 states: RC6 on, RC6p off, RC6pp off
Oct  2 14:41:18 id92 kernel: [19367.836656] perf samples too long (2523 > 2500), lowering kernel.perf_event_max_sample_rate to 50000
Comment 1 Christian Benke 2014-10-22 18:37:54 UTC
Having not gotten any response for a while - is there anything i can do to assist? Should i post the bug elsewhere (Intel?) or is this the right place to get some feedback?
Comment 2 Ian Romanick 2014-10-22 18:56:20 UTC
Have you tried disabling (or enabling) SNA?
Comment 3 Christian Benke 2014-11-04 19:59:44 UTC
Created attachment 108914 [details]
GPU HANG in google-chrome
Comment 4 Christian Benke 2014-11-04 20:01:44 UTC
Following your suggestion to disabling SNA, i switched from SNA to UXA and tested it for a few days now. 

A minute ago i had another GPU HANG with chrome:

Nov  4 20:51:52 id92 kernel: [24247.230004] [drm] stuck on render ring
Nov  4 20:51:52 id92 kernel: [24247.230718] [drm] GPU HANG: ecode 0:0x85dffdfd, in chrome [2388], reason: Ring hung, action: reset
...

I've attached the core-dump from this crash as chrome_error.dump
Comment 5 Christian Benke 2015-07-23 11:50:06 UTC
Created attachment 117315 [details]
GPU crash dump - Ring hung, action: reset

I still have the same issues in performance-intensive situations, like watching YouTube, heavy JS-load in Chrome, watching a hd-video with mpv or playing a round of kerbin space program. Here's the dmesg for the attached GPU crash dump watching a YouTube-video in Chrome:

[ 5847.844056] [drm] stuck on render ring
[ 5847.844730] [drm] GPU HANG: ecode 0:0x85dffffd, in Xorg [1361], reason: Ring hung, action: reset
[ 5847.844731] [drm] GPU hangs can indicate a bug anywhere in the entire gfx stack, including userspace.
[ 5847.844732] [drm] Please file a _new_ bug report on bugs.freedesktop.org against DRI -> DRM/Intel
[ 5847.844733] [drm] drm/i915 developers can then reassign to the right component if it's not a kernel issue.
[ 5847.844733] [drm] The gpu crash dump is required to analyze gpu hangs, so please always attach it.
[ 5847.844734] [drm] GPU crash dump saved to /sys/class/drm/card0/error
[ 5849.844477] [drm] Enabling RC6 states: RC6 on, RC6p off, RC6pp off
[ 6211.913151] [drm] stuck on render ring
[ 6211.913807] [drm] GPU HANG: ecode 0:0x85dffffd, in Xorg [1361], reason: Ring hung, action: reset
[ 6213.913761] [drm] Enabling RC6 states: RC6 on, RC6p off, RC6pp off
Comment 6 Christian Benke 2015-07-23 12:07:12 UTC
This issue has occured daily since I bought this machine in September 2014 (I use it for work and privately). I have learned to live with the freezes, but of course I would still like to see it gone. 

As a buyer of Intel hardware I believe I should get some support in this, so far there has been no feedback from Intel engineers in this bug-report. Could you at least tell me if this issue is going to be tackled at some point in the future?
Comment 7 Matt Turner 2016-11-03 02:07:49 UTC
(In reply to Christian Benke from comment #6)
> This issue has occured daily since I bought this machine in September 2014
> (I use it for work and privately). I have learned to live with the freezes,
> but of course I would still like to see it gone. 
> 
> As a buyer of Intel hardware I believe I should get some support in this, so
> far there has been no feedback from Intel engineers in this bug-report.
> Could you at least tell me if this issue is going to be tackled at some
> point in the future?

Sorry about that. You're totally right.

I use mpv daily on my HSW and I've never experienced similar problems. I have configured mpv to use OpenGL output and VAAPI hardware decoding (I believe this is what upstream recommends for Intel GPUs)

mattst88@macbook ~ % cat ~/.mpv/config
vo=opengl
hwdec=vaapi

At this point because no one investigated your bug in a timely manner, we need you to tell us if you can reproduce it with currently supported software.

Please test a new version of Mesa (12 or 13) and mark as REOPENED
if you can reproduce and RESOLVED/* if you cannot reproduce.
Comment 8 Annie 2017-02-10 22:38:34 UTC
Dear Reporter,

This Mesa bug has been in the "NEEDINFO" status for over 60 days. I am closing this bug based on lack of response but feel free to reopen if resolution is still needed. Please ensure you're supplying the correct information as requested.

Thank you.
Comment 9 Christian Benke 2017-02-15 13:02:23 UTC
I was not able to immediately update to Ubuntu 16.04.
I'm now running Mesa 11.2.0-1ubuntu2 (Default distribution package)

Unfortunately the issue persists:
> Feb 15 13:52:24 id92 kernel: [46118.068388] [drm] GPU HANG: ecode 7:0:0x85dffffd, in Xorg [1090], reason: Ring hung, action: reset

I've attached the crash dump.

Current system specs:

# uname -ri
4.4.0-62-generic x86_64

# lsb_release -dc
Description:	Ubuntu 16.04.1 LTS
Codename:	xenial


# Xorg -version

X.Org X Server 1.18.3
Release Date: 2016-04-04
X Protocol Version 11, Revision 0
Build Operating System: Linux 3.13.0-86-generic x86_64 Ubuntu
Current Operating System: Linux id92 4.4.0-62-generic #83-Ubuntu SMP Wed Jan 18 14:10:15 UTC 2017 x86_64
Kernel command line: BOOT_IMAGE=/@/boot/vmlinuz-4.4.0-62-generic root=UUID=e6961a40-b8cf-4121-b58e-5ff1e2231c8b ro rootflags=subvol=@ quiet splash vt.handoff=7
Build Date: 18 May 2016  01:07:07AM
xorg-server 2:1.18.3-1ubuntu2.2 (For technical support please see http://www.ubuntu.com/support) 
Current version of pixman: 0.33.6
	Before reporting problems, check http://wiki.x.org
	to make sure that you have the latest version.
Comment 10 Christian Benke 2017-02-15 13:09:51 UTC
Ok, that didn't work out as planned. Bugzilla's attachment.cgi was acting up, I rebooted but forgot to create a copy of the dump - so no error-dump of the latest incident :-(

I assume it will happen again and I'll add an crashdump next time.
Comment 11 Matt Turner 2017-02-15 17:16:29 UTC
(In reply to Christian Benke from comment #9)
> I was not able to immediately update to Ubuntu 16.04.
> I'm now running Mesa 11.2.0-1ubuntu2 (Default distribution package)
> 
> # uname -ri
> 4.4.0-62-generic x86_64

The Mesa version is three major releases ago, and the kernel is even older.

We simply cannot support these any more, especially given that they're not even the latest release from their respective stable branches. I suspect the libva video acceleration code is also equally old.

Please update Mesa, the kernel, and libva.
Comment 12 Matt Turner 2017-02-15 18:06:08 UTC
I asked an Ubuntu developer, and he said it looks like you haven't installed updates -- that mesa-12.0.6 should be directly available.

Beyond that, there are PPAs containing new kernels and Mesa:

http://kernel.ubuntu.com/~kernel-ppa/mainline/
https://launchpad.net/~ubuntu-x-swat/+archive/ubuntu/updates
Comment 13 Christian Benke 2017-02-15 20:38:48 UTC
Thanks, yeah, I installed Xenial just last weekend and didn't realized there was no upgrade during the installation-process.
Comment 14 Christian Benke 2017-04-24 21:49:02 UTC
I've no upgraded to the latest Intel-drivers, mesa and latest Ubuntu-kernel, I'll attach the crash dump after this comment.

$ uname -ri
4.4.0-75-generic x86_64

$ lsb_release -dc
Description:	Ubuntu 16.04.2 LTS
Codename:	xenial

$ glxinfo | grep "OpenGL version"
OpenGL version string: 3.0 Mesa 17.0.2

$ Xorg -version

X.Org X Server 1.18.4
Release Date: 2016-07-19
X Protocol Version 11, Revision 0
Build Operating System: Linux 4.4.0-45-generic x86_64 Ubuntu
Current Operating System: Linux id92 4.4.0-75-generic #96-Ubuntu SMP Thu Apr 20 09:56:33 UTC 2017 x86_64
Kernel command line: BOOT_IMAGE=/@/boot/vmlinuz-4.4.0-75-generic root=UUID=e6961a40-b8cf-4121-b58e-5ff1e2231c8b ro rootflags=subvol=@ quiet splash vt.handoff=7
Build Date: 02 November 2016  10:06:10PM
xorg-server 2:1.18.4-0ubuntu0.2 (For technical support please see http://www.ubuntu.com/support) 
Current version of pixman: 0.33.6
	Before reporting problems, check http://wiki.x.org
	to make sure that you have the latest version.

Crash-error-message from kern.log:

Apr 24 23:42:27 id92 kernel: [  930.650345] [drm] stuck on render ring
Apr 24 23:42:27 id92 kernel: [  930.651179] [drm] GPU HANG: ecode 7:0:0x85dffffc, in factorio [15259], reason: Ring hung, action: reset
Apr 24 23:42:27 id92 kernel: [  930.651180] [drm] GPU hangs can indicate a bug anywhere in the entire gfx stack, including userspace.
Apr 24 23:42:27 id92 kernel: [  930.651181] [drm] Please file a _new_ bug report on bugs.freedesktop.org against DRI -> DRM/Intel
Apr 24 23:42:27 id92 kernel: [  930.651181] [drm] drm/i915 developers can then reassign to the right component if it's not a kernel issue.
Apr 24 23:42:27 id92 kernel: [  930.651182] [drm] The gpu crash dump is required to analyze gpu hangs, so please always attach it.
Apr 24 23:42:27 id92 kernel: [  930.651183] [drm] GPU crash dump saved to /sys/class/drm/card0/error
Apr 24 23:42:27 id92 kernel: [  930.651263] ------------[ cut here ]------------
Apr 24 23:42:27 id92 kernel: [  930.651291] WARNING: CPU: 2 PID: 14583 at /var/lib/dkms/i915-4.6.3-4.4.0/1/build/drivers/gpu/drm/i915/intel_display.c:11385 intel_mmio_flip_work_func+0x45e/0x490 [i915]()
Apr 24 23:42:27 id92 kernel: [  930.651292] WARN_ON(__i915_wait_request(mmio_flip->req, mmio_flip->crtc->reset_counter, false, ((void *)0), &mmio_flip->i915->rps.mmioflips))
Apr 24 23:42:27 id92 kernel: [  930.651293] Modules linked in: ufs qnx4 hfsplus hfs minix ntfs msdos jfs xfs libcrc32c cpuid rfcomm rtsx_usb_ms memstick bnep input_leds hid_generic usbhid hid arc4 snd_hda_codec_hdmi intel_rapl x86_pkg_temp_thermal intel_powerclamp coretemp kvm_intel kvm irqbypass crct10dif_pclmul crc32_pclmul snd_seq_midi snd_seq_midi_event ghash_clmulni_intel snd_rawmidi snd_seq aesni_intel aes_x86_64 lrw gf128mul iwlmvm glue_helper ablk_helper snd_hda_codec_realtek cryptd mac80211 snd_hda_codec_generic snd_seq_device snd_hda_intel serio_raw snd_hda_codec iwlwifi snd_hda_core snd_hwdep btusb btrtl btbcm cfg80211 btintel lpc_ich bluetooth ir_xmp_decoder ir_lirc_codec lirc_dev snd_pcm ir_mce_kbd_decoder ir_sharp_decoder snd_timer shpchp ir_sanyo_decoder ir_sony_decoder ir_jvc_decoder mei_me mei ir_rc6_decoder snd ir_rc5_decoder ir_nec_decoder soundcore rc_rc6_mce ite_cir rc_core mac_hid parport_pc ppdev lp parport autofs4 btrfs xor rtsx_usb_sdmmc rtsx_usb raid6_pq psmouse i915(OE) i2c_algo_bit drm_kms_helper(OE) syscopyarea ahci sysfillrect libahci sysimgblt fb_sys_fops drm r8169 mii video fjes
Apr 24 23:42:27 id92 kernel: [  930.651339] CPU: 2 PID: 14583 Comm: kworker/2:11 Tainted: G           OE   4.4.0-75-generic #96-Ubuntu
Apr 24 23:42:27 id92 kernel: [  930.651340] Hardware name: ZOTAC ZBOX-ID92/ZBOX-IQ01/ZBOX-ID92/ZBOX-IQ01, BIOS B220P007 05/21/2014
Apr 24 23:42:27 id92 kernel: [  930.651361] Workqueue: events intel_mmio_flip_work_func [i915]
Apr 24 23:42:27 id92 kernel: [  930.651362]  0000000000000286 00000000dc6e2867 ffff8801f8d7fd20 ffffffff813f8493
Apr 24 23:42:27 id92 kernel: [  930.651364]  ffff8801f8d7fd68 ffffffffc021a0d0 ffff8801f8d7fd58 ffffffff81081302
Apr 24 23:42:27 id92 kernel: [  930.651366]  ffff8801b3bd6d80 ffff88019daf69c0 ffff88021bb3d200 0000000000000080
Apr 24 23:42:27 id92 kernel: [  930.651368] Call Trace:
Apr 24 23:42:27 id92 kernel: [  930.651371]  [<ffffffff813f8493>] dump_stack+0x63/0x90
Apr 24 23:42:27 id92 kernel: [  930.651375]  [<ffffffff81081302>] warn_slowpath_common+0x82/0xc0
Apr 24 23:42:27 id92 kernel: [  930.651377]  [<ffffffff8108139c>] warn_slowpath_fmt+0x5c/0x80
Apr 24 23:42:27 id92 kernel: [  930.651380]  [<ffffffff8102d66c>] ? __switch_to+0x1dc/0x5c0
Apr 24 23:42:27 id92 kernel: [  930.651398]  [<ffffffffc019ab1e>] intel_mmio_flip_work_func+0x45e/0x490 [i915]
Apr 24 23:42:27 id92 kernel: [  930.651401]  [<ffffffff8109a555>] process_one_work+0x165/0x480
Apr 24 23:42:27 id92 kernel: [  930.651402]  [<ffffffff8109a8bb>] worker_thread+0x4b/0x4c0
Apr 24 23:42:27 id92 kernel: [  930.651404]  [<ffffffff8109a870>] ? process_one_work+0x480/0x480
Apr 24 23:42:27 id92 kernel: [  930.651406]  [<ffffffff8109a870>] ? process_one_work+0x480/0x480
Apr 24 23:42:27 id92 kernel: [  930.651408]  [<ffffffff810a0be8>] kthread+0xd8/0xf0
Apr 24 23:42:27 id92 kernel: [  930.651409]  [<ffffffff810a0b10>] ? kthread_create_on_node+0x1e0/0x1e0
Apr 24 23:42:27 id92 kernel: [  930.651412]  [<ffffffff8183bd0f>] ret_from_fork+0x3f/0x70
Apr 24 23:42:27 id92 kernel: [  930.651414]  [<ffffffff810a0b10>] ? kthread_create_on_node+0x1e0/0x1e0
Apr 24 23:42:27 id92 kernel: [  930.651415] ---[ end trace d60fc0c2dccc171f ]---
Apr 24 23:42:27 id92 kernel: [  930.651420] ------------[ cut here ]------------
Apr 24 23:42:27 id92 kernel: [  930.651438] WARNING: CPU: 2 PID: 14582 at /var/lib/dkms/i915-4.6.3-4.4.0/1/build/drivers/gpu/drm/i915/intel_display.c:11385 intel_mmio_flip_work_func+0x45e/0x490 [i915]()
Apr 24 23:42:27 id92 kernel: [  930.651439] WARN_ON(__i915_wait_request(mmio_flip->req, mmio_flip->crtc->reset_counter, false, ((void *)0), &mmio_flip->i915->rps.mmioflips))
Apr 24 23:42:27 id92 kernel: [  930.651440] Modules linked in: ufs qnx4 hfsplus hfs minix ntfs msdos jfs xfs libcrc32c cpuid rfcomm rtsx_usb_ms memstick bnep input_leds hid_generic usbhid hid arc4 snd_hda_codec_hdmi intel_rapl x86_pkg_temp_thermal intel_powerclamp coretemp kvm_intel kvm irqbypass crct10dif_pclmul crc32_pclmul snd_seq_midi snd_seq_midi_event ghash_clmulni_intel snd_rawmidi snd_seq aesni_intel aes_x86_64 lrw gf128mul iwlmvm glue_helper ablk_helper snd_hda_codec_realtek cryptd mac80211 snd_hda_codec_generic snd_seq_device snd_hda_intel serio_raw snd_hda_codec iwlwifi snd_hda_core snd_hwdep btusb btrtl btbcm cfg80211 btintel lpc_ich bluetooth ir_xmp_decoder ir_lirc_codec lirc_dev snd_pcm ir_mce_kbd_decoder ir_sharp_decoder snd_timer shpchp ir_sanyo_decoder ir_sony_decoder ir_jvc_decoder mei_me mei ir_rc6_decoder snd ir_rc5_decoder ir_nec_decoder soundcore rc_rc6_mce ite_cir rc_core mac_hid parport_pc ppdev lp parport autofs4 btrfs xor rtsx_usb_sdmmc rtsx_usb raid6_pq psmouse i915(OE) i2c_algo_bit drm_kms_helper(OE) syscopyarea ahci sysfillrect libahci sysimgblt fb_sys_fops drm r8169 mii video fjes
Apr 24 23:42:27 id92 kernel: [  930.651477] CPU: 2 PID: 14582 Comm: kworker/2:10 Tainted: G        W  OE   4.4.0-75-generic #96-Ubuntu
Apr 24 23:42:27 id92 kernel: [  930.651478] Hardware name: ZOTAC ZBOX-ID92/ZBOX-IQ01/ZBOX-ID92/ZBOX-IQ01, BIOS B220P007 05/21/2014
Apr 24 23:42:27 id92 kernel: [  930.651496] Workqueue: events intel_mmio_flip_work_func [i915]
Apr 24 23:42:27 id92 kernel: [  930.651498]  0000000000000286 000000007257603f ffff8801ff7e3d20 ffffffff813f8493
Apr 24 23:42:27 id92 kernel: [  930.651500]  ffff8801ff7e3d68 ffffffffc021a0d0 ffff8801ff7e3d58 ffffffff81081302
Apr 24 23:42:27 id92 kernel: [  930.651502]  ffff8801b3bd6e40 ffff88019daf6b00 ffff88021bb3d200 0000000000000080
Apr 24 23:42:27 id92 kernel: [  930.651504] Call Trace:
Apr 24 23:42:27 id92 kernel: [  930.651507]  [<ffffffff813f8493>] dump_stack+0x63/0x90
Apr 24 23:42:27 id92 kernel: [  930.651510]  [<ffffffff81081302>] warn_slowpath_common+0x82/0xc0
Apr 24 23:42:27 id92 kernel: [  930.651513]  [<ffffffff8108139c>] warn_slowpath_fmt+0x5c/0x80
Apr 24 23:42:27 id92 kernel: [  930.651516]  [<ffffffff8102d8c7>] ? __switch_to+0x437/0x5c0
Apr 24 23:42:27 id92 kernel: [  930.651537]  [<ffffffffc019ab1e>] intel_mmio_flip_work_func+0x45e/0x490 [i915]
Apr 24 23:42:27 id92 kernel: [  930.651541]  [<ffffffff8109a555>] process_one_work+0x165/0x480
Apr 24 23:42:27 id92 kernel: [  930.651543]  [<ffffffff8109a8bb>] worker_thread+0x4b/0x4c0
Apr 24 23:42:27 id92 kernel: [  930.651546]  [<ffffffff8109a870>] ? process_one_work+0x480/0x480
Apr 24 23:42:27 id92 kernel: [  930.651548]  [<ffffffff810a0be8>] kthread+0xd8/0xf0
Apr 24 23:42:27 id92 kernel: [  930.651550]  [<ffffffff810a0b10>] ? kthread_create_on_node+0x1e0/0x1e0
Apr 24 23:42:27 id92 kernel: [  930.651555]  [<ffffffff8183bd0f>] ret_from_fork+0x3f/0x70
Apr 24 23:42:27 id92 kernel: [  930.651557]  [<ffffffff810a0b10>] ? kthread_create_on_node+0x1e0/0x1e0
Apr 24 23:42:27 id92 kernel: [  930.651561] ---[ end trace d60fc0c2dccc1720 ]---
Apr 24 23:42:27 id92 kernel: [  930.653266] drm/i915: Resetting chip after gpu hang
Comment 15 Christian Benke 2017-04-24 21:51:00 UTC
Created attachment 131007 [details]
Crash dump (GPU HANG: ecode 7:0:0x85dffffc, in factorio [15259], reason: Ring hung, action: reset)
Comment 16 Christian Benke 2017-04-24 21:56:21 UTC
$ vainfo
libva info: VA-API version 0.39.2
libva info: va_getDriverName() returns 0
libva info: Trying to open /usr/lib/x86_64-linux-gnu/dri/i965_drv_video.so
libva info: Found init function __vaDriverInit_0_39
libva info: va_openDriver() returns 0
vainfo: VA-API version: 0.39 (libva 1.7.1)
vainfo: Driver version: Intel i965 driver for Intel(R) Haswell Desktop - 1.7.1

Kernel is still at 4.0.4-75-generic - let me know if I need to update to 4.4.14 from the link you posted.
Comment 17 Christian Benke 2017-07-13 12:50:39 UTC
Created attachment 132663 [details]
GPU crash dump

Just had a GPU HANG while using Google Maps.

I've since upgraded my kernel:

$ uname -ri
4.4.14-040414-generic x86_64

$ lsb_release -dc
Description:	Ubuntu 16.04.2 LTS
Codename:	xenial

$ Xorg -version

X.Org X Server 1.18.4
Release Date: 2016-07-19
X Protocol Version 11, Revision 0
Build Operating System: Linux 4.4.0-45-generic x86_64 Ubuntu
Current Operating System: Linux id92 4.4.14-040414-generic #201606241434 SMP Fri Jun 24 18:36:45 UTC 2016 x86_64
Kernel command line: BOOT_IMAGE=/@/boot/vmlinuz-4.4.14-040414-generic root=UUID=e6961a40-b8cf-4121-b58e-5ff1e2231c8b ro rootflags=subvol=@ quiet splash i915.semaphores=1 vt.handoff=7
Build Date: 02 November 2016  10:06:10PM
xorg-server 2:1.18.4-0ubuntu0.2 (For technical support please see http://www.ubuntu.com/support) 
Current version of pixman: 0.33.6

$ vainfo
libva info: VA-API version 0.39.2
libva info: va_getDriverName() returns 0
libva info: Trying to open /usr/lib/x86_64-linux-gnu/dri/i965_drv_video.so
libva info: Found init function __vaDriverInit_0_39
libva info: va_openDriver() returns 0
vainfo: VA-API version: 0.39 (libva 1.7.1)
vainfo: Driver version: Intel i965 driver for Intel(R) Haswell Desktop - 1.7.1

$ glxinfo | grep "OpenGL version"
OpenGL version string: 3.0 Mesa 17.1.2


cat /var/log/kern.log
[..]
Jul 13 14:44:30 id92 kernel: [ 3434.855583] [drm] stuck on render ring
Jul 13 14:44:30 id92 kernel: [ 3434.856446] [drm] GPU HANG: ecode 7:0:0x87d7fefe, in chrome [2388], reason: Ring hung, action: reset
Jul 13 14:44:30 id92 kernel: [ 3434.856447] [drm] GPU hangs can indicate a bug anywhere in the entire gfx stack, including userspace.
Jul 13 14:44:30 id92 kernel: [ 3434.856448] [drm] Please file a _new_ bug report on bugs.freedesktop.org against DRI -> DRM/Intel
Jul 13 14:44:30 id92 kernel: [ 3434.856448] [drm] drm/i915 developers can then reassign to the right component if it's not a kernel issue.
Jul 13 14:44:30 id92 kernel: [ 3434.856449] [drm] The gpu crash dump is required to analyze gpu hangs, so please always attach it.
Jul 13 14:44:30 id92 kernel: [ 3434.856450] [drm] GPU crash dump saved to /sys/class/drm/card0/error
Jul 13 14:44:30 id92 kernel: [ 3434.856467] ------------[ cut here ]------------
Jul 13 14:44:30 id92 kernel: [ 3434.856498] WARNING: CPU: 1 PID: 7941 at /home/kernel/COD/linux/drivers/gpu/drm/i915/intel_display.c:11289 intel_mmio_flip_work_func+0x38e/0x3d0 [i915]()
Jul 13 14:44:30 id92 kernel: [ 3434.856500] WARN_ON(__i915_wait_request(mmio_flip->req, mmio_flip->crtc->reset_counter, false, NULL, &mmio_flip->i915->rps.mmioflips))
Jul 13 14:44:30 id92 kernel: [ 3434.856501] Modules linked in: uas usb_storage rfcomm rtsx_usb_ms memstick bnep input_leds arc4 intel_rapl x86_pkg_temp_thermal intel_powerclamp coretemp kvm_intel kvm snd_hda_codec_hdmi irqbypass btusb snd_hda_codec_realtek crct10dif_pclmul btrtl snd_hda_codec_generic crc32_pclmul btbcm btintel bluetooth aesni_intel snd_hda_intel snd_hda_codec aes_x86_64 iwlmvm snd_hda_core snd_hwdep mac80211 lrw gf128mul snd_pcm glue_helper ablk_helper cryptd snd_seq_midi snd_seq_midi_event iwlwifi snd_rawmidi snd_seq serio_raw ir_xmp_decoder ir_lirc_codec lirc_dev ir_mce_kbd_decoder ir_sharp_decoder cfg80211 ir_sanyo_decoder ir_sony_decoder ir_jvc_decoder ir_rc6_decoder snd_seq_device ir_nec_decoder ir_rc5_decoder snd_timer mei_me snd lpc_ich shpchp mei soundcore rc_rc6_mce ite_cir rc_core mac_hid hid_generic usbhid hid parport_pc ppdev lp parport autofs4 btrfs xor raid6_pq rtsx_usb_sdmmc rtsx_usb i915 i2c_algo_bit drm_kms_helper psmouse syscopyarea sysfillrect sysimgblt fb_sys_fops ahci drm libahci r8169 mii fjes video
Jul 13 14:44:30 id92 kernel: [ 3434.856543] CPU: 1 PID: 7941 Comm: kworker/1:0 Tainted: G     U          4.4.14-040414-generic #201606241434
Jul 13 14:44:30 id92 kernel: [ 3434.856544] Hardware name: ZOTAC ZBOX-ID92/ZBOX-IQ01/ZBOX-ID92/ZBOX-IQ01, BIOS B220P007 05/21/2014
Jul 13 14:44:30 id92 kernel: [ 3434.856561] Workqueue: events intel_mmio_flip_work_func [i915]
Jul 13 14:44:30 id92 kernel: [ 3434.856562]  0000000000000286 0000000082bab1d2 ffff88013ea53d20 ffffffff813d0743
Jul 13 14:44:30 id92 kernel: [ 3434.856564]  ffff88013ea53d68 ffffffffc0235ae8 ffff88013ea53d58 ffffffff8107ff12
Jul 13 14:44:30 id92 kernel: [ 3434.856565]  ffff8801d9100000 ffff88023fa96300 ffff88023fa9ac00 0000000000000040
Jul 13 14:44:30 id92 kernel: [ 3434.856567] Call Trace:
Jul 13 14:44:30 id92 kernel: [ 3434.856571]  [<ffffffff813d0743>] dump_stack+0x63/0x90
Jul 13 14:44:30 id92 kernel: [ 3434.856574]  [<ffffffff8107ff12>] warn_slowpath_common+0x82/0xc0
Jul 13 14:44:30 id92 kernel: [ 3434.856576]  [<ffffffff8107ffac>] warn_slowpath_fmt+0x5c/0x80
Jul 13 14:44:30 id92 kernel: [ 3434.856578]  [<ffffffff8101666c>] ? __switch_to+0x1dc/0x5c0
Jul 13 14:44:30 id92 kernel: [ 3434.856592]  [<ffffffffc01cebfe>] intel_mmio_flip_work_func+0x38e/0x3d0 [i915]
Jul 13 14:44:30 id92 kernel: [ 3434.856595]  [<ffffffff81098f45>] process_one_work+0x165/0x480
Jul 13 14:44:30 id92 kernel: [ 3434.856597]  [<ffffffff810992ab>] worker_thread+0x4b/0x4c0
Jul 13 14:44:30 id92 kernel: [ 3434.856598]  [<ffffffff81099260>] ? process_one_work+0x480/0x480
Jul 13 14:44:30 id92 kernel: [ 3434.856600]  [<ffffffff81099260>] ? process_one_work+0x480/0x480
Jul 13 14:44:30 id92 kernel: [ 3434.856602]  [<ffffffff8109f448>] kthread+0xd8/0xf0
Jul 13 14:44:30 id92 kernel: [ 3434.856604]  [<ffffffff8109f370>] ? kthread_create_on_node+0x1a0/0x1a0
Jul 13 14:44:30 id92 kernel: [ 3434.856606]  [<ffffffff81808b0f>] ret_from_fork+0x3f/0x70
Jul 13 14:44:30 id92 kernel: [ 3434.856608]  [<ffffffff8109f370>] ? kthread_create_on_node+0x1a0/0x1a0
Jul 13 14:44:30 id92 kernel: [ 3434.856609] ---[ end trace 123c91c2b6e5b787 ]---
Jul 13 14:44:30 id92 kernel: [ 3434.856617] ------------[ cut here ]------------
Jul 13 14:44:30 id92 kernel: [ 3434.856631] WARNING: CPU: 1 PID: 4080 at /home/kernel/COD/linux/drivers/gpu/drm/i915/intel_display.c:11289 intel_mmio_flip_work_func+0x38e/0x3d0 [i915]()
Jul 13 14:44:30 id92 kernel: [ 3434.856632] WARN_ON(__i915_wait_request(mmio_flip->req, mmio_flip->crtc->reset_counter, false, NULL, &mmio_flip->i915->rps.mmioflips))
Jul 13 14:44:30 id92 kernel: [ 3434.856633] Modules linked in: uas usb_storage rfcomm rtsx_usb_ms memstick bnep input_leds arc4 intel_rapl x86_pkg_temp_thermal intel_powerclamp coretemp kvm_intel kvm snd_hda_codec_hdmi irqbypass btusb snd_hda_codec_realtek crct10dif_pclmul btrtl snd_hda_codec_generic crc32_pclmul btbcm btintel bluetooth aesni_intel snd_hda_intel snd_hda_codec aes_x86_64 iwlmvm snd_hda_core snd_hwdep mac80211 lrw gf128mul snd_pcm glue_helper ablk_helper cryptd snd_seq_midi snd_seq_midi_event iwlwifi snd_rawmidi snd_seq serio_raw ir_xmp_decoder ir_lirc_codec lirc_dev ir_mce_kbd_decoder ir_sharp_decoder cfg80211 ir_sanyo_decoder ir_sony_decoder ir_jvc_decoder ir_rc6_decoder snd_seq_device ir_nec_decoder ir_rc5_decoder snd_timer mei_me snd lpc_ich shpchp mei soundcore rc_rc6_mce ite_cir rc_core mac_hid hid_generic usbhid hid parport_pc ppdev lp parport autofs4 btrfs xor raid6_pq rtsx_usb_sdmmc rtsx_usb i915 i2c_algo_bit drm_kms_helper psmouse syscopyarea sysfillrect sysimgblt fb_sys_fops ahci drm libahci r8169 mii fjes video
Jul 13 14:44:30 id92 kernel: [ 3434.856667] CPU: 1 PID: 4080 Comm: kworker/1:3 Tainted: G     U  W       4.4.14-040414-generic #201606241434
Jul 13 14:44:30 id92 kernel: [ 3434.856668] Hardware name: ZOTAC ZBOX-ID92/ZBOX-IQ01/ZBOX-ID92/ZBOX-IQ01, BIOS B220P007 05/21/2014
Jul 13 14:44:30 id92 kernel: [ 3434.856680] Workqueue: events intel_mmio_flip_work_func [i915]
Jul 13 14:44:30 id92 kernel: [ 3434.856681]  0000000000000286 00000000d195c703 ffff880056933d20 ffffffff813d0743
Jul 13 14:44:30 id92 kernel: [ 3434.856683]  ffff880056933d68 ffffffffc0235ae8 ffff880056933d58 ffffffff8107ff12
Jul 13 14:44:30 id92 kernel: [ 3434.856684]  ffff8801d91009c0 ffff88023fa96300 ffff88023fa9ac00 0000000000000040
Jul 13 14:44:30 id92 kernel: [ 3434.856686] Call Trace:
Jul 13 14:44:30 id92 kernel: [ 3434.856688]  [<ffffffff813d0743>] dump_stack+0x63/0x90
Jul 13 14:44:30 id92 kernel: [ 3434.856690]  [<ffffffff8107ff12>] warn_slowpath_common+0x82/0xc0
Jul 13 14:44:30 id92 kernel: [ 3434.856692]  [<ffffffff8107ffac>] warn_slowpath_fmt+0x5c/0x80
Jul 13 14:44:30 id92 kernel: [ 3434.856693]  [<ffffffff810168c7>] ? __switch_to+0x437/0x5c0
Jul 13 14:44:30 id92 kernel: [ 3434.856706]  [<ffffffffc01cebfe>] intel_mmio_flip_work_func+0x38e/0x3d0 [i915]
Jul 13 14:44:30 id92 kernel: [ 3434.856708]  [<ffffffff81098f45>] process_one_work+0x165/0x480
Jul 13 14:44:30 id92 kernel: [ 3434.856709]  [<ffffffff810992ab>] worker_thread+0x4b/0x4c0
Jul 13 14:44:30 id92 kernel: [ 3434.856711]  [<ffffffff81099260>] ? process_one_work+0x480/0x480
Jul 13 14:44:30 id92 kernel: [ 3434.856713]  [<ffffffff8109f448>] kthread+0xd8/0xf0
Jul 13 14:44:30 id92 kernel: [ 3434.856715]  [<ffffffff8109f370>] ? kthread_create_on_node+0x1a0/0x1a0
Jul 13 14:44:30 id92 kernel: [ 3434.856717]  [<ffffffff81808b0f>] ret_from_fork+0x3f/0x70
Jul 13 14:44:30 id92 kernel: [ 3434.856719]  [<ffffffff8109f370>] ? kthread_create_on_node+0x1a0/0x1a0
Jul 13 14:44:30 id92 kernel: [ 3434.856720] ---[ end trace 123c91c2b6e5b788 ]---
Jul 13 14:44:30 id92 kernel: [ 3434.859103] drm/i915: Resetting chip after gpu hang
Comment 18 Elizabeth 2018-03-21 23:29:27 UTC
Hi, sorry for the spam. Just want to point out that recent mesa release 17.3.6 seems to have fixed various hangs related to games and DEs, and maybe you'll want to give it a try if still facing the mpv issue. Good day :)
Comment 19 vadym 2018-06-06 10:03:22 UTC
Not able to reproduce this on haswell laptop. Tried playing full hd video in mpv, chrome, firefox. 

Below is my HW/SW info:

Platform: HP Zbook
OS: Ubuntu 16.04
CPU: Intel® Core™ i5-4310M CPU @ 2.70GHz × 4 
GPU: Intel® Haswell Mobile 
Linux kernel: 4.4.14-040414-generic and 4.16.1-041601-generic
Mesa version: 17.1.0-devel (git-36e029d) and 18.2.0-devel (git-75e919c045)
Comment 20 Francesco Balestrieri 2018-06-06 10:08:45 UTC
Looks like we can resolve this, thanks for the update!


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.