Bug 84758 - Register spilling with gl_VertexID
Summary: Register spilling with gl_VertexID
Status: RESOLVED DUPLICATE of bug 77957
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i965 (show other bugs)
Version: git
Hardware: Other All
: medium normal
Assignee: Ian Romanick
QA Contact: Intel 3D Bugs Mailing List
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: i965-perf
  Show dependency treegraph
 
Reported: 2014-10-07 15:27 UTC by Eero Tamminen
Modified: 2014-10-09 13:56 UTC (History)
2 users (show)

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Eero Tamminen 2014-10-07 15:27:56 UTC
HS/SW setup:
- HSW GT3e
- Mesa git from 2014-09-30
- Ubuntu 14.04

Test-case:
- Build ogl-samples test-suite from:
  https://github.com/g-truc/ogl-samples.git
- Run following test:
  build/Release/gl-400-fbo-rtt-texture-array

Actual result:
- "Vertex shader triggered register spilling.  Try reducing number of live vec4 value to improve performance."

Expected result:
- No register spilling with this simple vertex shader


Vertex shader is this:
https://github.com/g-truc/ogl-samples/blob/master/data/gl-400/rtt-array.vert

Code for the test is here:
https://github.com/g-truc/ogl-samples/blob/master/tests/gl-400-fbo-rtt-texture-array.cpp


Same thing happens also with the other tests using gl_VertexID as array index to small const array, for example with gl-320-draw-without-vertex-attrib test:
https://github.com/g-truc/ogl-samples/blob/master/data/gl-320/draw-without-vertex-attrib.vert

(which doesn't require setting these like gl-400-fbo-rtt* tests do:
  MESA_GL_VERSION_OVERRIDE=4.00
  MESA_GLSL_VERSION_OVERRIDE=400
)
Comment 1 Kenneth Graunke 2014-10-09 13:56:01 UTC

*** This bug has been marked as a duplicate of bug 77957 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.