Bug 84781 - [gen4] GPU hang in firefox on Google Chrome homepage (webgl)
Summary: [gen4] GPU hang in firefox on Google Chrome homepage (webgl)
Status: RESOLVED DUPLICATE of bug 80568
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i965 (show other bugs)
Version: unspecified
Hardware: x86-64 (AMD64) Linux (All)
: medium major
Assignee: Ian Romanick
QA Contact: Intel 3D Bugs Mailing List
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-10-08 06:42 UTC by pac12referee
Modified: 2014-11-14 19:24 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments
/sys/class/drm/card0/error log (849.03 KB, text/plain)
2014-10-08 06:42 UTC, pac12referee
Details
/sys/class/drm/card0/error log #2 (851.95 KB, text/plain)
2014-10-08 16:13 UTC, pac12referee
Details
/sys/class/drm/card0/error log #3 (849.67 KB, text/plain)
2014-10-08 16:33 UTC, pac12referee
Details

Note You need to log in before you can comment on or make changes to this bug.
Description pac12referee 2014-10-08 06:42:23 UTC
Created attachment 107537 [details]
/sys/class/drm/card0/error log

I just installed Linux Mint Qiana 64-bit on a stock Dell Inc. Vostro1510/0R780K.  The primary laptop display (not hooked up to any monitors) will go black, and is seemingly unrecoverable without reboot. 

I can reproduce the issue every time when opening up Firefox and attempting to go to the Google Chrome website.

The kernel is 3.13.0-24.

$ dpkg-query -l xserver-xorg-video-intel | grep ii
ii  xserver-xorg-video-intel                    2:2.99.910-0ubuntu1.1                               amd64        X.Org X server -- Intel i8xx, i9xx display driver


[Tue Oct  7 23:12:42 2014] [drm] stuck on render ring
[Tue Oct  7 23:12:42 2014] [drm] GPU crash dump saved to /sys/class/drm/card0/error
[Tue Oct  7 23:12:42 2014] [drm] GPU hangs can indicate a bug anywhere in the entire gfx stack, including userspace.
[Tue Oct  7 23:12:42 2014] [drm] Please file a _new_ bug report on bugs.freedesktop.org against DRI -> DRM/Intel
[Tue Oct  7 23:12:42 2014] [drm] drm/i915 developers can then reassign to the right component if it's not a kernel issue.
[Tue Oct  7 23:12:42 2014] [drm] The gpu crash dump is required to analyze gpu hangs, so please always attach it.
[Tue Oct  7 23:12:42 2014] [drm:i915_set_reset_status] *ERROR* render ring hung inside bo (0x5a66000 ctx 0) at 0x5a661cc
[Tue Oct  7 23:12:43 2014] [drm:i915_reset] *ERROR* Failed to reset chip.
[Tue Oct  7 23:12:52 2014] [drm:i915_gem_wait_for_error] *ERROR* Timed out waiting for the gpu reset to complete
[Tue Oct  7 23:12:52 2014] [drm] GMBUS [i915 gmbus vga] timed out, falling back to bit banging on pin 2
[Tue Oct  7 23:12:52 2014] ------------[ cut here ]------------
[Tue Oct  7 23:12:52 2014] WARNING: CPU: 1 PID: 1927 at /build/buildd/linux-3.13.0/drivers/gpu/drm/i915/intel_display.c:922 assert_pll+0x68/0x70 [i915]()
[Tue Oct  7 23:12:52 2014] PLL state assertion failure (expected on, current off)
[Tue Oct  7 23:12:52 2014] Modules linked in: ctr ccm rfcomm bnep bluetooth binfmt_misc dell_wmi sparse_keymap arc4 dell_laptop dcdbas dm_multipath coretemp scsi_dh kvm_intel snd_hda_codec_realtek kvm snd_hda_intel snd_hda_codec snd_hwdep snd_pcm b43 bcma joydev serio_raw mac80211 snd_page_alloc snd_seq_midi snd_seq_midi_event snd_rawmidi lpc_ich snd_seq snd_seq_device snd_timer cfg80211 snd soundcore parport_pc ppdev lp parport mac_hid dm_mirror dm_region_hash dm_log psmouse firewire_ohci ahci libahci sdhci_pci sdhci firewire_core crc_itu_t r8169 mii ssb i915 i2c_algo_bit drm_kms_helper drm wmi video
[Tue Oct  7 23:12:52 2014] CPU: 1 PID: 1927 Comm: upowerd Not tainted 3.13.0-24-generic #47-Ubuntu
[Tue Oct  7 23:12:52 2014] Hardware name: Dell Inc. Vostro1510/0R780K, BIOS A13 10/09/2008
[Tue Oct  7 23:12:52 2014]  0000000000000009 ffff88007a655a00 ffffffff81715ac4 ffff88007a655a48
[Tue Oct  7 23:12:52 2014]  ffff88007a655a38 ffffffff810676bd 0000000000000001 ffff880035d5d800
[Tue Oct  7 23:12:52 2014]  ffff880035bad000 0000000000000001 0000000000000000 ffff88007a655a98
[Tue Oct  7 23:12:52 2014] Call Trace:
[Tue Oct  7 23:12:52 2014]  [<ffffffff81715ac4>] dump_stack+0x45/0x56
[Tue Oct  7 23:12:52 2014]  [<ffffffff810676bd>] warn_slowpath_common+0x7d/0xa0
[Tue Oct  7 23:12:52 2014]  [<ffffffff8106772c>] warn_slowpath_fmt+0x4c/0x50
[Tue Oct  7 23:12:52 2014]  [<ffffffffa00fd7bc>] ? gen4_read32+0x3c/0xb0 [i915]
[Tue Oct  7 23:12:52 2014]  [<ffffffffa00bec38>] assert_pll+0x68/0x70 [i915]
[Tue Oct  7 23:12:52 2014]  [<ffffffffa00c4a50>] intel_crtc_load_lut+0x1b0/0x1d0 [i915]
[Tue Oct  7 23:12:52 2014]  [<ffffffff813697aa>] ? delay_tsc+0x4a/0x80
[Tue Oct  7 23:12:52 2014]  [<ffffffffa00c4c81>] i9xx_crtc_enable+0x211/0x410 [i915]
[Tue Oct  7 23:12:52 2014]  [<ffffffffa00c7689>] __intel_set_mode+0x859/0x9d0 [i915]
[Tue Oct  7 23:12:52 2014]  [<ffffffffa00ca346>] intel_set_mode+0x16/0x30 [i915]
[Tue Oct  7 23:12:52 2014]  [<ffffffffa00cb816>] intel_get_load_detect_pipe+0x256/0x410 [i915]
[Tue Oct  7 23:12:52 2014]  [<ffffffffa00f1ffd>] intel_tv_detect+0x13d/0x500 [i915]
[Tue Oct  7 23:12:52 2014]  [<ffffffff811c3e19>] ? terminate_walk+0x49/0x50
[Tue Oct  7 23:12:52 2014]  [<ffffffffa0022e3e>] status_show+0x3e/0x80 [drm]
[Tue Oct  7 23:12:52 2014]  [<ffffffff8148a840>] dev_attr_show+0x20/0x60
[Tue Oct  7 23:12:52 2014]  [<ffffffff8171c302>] ? mutex_lock+0x12/0x2f
[Tue Oct  7 23:12:52 2014]  [<ffffffff8122eeb0>] sysfs_seq_show+0xd0/0x180
[Tue Oct  7 23:12:52 2014]  [<ffffffff811dd43a>] seq_read+0x14a/0x390
[Tue Oct  7 23:12:52 2014]  [<ffffffff811b93b5>] vfs_read+0x95/0x160
[Tue Oct  7 23:12:52 2014]  [<ffffffff811b9ec9>] SyS_read+0x49/0xa0
[Tue Oct  7 23:12:52 2014]  [<ffffffff817266bf>] tracesys+0xe1/0xe6
[Tue Oct  7 23:12:52 2014] ---[ end trace 147dd23200ae0cb0 ]---
[Tue Oct  7 23:12:52 2014] ------------[ cut here ]------------
Comment 1 Chris Wilson 2014-10-08 06:52:26 UTC
The gpu reset should be improved in later kernels (or the gen4 fixes may *still* be pending).
Comment 2 pac12referee 2014-10-08 16:13:04 UTC
I updated the kernel to 3.16.0-031600-generic, and it failed again, however recovered and Cinnamon went into fallback mode.  Although, when I tried to restart Cinnamon, it kept going into fallback mode.

Will upload latest /sys/class/drm/card0/error.

$ dmesg -T | tail -8
[Wed Oct  8 09:04:27 2014] [drm] stuck on render ring
[Wed Oct  8 09:04:27 2014] [drm] GPU HANG: ecode 0:0x46e4fafe, in firefox [2289], reason: Ring hung, action: reset
[Wed Oct  8 09:04:27 2014] [drm] GPU hangs can indicate a bug anywhere in the entire gfx stack, including userspace.
[Wed Oct  8 09:04:27 2014] [drm] Please file a _new_ bug report on bugs.freedesktop.org against DRI -> DRM/Intel
[Wed Oct  8 09:04:27 2014] [drm] drm/i915 developers can then reassign to the right component if it's not a kernel issue.
[Wed Oct  8 09:04:27 2014] [drm] The gpu crash dump is required to analyze gpu hangs, so please always attach it.
[Wed Oct  8 09:04:27 2014] [drm] GPU crash dump saved to /sys/class/drm/card0/error
[Wed Oct  8 09:04:27 2014] [drm:i915_reset] *ERROR* Failed to reset chip: -19
Comment 3 pac12referee 2014-10-08 16:13:58 UTC
Created attachment 107562 [details]
/sys/class/drm/card0/error log #2

error log after upgrading to 3.16.0-031600-generic
Comment 4 pac12referee 2014-10-08 16:33:22 UTC
Created attachment 107569 [details]
/sys/class/drm/card0/error log #3

Error log after upgrading to 3.17.0-031700-generic.  dmesg output looks to be the same.

$ dmesg -T | tail -8
[Wed Oct  8 09:29:36 2014] [drm] stuck on render ring
[Wed Oct  8 09:29:36 2014] [drm] GPU HANG: ecode 0:0x46e4fafe, in firefox [2248], reason: Ring hung, action: reset
[Wed Oct  8 09:29:36 2014] [drm] GPU hangs can indicate a bug anywhere in the entire gfx stack, including userspace.
[Wed Oct  8 09:29:36 2014] [drm] Please file a _new_ bug report on bugs.freedesktop.org against DRI -> DRM/Intel
[Wed Oct  8 09:29:36 2014] [drm] drm/i915 developers can then reassign to the right component if it's not a kernel issue.
[Wed Oct  8 09:29:36 2014] [drm] The gpu crash dump is required to analyze gpu hangs, so please always attach it.
[Wed Oct  8 09:29:36 2014] [drm] GPU crash dump saved to /sys/class/drm/card0/error
[Wed Oct  8 09:29:36 2014] [drm:i915_reset] *ERROR* Failed to reset chip: -19
Comment 5 Matt Turner 2014-11-14 19:24:49 UTC

*** This bug has been marked as a duplicate of bug 80568 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct.