Bug 84787 - [BSW]Piglit spec_glsl-1.50_transform-feedback-builtins fails
Summary: [BSW]Piglit spec_glsl-1.50_transform-feedback-builtins fails
Status: VERIFIED DUPLICATE of bug 84777
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i965 (show other bugs)
Version: unspecified
Hardware: All Linux (All)
: medium normal
Assignee: Ben Widawsky
QA Contact: Intel 3D Bugs Mailing List
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-10-08 06:56 UTC by lu hua
Modified: 2014-12-16 05:52 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description lu hua 2014-10-08 06:56:01 UTC
System Environment:
--------------------------
Platform: BSW
Libdrm:	(master)libdrm-2.4.58-4-g00847fa48b83a85b0cb882594a12ed1511f780db
Mesa:	(master)16b53005a7df4249fecb6641af0934c32181fdea
Xserver:(master)xorg-server-1.16.0-386-g95a5b92e37f73f497d547fd91c543c16d2cc73de
Xf86_video_intel:(master)2.99.916-84-gec2b9ac81aed0d2dda2948171ca1c260184bf221
Libva:		(master)cdf8636d5fc5b1558570fede347e1599e0d6af3d
Libva_intel_driver:(master)f11176415ec26eb5960ba6841d2d9c22f2cabc60
Kernel:   (drm-intel-nightly)eabc0c8db15f9ba4d727aee5e0612a68cafe1ab5

Bug detailed description:
---------------------------
It fails on BSW with mesa master branch, works well on BDW.
spec_glsl-1.50_transform-feedback-type-and-size also fails.

output:
Incorrect data for 'gl_Layer' output 0.  Expected 1, got 5.
Incorrect data for 'gl_Layer' output 1.  Expected 3, got 0.
Incorrect data for 'gl_Layer' output 2.  Expected 5, got 0.
Incorrect data for 'gl_ViewportIndex' output 0.  Expected 1, got 3.
Incorrect data for 'gl_ViewportIndex' output 1.  Expected 2, got 0.
Incorrect data for 'gl_ViewportIndex' output 2.  Expected 3, got 0.
PIGLIT: {"result": "fail" }


Reproduce steps:
-------------------------
1. xinit
2. bin/glsl-1.50-transform-feedback-builtins -fbo -auto
Comment 1 Ben Widawsky 2014-12-04 02:52:11 UTC

*** This bug has been marked as a duplicate of bug 84777 ***
Comment 2 lu hua 2014-12-16 05:52:20 UTC
Verified.Fixed.
root@x-bsw01:/GFX/Test/Piglit/piglit# bin/glsl-1.50-transform-feedback-builtins -fbo -auto
libGL: OpenDriver: trying /opt/X11R7/lib/dri/tls/i965_dri.so
libGL: OpenDriver: trying /opt/X11R7/lib/dri/i965_dri.so
PIGLIT: {"result": "pass" }


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.