Bug 84803 - [gen4] GPU crash
Summary: [gen4] GPU crash
Status: RESOLVED DUPLICATE of bug 80568
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i965 (show other bugs)
Version: unspecified
Hardware: x86-64 (AMD64) Linux (All)
: medium blocker
Assignee: Ian Romanick
QA Contact: Intel 3D Bugs Mailing List
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-10-08 14:28 UTC by Alejandro Gonzalez
Modified: 2015-04-30 23:21 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments
/sys/class/drm/card0/error (846.48 KB, text/plain)
2014-10-08 14:28 UTC, Alejandro Gonzalez
Details
dmsg output (3.08 KB, text/plain)
2014-10-13 13:19 UTC, Alejandro Gonzalez
Details
glxinfo output (43 bytes, text/plain)
2014-10-13 13:20 UTC, Alejandro Gonzalez
Details
lsb_release -a output (135 bytes, text/plain)
2014-10-13 13:20 UTC, Alejandro Gonzalez
Details
lshw output (15.43 KB, text/plain)
2014-10-13 13:21 UTC, Alejandro Gonzalez
Details
Xorg -version output (678 bytes, text/plain)
2014-10-13 13:21 UTC, Alejandro Gonzalez
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Alejandro Gonzalez 2014-10-08 14:28:51 UTC
Created attachment 107557 [details]
/sys/class/drm/card0/error

The video die


[  255.808017] [drm] GPU crash dump saved to /sys/class/drm/card0/error
[  255.808018] [drm] GPU hangs can indicate a bug anywhere in the entire gfx stack, including userspace.
[  255.808018] [drm] Please file a _new_ bug report on bugs.freedesktop.org against DRI -> DRM/Intel
[  255.808019] [drm] drm/i915 developers can then reassign to the right component if it's not a kernel issue.
[  255.808020] [drm] The gpu crash dump is required to analyze gpu hangs, so please always attach it.
[  255.816085] [drm:i915_set_reset_status] *ERROR* render ring hung inside bo (0x5b1d000 ctx 0) at 0x5b1d6c0
Comment 1 Alejandro Gonzalez 2014-10-08 14:31:31 UTC
The video died
Comment 2 Tapani Pälli 2014-10-10 11:40:04 UTC
Could you add more information on the system (which distro, which version of Mesa and X server) and also on the use case or program that was executed?
Comment 3 Alejandro Gonzalez 2014-10-13 13:19:36 UTC
Created attachment 107775 [details]
dmsg output
Comment 4 Alejandro Gonzalez 2014-10-13 13:20:03 UTC
Created attachment 107776 [details]
glxinfo output
Comment 5 Alejandro Gonzalez 2014-10-13 13:20:40 UTC
Created attachment 107777 [details]
lsb_release -a output
Comment 6 Alejandro Gonzalez 2014-10-13 13:21:10 UTC
Created attachment 107778 [details]
lshw output
Comment 7 Alejandro Gonzalez 2014-10-13 13:21:37 UTC
Created attachment 107779 [details]
Xorg -version output
Comment 8 Alejandro Gonzalez 2014-10-13 13:23:04 UTC
I executed an "apt-get dist-upgrade" and the the video died. 
Now, when i boot the machine, when X start then the monitor died (X and text console), 
The service on machine are running well (the machine is a postgresql node for QA testing). Now I only can access the console by ssh.

I attached the output for commands (after reboot the machine): lshw, Xorg -version, lsb_release -a

If you need the output for other command just tell me the command-line.
Comment 9 Matt Turner 2015-03-06 23:28:53 UTC
I suspect this may be another duplicate of the bug 80568, fixed (worked-around) by this commit:

commit c4fd0c9052dd391d6f2e9bb8e6da209dfc7ef35b
Author: Kenneth Graunke <kenneth@whitecape.org>
Date:   Sat Jan 17 23:21:15 2015 -0800

    i965: Work around mysterious Gen4 GPU hangs with minimal state changes.
    
    Gen4 hardware appears to GPU hang frequently when using Chromium, and
    also when running 'glmark2 -b ideas'.  Most of the error states contain
    3DPRIMITIVE commands in quick succession, with very few state packets
    between them - usually VERTEX_BUFFERS/ELEMENTS and CONSTANT_BUFFER.
    
    I trimmed an apitrace of the glmark2 hang down to two draw calls with a
    glUniformMatrix4fv call between the two.  Either draw by itself works
    fine, but together, they hang the GPU.  Removing the glUniform call
    makes the hangs disappear.  In the hardware state, this translates to
    removing the CONSTANT_BUFFER packet between the two 3DPRIMITIVE packets.
    
    Flushing before emitting CONSTANT_BUFFER packets also appears to make
    the hangs disappear.  I observed a slowdown in glxgears by doing it all
    the time, so I've chosen to only do it when BRW_NEW_BATCH and
    BRW_NEW_PSP are unset (i.e. we haven't done a CS_URB_STATE change or
    already flushed the whole pipeline).
    
    I'd much rather understand the problem, but at this point, I don't see
    how we'd ever be able to track it down further.  We have no real tools,
    and the hardware people moved on years ago.  I've analyzed 20+ error
    states and read every scrap of documentation I could find.
    
    Bugzilla: https://bugs.freedesktop.org/show_bug.cgi?id=80568
    Bugzilla: https://bugs.freedesktop.org/show_bug.cgi?id=85367
    Signed-off-by: Kenneth Graunke <kenneth@whitecape.org>
    Acked-by: Matt Turner <mattst88@gmail.com>
    Cc: "10.4 10.3" <mesa-stable@lists.freedesktop.org>

It's in git, and backports are in Mesa 10.4.x for x > 3. Please try upgrading to >10.4.3. If it's resolved by such an upgrade, please mark as a duplicate of bug 80568.
Comment 10 Matt Turner 2015-04-30 23:21:45 UTC
No reply. Marking as duplicate.

*** This bug has been marked as a duplicate of bug 80568 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct.