Bug 84852 - [snb] GPU hang with mpv -- stray writes
Summary: [snb] GPU hang with mpv -- stray writes
Status: RESOLVED MOVED
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i965 (show other bugs)
Version: unspecified
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Intel 3D Bugs Mailing List
QA Contact: Intel 3D Bugs Mailing List
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-10-10 02:21 UTC by munuyiyusi
Modified: 2019-09-25 18:52 UTC (History)
2 users (show)

See Also:
i915 platform:
i915 features:


Attachments
GPU crash dump (2.41 MB, text/plain)
2014-10-10 02:24 UTC, munuyiyusi
Details
dmesg (5.05 KB, text/plain)
2014-10-10 02:25 UTC, munuyiyusi
Details
lspci (775 bytes, text/plain)
2014-10-10 02:26 UTC, munuyiyusi
Details
Xorg log (17.12 KB, text/plain)
2014-10-10 02:26 UTC, munuyiyusi
Details

Note You need to log in before you can comment on or make changes to this bug.
Description munuyiyusi 2014-10-10 02:21:50 UTC
Motherboard: ASRock Z68 PRO3
Chipset: i915
xf86-video-intel: 2.99.916-3
xorg-server: 1.16.1-1
mesa: 10.3.0-3
mesa-dri: 10.3.0-3
libdrm: 2.4.58-1
mpv: 0.6.0-1
Kernel: archlinux 3.16.4-1-ARCH x86_64

Switch back from fullscreen-mode to windowed mode in mpv, while playing a video. Screen hangs for anywhere between a second and a minute. Sometimes gets stuck. Hang does not always occur, seems random.
Comment 1 munuyiyusi 2014-10-10 02:24:17 UTC
Created attachment 107636 [details]
GPU crash dump
Comment 2 munuyiyusi 2014-10-10 02:25:44 UTC
Created attachment 107637 [details]
dmesg
Comment 3 munuyiyusi 2014-10-10 02:26:22 UTC
Created attachment 107638 [details]
lspci
Comment 4 munuyiyusi 2014-10-10 02:26:52 UTC
Created attachment 107639 [details]
Xorg log
Comment 5 Chris Wilson 2014-10-10 06:43:09 UTC
Someone scribbled over random addresses in the GTT with pixel data. Please try using mpv with the xv backend (mpv -vo xv if it inherits its options from mplayer).
Comment 6 munuyiyusi 2014-10-10 12:38:31 UTC
(In reply to Chris Wilson from comment #5)
> Someone scribbled over random addresses in the GTT with pixel data. Please
> try using mpv with the xv backend (mpv -vo xv if it inherits its options
> from mplayer).

I don't know what the GTT is. When I use mpv --vo=xv the bug does not occur.
Comment 7 Matt Turner 2017-03-22 16:51:24 UTC
I'm using mpv and VAAPI on Sandybridge and I don't see any problems. My config is

% cat ~/.mpv/config 
vo=opengl
hwdec=vaapi
ao=pulse

Can you reproduce with libva-1.7.3 and Mesa 17.0?
Comment 8 Danylo 2018-06-13 11:56:13 UTC
Hello, was not able to reproduce the issue with next setup:

cpu: i5-2400 Sandy Bridge
mpv: 0.28.2
mesa: 18.1.1, 10.5, 10.3
libva: 2.1.0
kernel: 4.14

The issue seems to be long gone.
Comment 9 GitLab Migration User 2019-09-25 18:52:36 UTC
-- GitLab Migration Automatic Message --

This bug has been migrated to freedesktop.org's GitLab instance and has been closed from further activity.

You can subscribe and participate further through the new bug through this link to our GitLab instance: https://gitlab.freedesktop.org/mesa/mesa/issues/1457.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.