Bug 84969 - /usr/bin/ld: cannot find -llibpiglitutil.so.0
Summary: /usr/bin/ld: cannot find -llibpiglitutil.so.0
Status: RESOLVED FIXED
Alias: None
Product: piglit
Classification: Unclassified
Component: infrastructure (show other bugs)
Version: unspecified
Hardware: x86-64 (AMD64) OpenBSD
: medium normal
Assignee: Jordan Justen
QA Contact: Eric Anholt
URL:
Whiteboard:
Keywords: bisected, regression
Depends on:
Blocks:
 
Reported: 2014-10-13 20:51 UTC by Vinson Lee
Modified: 2014-10-21 00:20 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Vinson Lee 2014-10-13 20:51:22 UTC
piglit: 122a4b4a3553b13737ee464ab61f90c6f85f940c (master)

Build error on OpenBSD.

Linking CXX shared library ../../../../lib/libpiglitutil_gl.so
/usr/bin/ld: cannot find -llibpiglitutil.so.0


commit 4efb025fcac0b37d04ab759ab15055f27cea94f8
Author: Jordan Justen <jordan.l.justen@intel.com>
Date:   Wed Sep 10 01:55:06 2014 -0700

    libpiglit: Set CMAKE SOVERSION for internal libraries to "0"
    
    When packaging for piglit for debian, I see this type of message:
    dpkg-shlibdeps: warning: Can't extract name and version from library name libpiglitutil.so
    
    It it repeated several times for each piglit executable causing a
    significant delay in the build time. Setting a soname version for
    these internal libraries causes this message to go away.
    
    Signed-off-by: Jordan Justen <jordan.l.justen@intel.com>
Comment 1 Jordan Justen 2014-10-19 19:44:57 UTC
I can't reproduce this on linux using ninja 1.3.4 and cmake 3.0.2.

Are you using plain cmake? Which version?

Does the build also fail for you with a completely cleaned tree? (git clean -dfx)
Comment 2 Vinson Lee 2014-10-21 00:20:53 UTC
commit 81481096dccb65b8b2601718123afe3e782849d2
Author: Vinson Lee <vlee@freedesktop.org>
Date:   Sat Oct 18 15:38:19 2014 -0700

    libpiglit: Do not set CMAKE_SOVERSION on OpenBSD.
    
    This patch fixes build regression on OpenBSD introduced with commit
    4efb025fcac0b37d04ab759ab15055f27cea94f8 'libpiglit: Set CMAKE SOVERSION
    for internal libraries to "0"'.
    
    Linking CXX shared library ../../../../lib/libpiglitutil_gl.so
    /usr/bin/ld: cannot find -llibpiglitutil.so.0
    collect2: ld returned 1 exit status
    target_api/gl/tests/util/CMakeFiles/piglitutil_gl.dir/build.make:515: recipe for target
    'lib/libpiglitutil_gl.so.0' failed
    
    Bugzilla: https://bugs.freedesktop.org/show_bug.cgi?id=84969
    Signed-off-by: Vinson Lee <vlee@freedesktop.org>
    Reviewed-by: Brian Paul <brianp@vmware.com>


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.