Bug 84971 - [gen4] GPU hang in chrome
Summary: [gen4] GPU hang in chrome
Status: RESOLVED DUPLICATE of bug 80568
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i965 (show other bugs)
Version: unspecified
Hardware: x86-64 (AMD64) Linux (All)
: medium major
Assignee: Ian Romanick
QA Contact: Intel 3D Bugs Mailing List
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-10-13 22:10 UTC by Alex
Modified: 2014-11-14 19:25 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
The requested "error" file (848.10 KB, text/plain)
2014-10-18 23:11 UTC, Alex
Details
The Xorg.0.log file (25.68 KB, text/plain)
2014-10-18 23:12 UTC, Alex
Details
The "dmesg" file. (70.82 KB, text/plain)
2014-10-18 23:12 UTC, Alex
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Alex 2014-10-13 22:10:35 UTC
System environment:
-- chipset: 965GM
-- system architecture: 64-bit
-- xf86-video-intel: 2.99.911
-- xserver: 1.15.1
-- mesa: 10.2.2
-- libdrm: 2.4.54
-- kernel: 3.13.0-37-generic
-- Linux distribution: Xubuntu 14.04 LTS
-- Machine or mobo model: Lenovo Thinkpad R61 laptop


Hi,

I am using Xubuntu 14.04 64-bits and Chrome as my main browser.  The computer is a Lenovo Thinkpad R61 laptop with an Intel 965GM video card inside.  Although everything was going fine when I was using Xubuntu 12.04, now, with 14.04, I am facing a problem that I am not able to find either a solution or a successful workaround for.

When I'm trying to watch a flash video, most of the time it works fine but randomly, the playback will pause right after it starts and 3-4 seconds later the screen will go black.  By saying black, I mean it's switched off, not simply blank.  It doesn't go back on unless I restart the laptop.  Everything else keeps working fine when this happens, and I can even hear the sound of the video playing.  I can press Ctrl-W and close the Chrome window or Ctrl-Alt-F1 and go to TTY1 mode, logon and turn the system off normally using the poweroff command.

Sometimes, when I see the video pause like that and rush to close its window before the screen goes black, I can avoid it from happening.  If I attempt to play the same video again right after that, it plays fine and, most of the time, many more videos play just fine afterwards.  Till it happens again for some unknown reason so far and the story goes on...

The only app that causes this on a standard basis is glmark2 on a specific test it runs, which is called "[ideas] speed=duration:".  All previous tests are ok.  I don't know about the tests after this specific one of course.  I never get to test them.

Additionally, Chrome has caused this problem two more times and both are not flash video related.  It happened for the first time when I clicked on the "Download Chrome" link on the google page at the point where it usually brings up a separate white window where the file links are and the second time when I clicked on a messenger contact in hotmail to see what happens now they brought msn back.  Never got to find out eventually.  :D

The point is that I've clicked the "Download Chrome" link tens of times after that and it always worked fine.  This issue is completely random.

It happens with both the Intel drivers installed with the system and the latest one I installed from Intel using 1.0.6 installer.  I also tried switching AccelMethod from SNA (the default) to UXA which seemed to save others from this issue but in my case it didn't.

As you understand, this is quite serious and it has become even more serious after the latest Chrome update to version 38 since it happens more often.

This is the beginning of the log entries concerning this, in syslog:
Oct 13 03:41:39 Lenovo kernel: [41804.816060] [drm] stuck on render ring
Oct 13 03:41:39 Lenovo kernel: [41804.816069] [drm] GPU crash dump saved to /sys/class/drm/card0/error
Oct 13 03:41:39 Lenovo kernel: [41804.816071] [drm] GPU hangs can indicate a bug anywhere in the entire gfx stack, including userspace.
Oct 13 03:41:39 Lenovo kernel: [41804.816079] [drm] Please file a _new_ bug report on bugs.freedesktop.org against DRI -> DRM/Intel
Oct 13 03:41:39 Lenovo kernel: [41804.816080] [drm] drm/i915 developers can then reassign to the right component if it's not a kernel issue.
Oct 13 03:41:39 Lenovo kernel: [41804.816081] [drm] The gpu crash dump is required to analyze gpu hangs, so please always attach it.
Oct 13 03:41:39 Lenovo kernel: [41804.817061] [drm:i915_set_reset_status] *ERROR* render ring hung inside bo (0xb99e000 ctx 0) at 0xb99f804
Oct 13 03:41:40 Lenovo kernel: [41805.332085] [drm:i915_reset] *ERROR* Failed to reset chip.
Oct 13 03:41:40 Lenovo kernel: [41805.332791] ------------[ cut here ]------------
Oct 13 03:41:40 Lenovo kernel: [41805.332879] WARNING: CPU: 1 PID: 1834 at /build/buildd/linux-3.13.0/drivers/gpu/drm/i915/intel_display.c:922 assert_pll+0x68/0x70 [i915]()
Oct 13 03:41:40 Lenovo kernel: [41805.332884] PLL state assertion failure (expected on, current off)

The file (/sys/class/drm/card0/error) it's referring to, is empty.  Nothing is actually saved in there.



I'd appreciate it if you could help on this one.  Thanks a lot everyone.  ;)
Comment 1 Alex 2014-10-14 00:25:21 UTC
Just happened again when I simply tried to enter Chrome store.

Working is becoming impossible till this gets fixed.
Comment 2 Chris Wilson 2014-10-14 06:12:58 UTC
The file is not empty, ls is confused. Please attach /sys/class/drm/card0/error.
Comment 3 Alex 2014-10-14 12:36:47 UTC
It seems I had to open the "error" file as root only.
These are the contents: no error state collected

There is nothing else in that file.
Comment 4 Rodrigo Vivi 2014-10-15 20:51:51 UTC
Please reproduce the error, then immediatelly collect the i915_error_state file. Otherwise it will show "no error collected"
Comment 5 Alex 2014-10-18 23:11:24 UTC
Created attachment 108049 [details]
The requested "error" file

The "error" file.  The crash was produced by visiting google web store.
Comment 6 Alex 2014-10-18 23:12:15 UTC
Created attachment 108050 [details]
The Xorg.0.log file
Comment 7 Alex 2014-10-18 23:12:47 UTC
Created attachment 108051 [details]
The "dmesg" file.
Comment 8 Alex 2014-10-18 23:16:01 UTC
I have attached all three files.  All of them were created by the same crash that occured when I just visited google web store.  The web store always produces this crash.

I have disabled Hardware acceleration in Chrome for now and I can work.
Comment 9 Alex 2014-11-13 20:45:44 UTC
Are there any updates on this issue please?

I have installed the new updates two days ago but the issue remains the same.
Comment 10 lagreca 2014-11-14 17:12:39 UTC
My laptop is also affected by this bug, since its chipset is intel 965gm.

I'd like to hear good news about it.
Comment 11 Matt Turner 2014-11-14 19:25:25 UTC

*** This bug has been marked as a duplicate of bug 80568 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct.