Bug 85223 - Does not want to use local candidates if STUN server sends broken replies
Summary: Does not want to use local candidates if STUN server sends broken replies
Status: RESOLVED MOVED
Alias: None
Product: nice
Classification: Unclassified
Component: General (show other bugs)
Version: unspecified
Hardware: Other All
: medium normal
Assignee: Olivier Crête
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-10-20 08:44 UTC by Sebastian Dröge (slomo)
Modified: 2015-06-26 14:02 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
log (750.81 KB, text/plain)
2014-10-20 08:44 UTC, Sebastian Dröge (slomo)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Sebastian Dröge (slomo) 2014-10-20 08:44:56 UTC
Created attachment 108093 [details]
log

See summary and the attached log. What seems to happen here is that:
- the STUN server replies with a broken reply very fast (line 66)
- then gathering candidates finished (line 73)
- then local candidates reply (line 87, 115, etc)


Later it then tries to communicate with the other side, but the nice agent never finishes setup (line 461 and following).

When just removing the STUN server, everything works fine. I would expect libnice to do the same if the STUN server sends broken replies :)
Comment 1 Olivier Crête 2014-10-22 18:48:01 UTC
Indeed, we should wait until the nice_agent_gather_candidates() return before allowing the gathering-done signal to be emitted... This is caused by the STUN error coming on another thread and we no longer hold the global lock while emiting signals since 0.1.8.
Patch welcome.
Comment 2 Philip Withnall 2015-06-26 14:02:08 UTC
Migrated to Phabricator: http://phabricator.freedesktop.org/T109


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.