Bug 85249 - GM965 crash (black screen) when using Chrome (reliably repeatable) and other apps
Summary: GM965 crash (black screen) when using Chrome (reliably repeatable) and other ...
Status: RESOLVED DUPLICATE of bug 80568
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i965 (show other bugs)
Version: unspecified
Hardware: x86 (IA32) Linux (All)
: medium major
Assignee: Ian Romanick
QA Contact: Intel 3D Bugs Mailing List
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-10-20 16:22 UTC by Nick T
Modified: 2014-11-14 19:36 UTC (History)
4 users (show)

See Also:
i915 platform:
i915 features:


Attachments
full copy of crash dump from /sys/class/drm/card0/error (849.71 KB, text/plain)
2014-10-20 16:22 UTC, Nick T
Details
/sys/class/drm/card0/error toshiba satalite a205-s5000 (851.69 KB, text/plain)
2014-10-21 19:04 UTC, Justin VanDeBrake
Details
kern.log Toshiba satellite a205-s5000 (21.79 KB, text/plain)
2014-10-21 19:06 UTC, Justin VanDeBrake
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Nick T 2014-10-20 16:22:07 UTC
Created attachment 108123 [details]
full copy of crash dump from /sys/class/drm/card0/error

Running Ubuntu 14.04.1 (fresh install) on Lenovo T61 15.4" WSXGA+ with Intel GM965/GL960 intgrated graphics.

Repeatable sequence to cause graphics to crash:
- Launch Chrome (using 38.0.2125.104).
- Go to More Tools -> Extensions
- click Get more Extensions link
Screen hangs for a second or so then goes black.
Rest of system appears to stay live - ssh remote connection remains operational.

Also crashes in similar way using other applications.

Full syslog entries read:

** Excerpt from syslog
** (no other entries in previous 7 minutes)
Oct 20 17:04:38 training-08 kernel: [ 2677.000062] [drm] stuck on render ring
Oct 20 17:04:38 training-08 kernel: [ 2677.000068] [drm] GPU crash dump saved to /sys/class/drm/card0/error
Oct 20 17:04:38 training-08 kernel: [ 2677.000070] [drm] GPU hangs can indicate a bug anywhere in the entire gfx stack, including userspace.
Oct 20 17:04:38 training-08 kernel: [ 2677.000072] [drm] Please file a _new_ bug report on bugs.freedesktop.org against DRI -> DRM/Intel
Oct 20 17:04:38 training-08 kernel: [ 2677.000074] [drm] drm/i915 developers can then reassign to the right component if it's not a kernel issue.
Oct 20 17:04:38 training-08 kernel: [ 2677.000075] [drm] The gpu crash dump is required to analyze gpu hangs, so please always attach it.
Oct 20 17:04:38 training-08 kernel: [ 2677.001228] [drm:i915_set_reset_status] *ERROR* render ring hung inside bo (0x6a59000 ctx 0) at 0x6a59d80
Oct 20 17:04:38 training-08 kernel: [ 2677.072073] [drm] GMBUS [i915 gmbus vga] timed out, falling back to bit banging on pin 2
Oct 20 17:04:39 training-08 kernel: [ 2677.512090] [drm:i915_reset] *ERROR* Failed to reset chip.
Oct 20 17:04:39 training-08 gnome-session[1239]: WARNING: App 'compiz.desktop' exited with code 1
Oct 20 17:04:39 training-08 gnome-session[1239]: WARNING: App 'compiz.desktop' respawning too quickly
Oct 20 17:04:39 training-08 gnome-session[1239]: CRITICAL: We failed, but the fail whale is dead. Sorry....
Oct 20 17:04:40 training-08 kernel: [ 2678.614552] ------------[ cut here ]------------
Oct 20 17:04:40 training-08 kernel: [ 2678.614611] WARNING: CPU: 0 PID: 1070 at /build/buildd/linux-3.13.0/drivers/gpu/drm/i915/intel_display.c:922 assert_pll+0x73/0x80 [i915]()
Oct 20 17:04:40 training-08 kernel: [ 2678.614614] PLL state assertion failure (expected on, current off)
Oct 20 17:04:40 training-08 kernel: [ 2678.614616] Modules linked in: ctr ccm snd_hda_codec_analog pcmcia rfcomm bnep arc4 iwl4965 iwlegacy coretemp kvm_intel kvm mac80211 r852 sm_common nand nand_ecc joydev nand_bch serio_raw bch nand_ids yenta_socket thinkpad_acpi mtd nvram snd_hda_intel snd_seq_midi snd_hda_codec pcmcia_rsrc lpc_ich r592 snd_seq_midi_event memstick cfg80211 pcmcia_core snd_hwdep snd_pcm snd_rawmidi snd_seq snd_page_alloc btusb snd_seq_device snd_timer bluetooth i915 drm_kms_helper snd drm i2c_algo_bit wmi soundcore video parport_pc mac_hid ppdev lp parport ahci firewire_ohci psmouse libahci firewire_core sdhci_pci e1000e sdhci crc_itu_t ptp pps_core
Oct 20 17:04:40 training-08 kernel: [ 2678.614676] CPU: 0 PID: 1070 Comm: Xorg Not tainted 3.13.0-32-generic #57-Ubuntu
Oct 20 17:04:40 training-08 kernel: [ 2678.614679] Hardware name: LENOVO 64644YG/64644YG, BIOS 7LETC9WW (2.29 ) 03/18/2011
Oct 20 17:04:40 training-08 kernel: [ 2678.614682]  00000000 00000000 eea69d60 c1650cd3 eea69da0 eea69d90 c10567ee f936b25c
Oct 20 17:04:40 training-08 kernel: [ 2678.614690]  eea69dbc 0000042e f9369bb0 0000039a f9317d73 f9317d73 00000001 00000001
Oct 20 17:04:40 training-08 kernel: [ 2678.614697]  00000000 eea69da8 c1056843 00000009 eea69da0 f936b25c eea69dbc eea69dcc
Oct 20 17:04:40 training-08 kernel: [ 2678.614704] Call Trace:
Oct 20 17:04:40 training-08 kernel: [ 2678.614715]  [<c1650cd3>] dump_stack+0x41/0x52
Oct 20 17:04:40 training-08 kernel: [ 2678.614723]  [<c10567ee>] warn_slowpath_common+0x7e/0xa0
Oct 20 17:04:40 training-08 kernel: [ 2678.614747]  [<f9317d73>] ? assert_pll+0x73/0x80 [i915]
Oct 20 17:04:40 training-08 kernel: [ 2678.614770]  [<f9317d73>] ? assert_pll+0x73/0x80 [i915]
Oct 20 17:04:40 training-08 kernel: [ 2678.614774]  [<c1056843>] warn_slowpath_fmt+0x33/0x40
Oct 20 17:04:40 training-08 kernel: [ 2678.614798]  [<f9317d73>] assert_pll+0x73/0x80 [i915]
Oct 20 17:04:40 training-08 kernel: [ 2678.614823]  [<f931d43a>] intel_crtc_load_lut+0x19a/0x1b0 [i915]
Oct 20 17:04:40 training-08 kernel: [ 2678.614847]  [<f931e631>] intel_crtc_gamma_set+0x71/0x80 [i915]
Oct 20 17:04:40 training-08 kernel: [ 2678.614883]  [<f8d9b8c8>] drm_mode_gamma_set_ioctl+0x118/0x130 [drm]
Oct 20 17:04:40 training-08 kernel: [ 2678.614899]  [<f8d9b7b0>] ? drm_mode_connector_property_set_ioctl+0x40/0x40 [drm]
Oct 20 17:04:40 training-08 kernel: [ 2678.614912]  [<f8d8c792>] drm_ioctl+0x472/0x500 [drm]
Oct 20 17:04:40 training-08 kernel: [ 2678.614930]  [<f8d9b7b0>] ? drm_mode_connector_property_set_ioctl+0x40/0x40 [drm]
Oct 20 17:04:40 training-08 kernel: [ 2678.614940]  [<c10b183f>] ? ktime_get+0x4f/0x130
Oct 20 17:04:40 training-08 kernel: [ 2678.614948]  [<c12f7a50>] ? timerqueue_add+0x50/0xb0
Oct 20 17:04:40 training-08 kernel: [ 2678.614953]  [<c10779fe>] ? enqueue_hrtimer+0x1e/0x70
Oct 20 17:04:40 training-08 kernel: [ 2678.614957]  [<c10784a8>] ? __hrtimer_start_range_ns+0x1a8/0x3f0
Oct 20 17:04:40 training-08 kernel: [ 2678.614970]  [<f8d8c320>] ? drm_free_buffer+0x30/0x30 [drm]
Oct 20 17:04:40 training-08 kernel: [ 2678.614976]  [<c1189c92>] do_vfs_ioctl+0x2e2/0x4d0
Oct 20 17:04:40 training-08 kernel: [ 2678.614979]  [<c1078747>] ? hrtimer_start+0x27/0x30
Oct 20 17:04:40 training-08 kernel: [ 2678.614983]  [<c1059c20>] ? do_setitimer+0x200/0x270
Oct 20 17:04:40 training-08 kernel: [ 2678.614987]  [<c10b1d68>] ? ktime_get_ts+0x48/0x140
Oct 20 17:04:40 training-08 kernel: [ 2678.614991]  [<c1189ee0>] SyS_ioctl+0x60/0x80
Oct 20 17:04:40 training-08 kernel: [ 2678.614998]  [<c165efcd>] sysenter_do_call+0x12/0x28
Oct 20 17:04:40 training-08 kernel: [ 2678.615000] ---[ end trace 2c018a3de7223e68 ]---
Oct 20 17:04:41 training-08 gnome-session[1239]: WARNING: App 'compiz.desktop' respawning too quickly
Oct 20 17:04:41 training-08 gnome-session[1239]: WARNING: App 'compiz.desktop' exited with code 1
Oct 20 17:04:41 training-08 gnome-session[1239]: WARNING: App 'compiz.desktop' respawning too quickly
Comment 1 Justin VanDeBrake 2014-10-21 19:02:50 UTC
Same problem on a toshiba satalite A205-s5000

Linux Mint 17 with Cinnamon desktop

Linux VSatalite 3.13.0-24-generic #47-Ubuntu SMP Fri May 2 23:31:42 UTC 2014 i686 i686 i686 GNU/Linux

Graphics: Intel GMA X3100

Can be reproduced every time by starting google chrome 38.0.2125.104-1 or 39.0.2171.27 beta and visiting chrome.google.com/webstore. once page loads graphics immediately freezes and goes black in about 5 seconds.
Sleeping the computer and waking it up again causes the driver to restart and cinnamon to start in falback mode.  When cinnamon is in fallback mode I have not seen the bug occur.

Starting either chrome version with the --disable-gpu-compositing flag prevents the issue from occurring.

sys/class/drm/card0/error and associated kern.log has been attached.
Comment 2 Justin VanDeBrake 2014-10-21 19:04:12 UTC
Created attachment 108202 [details]
/sys/class/drm/card0/error toshiba satalite a205-s5000
Comment 3 Justin VanDeBrake 2014-10-21 19:06:01 UTC
Created attachment 108203 [details]
kern.log Toshiba satellite a205-s5000

file has been trimmed to show a few stack traces associated with 2 occurrences of the error.
Comment 4 Nick T 2014-10-26 16:36:23 UTC
Update:  The issue described seems to be resolved in Ubuntu 14.10 (just installed to check).
  
However, still present in Ubuntu 14.04 LTS.
Tried updating the Ubuntu kernel to 3.17.1 (from kernel.ubuntu.com) but this made no difference.
Also tried using the Intel Graphics Installer 1.0.6 for Linux to update graphics drivers (both with the stock 3.13 kernel and the updated 3.17 kernel) but crash remains as described.
Comment 5 javimarco 2014-11-05 22:45:37 UTC
Hi!

Same behavior in my Compaq laptop.

Linux LinuxMint 3.13.0-24-generic #47-Ubuntu SMP

This is what syslog uotputs:

LinuxMint kernel: [ 5641.992065] [drm] The gpu crash dump is required to analyze gpu hangs, so please always attach it.
Nov  5 01:42:20 LinuxMint kernel: [ 5641.993403] [drm:i915_set_reset_status] *ERROR* render ring hung inside bo (0x7bd8000 ctx 0) at 0x7bd9dcc
Nov  5 01:42:20 LinuxMint kernel: [ 5642.504078] [drm:i915_reset] *ERROR* Failed to reset chip.
Nov  5 01:42:24 LinuxMint kernel: [ 5646.345702] Watchdog[7945]: segfault at 0 ip b63806bf sp afc04d10 error 6 in chrome[b2296000+54f4000]
Nov  5 01:42:30 LinuxMint kernel: [ 5652.072121] [drm:i915_gem_wait_for_error] *ERROR* Timed out waiting for the gpu reset to complete
Nov  5 01:42:30 LinuxMint kernel: [ 5652.128055] [drm] GMBUS [i915 gmbus vga] timed out, falling back to bit banging on pin 2
Nov  5 01:42:30 LinuxMint kernel: [ 5652.151484] ------------[ cut here ]------------
Nov  5 01:42:30 LinuxMint kernel: [ 5652.151519] WARNING: CPU: 0 PID: 1846 at /build/buildd/linux-3.13.0/drivers/gpu/drm/i915/intel_display.c:922 assert_pll+0x73/0x80 [
i915]()
Nov  5 01:42:30 LinuxMint kernel: [ 5652.151522] PLL state assertion failure (expected on, current off)
Nov  5 01:42:30 LinuxMint kernel: [ 5652.151524] Modules linked in: rfcomm bnep bluetooth binfmt_misc hp_wmi sparse_keymap arc4 iwldvm mac80211 snd_hda_codec_idt snd_hd
a_intel snd_hda_codec snd_hwdep snd_pcm snd_page_alloc snd_seq_midi snd_seq_midi_event snd_rawmidi snd_seq dm_multipath snd_seq_device uvcvideo snd_timer scsi_dh videob
uf2_vmalloc videobuf2_memops coretemp iwlwifi snd videobuf2_core videodev joydev serio_raw cfg80211 lpc_ich soundcore parport_pc mac_hid ppdev lp parport dm_mirror dm_r
egion_hash dm_log hid_generic usbhid hid ahci psmouse i915 libahci i2c_algo_bit video wmi drm_kms_helper drm sky2
Nov  5 01:42:30 LinuxMint kernel: [ 5652.151568] CPU: 0 PID: 1846 Comm: upowerd Not tainted 3.13.0-24-generic #47-Ubuntu
Nov  5 01:42:30 LinuxMint kernel: [ 5652.151570] Hardware name: Hewlett-Packard Compaq 610/308A, BIOS 68PVU Ver. F.0B 11/20/2009
Nov  5 01:42:30 LinuxMint kernel: [ 5652.151572]  00000000 00000000 ecb51be4 c164b8c3 ecb51c24 ecb51c14 c10567ee f8ae40f0
Nov  5 01:42:30 LinuxMint kernel: [ 5652.151579]  ecb51c40 00000736 f8ae2a44 0000039a f8a90c43 f8a90c43 00000001 00000001
Nov  5 01:42:30 LinuxMint kernel: [ 5652.151586]  00000000 ecb51c2c c1056843 00000009 ecb51c24 f8ae40f0 ecb51c40 ecb51c50
Nov  5 01:42:30 LinuxMint kernel: [ 5652.151592] Call Trace:
Nov  5 01:42:30 LinuxMint kernel: [ 5652.151600]  [<c164b8c3>] dump_stack+0x41/0x52
Nov  5 01:42:30 LinuxMint kernel: [ 5652.151605]  [<c10567ee>] warn_slowpath_common+0x7e/0xa0
Nov  5 01:42:30 LinuxMint kernel: [ 5652.151627]  [<f8a90c43>] ? assert_pll+0x73/0x80 [i915]
Nov  5 01:42:30 LinuxMint kernel: [ 5652.151647]  [<f8a90c43>] ? assert_pll+0x73/0x80 [i915]
Nov  5 01:42:30 LinuxMint kernel: [ 5652.151651]  [<c1056843>] warn_slowpath_fmt+0x33/0x40
Nov  5 01:42:30 LinuxMint kernel: [ 5652.151671]  [<f8a90c43>] assert_pll+0x73/0x80 [i915]
Nov  5 01:42:30 LinuxMint kernel: [ 5652.151694]  [<f8a9630a>] intel_crtc_load_lut+0x19a/0x1b0 [i915]
Nov  5 01:42:30 LinuxMint kernel: [ 5652.151713]  [<f8a8e325>] ? assert_panel_unlocked+0xa5/0xb0 [i915]
Nov  5 01:42:30 LinuxMint kernel: [ 5652.151733]  [<f8a964eb>] i9xx_crtc_enable+0x1cb/0x3a0 [i915]
Nov  5 01:42:30 LinuxMint kernel: [ 5652.151754]  [<f8a98b3c>] __intel_set_mode+0x75c/0x8b0 [i915]
Nov  5 01:42:30 LinuxMint kernel: [ 5652.151778]  [<f8a9b7e3>] intel_set_mode+0x23/0x40 [i915]
Nov  5 01:42:30 LinuxMint kernel: [ 5652.151799]  [<f8a9cbb0>] intel_get_load_detect_pipe+0x230/0x3a0 [i915]
Nov  5 01:42:30 LinuxMint kernel: [ 5652.151827]  [<f8ac1845>] intel_tv_detect+0x125/0x510 [i915]
Nov  5 01:42:30 LinuxMint kernel: [ 5652.151835]  [<c1404080>] ? dev_uevent_name+0x30/0x30
Nov  5 01:42:30 LinuxMint kernel: [ 5652.281539]  [<c1404098>] dev_attr_show+0x18/0x40
Nov  5 01:42:30 LinuxMint kernel: [ 5652.281543]  [<c11d8183>] sysfs_seq_show+0xa3/0x140
Nov  5 01:42:30 LinuxMint kernel: [ 5652.281547]  [<c119598e>] seq_read+0xce/0x370
Nov  5 01:42:30 LinuxMint kernel: [ 5652.281551]  [<c11958c0>] ? seq_hlist_next_percpu+0x90/0x90
Nov  5 01:42:30 LinuxMint kernel: [ 5652.281555]  [<c1176718>] vfs_read+0x78/0x140
Nov  5 01:42:30 LinuxMint kernel: [ 5652.281559]  [<c1176e89>] SyS_read+0x49/0x90
Nov  5 01:42:30 LinuxMint kernel: [ 5652.281563]  [<c1659bcd>] sysenter_do_call+0x12/0x28
Nov  5 01:42:30 LinuxMint kernel: [ 5652.281565] ---[ end trace 99793ac2c2d91d8a ]---

Thanks for your help!
Comment 6 Matt Turner 2014-11-14 19:36:28 UTC

*** This bug has been marked as a duplicate of bug 80568 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct.