Bug 85406 - [gen4] GPU hang in firefox or chrome
Summary: [gen4] GPU hang in firefox or chrome
Status: RESOLVED DUPLICATE of bug 80568
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i965 (show other bugs)
Version: unspecified
Hardware: x86-64 (AMD64) Linux (All)
: highest blocker
Assignee: Ian Romanick
QA Contact: Intel 3D Bugs Mailing List
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-10-24 13:06 UTC by ou.ghorbel
Modified: 2015-05-01 22:35 UTC (History)
3 users (show)

See Also:
i915 platform:
i915 features:


Attachments
/sys/class/drm/card0/error (848.04 KB, text/plain)
2014-10-24 13:43 UTC, ou.ghorbel
Details
crash dump from /sys/class/drm/card0/error (846.98 KB, text/plain)
2014-10-26 10:42 UTC, Darius Kellermann
Details

Note You need to log in before you can comment on or make changes to this bug.
Description ou.ghorbel 2014-10-24 13:06:55 UTC
I get black screen when visiting some website on Google Chrome or Firefox. As example, the bug is reproduced when playing some video on youtube.
When playing a video on youtube the screen get black and the sound continue to play back. On FireFox the screen get black when accessing the page: http://www.google.com/chrome

Info about my graphic card

lspci | grep -i vga 00:02.0 VGA compatible controller: Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller (primary) (rev 0c)

I have tested a couple of ubuntu 14.04 based distribution (64 and 32 bit) and they all have the issue. It's reproduced event with Fedora 20.

The bug can simply reproducing by booting the live CD of ubuntu 14.04, then open FireFox and go to the page google.com/chrome

Loading the DDX fbdev instead of intel, seems to fix the issue. but this is not efficient....

Is there a way to debug the issue?
Comment 1 Chris Wilson 2014-10-24 13:09:13 UTC
Look at /var/log/Xorg.0.log and dmesg, see the error message, then attach /sys/class/drm/card0/error.
Comment 2 ou.ghorbel 2014-10-24 13:43:46 UTC
Created attachment 108354 [details]
/sys/class/drm/card0/error

The Xorg log says that it has detected hung GPU.

dmesg outpout:
[  222.804045] [drm] stuck on render ring
[  222.804053] [drm] GPU crash dump saved to /sys/class/drm/card0/error
[  222.804055] [drm] GPU hangs can indicate a bug anywhere in the entire gfx stack, including userspace.
[  222.804059] [drm] Please file a _new_ bug report on bugs.freedesktop.org against DRI -> DRM/Intel
[  222.804060] [drm] drm/i915 developers can then reassign to the right component if it's not a kernel issue.
[  222.804062] [drm] The gpu crash dump is required to analyze gpu hangs, so please always attach it.
[  222.805220] [drm:i915_set_reset_status] *ERROR* render ring hung inside bo (0x5e56000 ctx 0) at 0x5e561cc
[  222.864062] [drm] GMBUS [i915 gmbus vga] timed out, falling back to bit banging on pin 2
[  223.316095] [drm:i915_reset] *ERROR* Failed to reset chip.
Comment 3 ou.ghorbel 2014-10-24 14:04:25 UTC
Any suggestion about what part for code that could make the GPU hungs are very helpful. I will work on it.
Comment 4 ou.ghorbel 2014-10-24 14:11:15 UTC
It seems that Firefox get frozen for few seconds when access google.com/chrome on Windows Vista, but later it will display the page, however Windows display an error message saying there is hardware issue in the video card.

PS: I have used Linux for more than 3 month on this laptop and I have not this issue before.
Comment 5 Darius Kellermann 2014-10-26 10:42:08 UTC
Created attachment 108441 [details]
crash dump from /sys/class/drm/card0/error

I am having the same problem since the last system update. I'm also running 64 bit and I have the same graphics card, so it really seems to be the same issue.
I'm getting the error in chrome, when I'm opening the details view of an extension in the Chrome App Store. Gnome's Oops dialog screen thing will pop up, but the screen doesn't go black.

Below are packages from the last system upgrade that I think could be relevant.

[2014-10-25 10:22] [PACMAN] upgraded mesa-dri (10.3.1-1 -> 10.3.2-1)
[2014-10-25 10:22] [PACMAN] upgraded mesa (10.3.1-1 -> 10.3.2-1)
[2014-10-25 10:22] [PACMAN] upgraded mesa-libgl (10.3.1-1 -> 10.3.2-1)
[2014-10-25 10:24] [PACMAN] upgraded webkitgtk (2.4.5-1 -> 2.4.6-3)
[2014-10-25 10:24] [PACMAN] upgraded gnome-shell (3.12.2-1 -> 3.14.1-1)
[2014-10-25 10:25] [PACMAN] upgraded linux-firmware (20140828.13eb208-1 -> 20141009.0e5f637-1)
[2014-10-25 10:26] [PACMAN] upgraded linux (3.16.4-1 -> 3.17.1-1)
[2014-10-25 10:28] [PACMAN] upgraded webkitgtk2 (2.4.5-1 -> 2.4.6-3)
[2014-10-25 10:35] [PACMAN] upgraded google-chrome (38.0.2125.101-1 -> 38.0.2125.104-1)

Also:
lspci | grep -i vga
00:02.0 VGA compatible controller: Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller (primary) (rev 0c)

And:
[  134.336677] [drm] stuck on render ring
[  134.337590] [drm] GPU HANG: ecode 0:0x9f47f9fd, in chrome [1017], reason: Ring hung, action: reset
[  134.337593] [drm] GPU hangs can indicate a bug anywhere in the entire gfx stack, including userspace.
[  134.337594] [drm] Please file a _new_ bug report on bugs.freedesktop.org against DRI -> DRM/Intel
[  134.337596] [drm] drm/i915 developers can then reassign to the right component if it's not a kernel issue.
[  134.337598] [drm] The gpu crash dump is required to analyze gpu hangs, so please always attach it.
[  134.337599] [drm] GPU crash dump saved to /sys/class/drm/card0/error
[  134.337713] [drm:i915_reset] *ERROR* Failed to reset chip: -19

I'll also attach the crash dump. If there is anything else that could be of help, please let me know.
Comment 6 Kaveh 2014-11-12 07:15:55 UTC
Could you please explain what this bug is a "blocker" for?
Comment 7 ou.ghorbel 2014-11-12 13:30:37 UTC
I'm unable to navigate to website in FireFox or Chrome because this issue.
youtube and many others website that have some graphics make the screen black.
I was forced to drop linux because this issue and I went back to my MS Vista.
Comment 8 Matt Turner 2014-11-14 19:26:12 UTC

*** This bug has been marked as a duplicate of bug 80568 ***
Comment 9 ou.ghorbel 2015-05-01 22:35:03 UTC
Bug seems fixed in the the mainline kernel 3.19 and with libgl1-mesa-dri 10.6.0~git20


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct.