Bug 85656 - [gen4] GPU hang in chrome
Summary: [gen4] GPU hang in chrome
Status: RESOLVED DUPLICATE of bug 80568
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i965 (show other bugs)
Version: unspecified
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Ian Romanick
QA Contact: Intel 3D Bugs Mailing List
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-10-30 16:44 UTC by Adam
Modified: 2014-11-14 19:26 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments
kern.log (723.14 KB, text/plain)
2014-10-30 16:44 UTC, Adam
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Adam 2014-10-30 16:44:42 UTC
Created attachment 108702 [details]
kern.log

To reproduce the error I start Chrome (Version 38.0.2125.111 (64-bit))
and start the Tweetdeck App I have installed.
Whenever I click the "New Tweet" button, the system freezes for about a second and then the screen blacks out. While the rest of the system is still running, there is no way re-enabling ANY graphics output from the Intel graphics adapter. I can only ssh into the machine and do a controlled reboot to regain any output.

I have attached the kern.log as instructed by the log entry.
The /sys/class/drm/card0/error file only contains the following line:
no error state collected

Any clues for me?


Adam
Comment 1 Adam 2014-10-30 16:45:44 UTC
Comment on attachment 108702 [details]
kern.log

These are the relevant lines:
Oct 30 17:24:52 toughy kernel: [  508.804037] [drm] stuck on render ring
Oct 30 17:24:52 toughy kernel: [  508.804045] [drm] GPU crash dump saved to /sys/class/drm/card0/error
Oct 30 17:24:52 toughy kernel: [  508.804048] [drm] GPU hangs can indicate a bug anywhere in the entire gfx stack, including userspace.
Oct 30 17:24:52 toughy kernel: [  508.804051] [drm] Please file a _new_ bug report on bugs.freedesktop.org against DRI -> DRM/Intel
Oct 30 17:24:52 toughy kernel: [  508.804053] [drm] drm/i915 developers can then reassign to the right component if it's not a kernel issue.
Oct 30 17:24:52 toughy kernel: [  508.804056] [drm] The gpu crash dump is required to analyze gpu hangs, so please always attach it.
Oct 30 17:24:52 toughy kernel: [  508.805072] [drm:i915_set_reset_status] *ERROR* render ring hung inside bo (0x7908000 ctx 0) at 0x7908ed0
Oct 30 17:24:53 toughy kernel: [  508.864192] [drm] GMBUS [i915 gmbus vga] timed out, falling back to bit banging on pin 2
Oct 30 17:24:53 toughy kernel: [  509.312159] [drm:i915_reset] *ERROR* Failed to reset chip.
Comment 2 Matt Turner 2014-11-14 19:26:26 UTC

*** This bug has been marked as a duplicate of bug 80568 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct.