Bug 85726 - [gen4] GPU hang from scrolling in chrome
Summary: [gen4] GPU hang from scrolling in chrome
Status: RESOLVED DUPLICATE of bug 80568
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i965 (show other bugs)
Version: unspecified
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Ian Romanick
QA Contact: Intel 3D Bugs Mailing List
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-11-01 06:43 UTC by shachar
Modified: 2014-11-14 19:26 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments
The content of /sys/class/drm/card0/error when the GPU crashed (853.19 KB, text/plain)
2014-11-01 06:43 UTC, shachar
Details

Note You need to log in before you can comment on or make changes to this bug.
Description shachar 2014-11-01 06:43:14 UTC
Created attachment 108750 [details]
The content of /sys/class/drm/card0/error when the GPU crashed

When scrolling up and down a google inbox in chromium, my computer display dies. The CPU and network is still available, but the display is completely black.
I'm running ubuntu 14.04, fully updated to date from official repositories.
The machine is a dell inspiron 1525, with an intel GM965/GL960 display card.

The crash is 100% reproducible, so I can test fixes and provide additional information as needed.

The syslog message contains the following indicative lines:


Nov  1 08:08:41 shacharr-Inspiron-1525 kernel: [35964.804220] [drm] stuck on render ring
Nov  1 08:08:41 shacharr-Inspiron-1525 kernel: [35964.804230] [drm] GPU crash dump saved to /sys/class/drm/card0/error
Nov  1 08:08:41 shacharr-Inspiron-1525 kernel: [35964.804233] [drm] GPU hangs can indicate a bug anywhere in the entire gfx stack, including u
serspace.
Nov  1 08:08:41 shacharr-Inspiron-1525 kernel: [35964.804237] [drm] Please file a _new_ bug report on bugs.freedesktop.org against DRI -> DRM/
Intel
Nov  1 08:08:41 shacharr-Inspiron-1525 kernel: [35964.804240] [drm] drm/i915 developers can then reassign to the right component if it's not a
 kernel issue.
Nov  1 08:08:41 shacharr-Inspiron-1525 kernel: [35964.804243] [drm] The gpu crash dump is required to analyze gpu hangs, so please always atta
ch it.
Nov  1 08:08:41 shacharr-Inspiron-1525 kernel: [35964.805413] [drm:i915_set_reset_status] *ERROR* render ring hung inside bo (0xb839000 ctx 0)
 at 0xb83975c
Nov  1 08:08:42 shacharr-Inspiron-1525 kernel: [35965.316262] [drm:i915_reset] *ERROR* Failed to reset chip.
Nov  1 08:08:46 shacharr-Inspiron-1525 kernel: [35969.166248] Watchdog[9404]: segfault at 0 ip 00007f05f4952d98 sp 00007f05e4f2a710 error 6 in
 libcontent.so[7f05f411d000+1170000]
Nov  1 08:08:51 shacharr-Inspiron-1525 kernel: [35974.804172] [drm:i915_gem_wait_for_error] *ERROR* Timed out waiting for the gpu reset to com
plete
Nov  1 08:08:52 shacharr-Inspiron-1525 kernel: [35974.908259] [drm:i915_gem_wait_for_error] *ERROR* Timed out waiting for the gpu reset to com
plete
Nov  1 08:08:52 shacharr-Inspiron-1525 kernel: [35974.968045] [drm] GMBUS [i915 gmbus vga] timed out, falling back to bit banging on pin 2


I attach the dump file from the crash.

--Shachar
Comment 1 Matt Turner 2014-11-14 19:26:38 UTC

*** This bug has been marked as a duplicate of bug 80568 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct.