Bug 85756 - anongit effectively down or unusably slow
Summary: anongit effectively down or unusably slow
Alias: None
Product: freedesktop.org
Classification: Unclassified
Component: Version control (show other bugs)
Version: unspecified
Hardware: Other All
: highest critical
Assignee: fd.o Admin Massive
QA Contact:
Depends on:
Reported: 2014-11-02 12:44 UTC by Tim Müller
Modified: 2016-11-30 22:39 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Description Tim Müller 2014-11-02 12:44:46 UTC
Over the past week anongit access has been either down (as in not responding / timing out) or been extremely slow.

At the time of writing the service does not respond at all [*]

I first reported this on #freenode on Oct 27th when it looked like it wasn't just a temporary fluke. Mithrandir kindly poked around a bit and restored cgit functionality again, but anongit access is still not working reliably.

It would be great if someone could have a look at this.

[*] $ git clone git://anongit.freedesktop.org/gstreamer/common
Cloning into 'common'...
Remote: Counting objects: 30   
real	11m5.156s
user	0m0.000s
sys	0m0.012s

So after 11 minutes the remote starts counting objects at a rate of about 1 every two seconds.
Comment 1 Luis de Bethencourt 2014-11-02 14:18:37 UTC
I am experiencing this as well.
Comment 2 Luis de Bethencourt 2014-11-02 14:29:15 UTC
gst-plugins-base (master) $ git pull
fatal: The remote end hung up upon initial contact

Tim, at least you are getting something ;)
Comment 3 Carl Worth 2014-11-03 19:35:33 UTC
I tried poking around a bit on kemper (anongit.freedesktop.org) today.

I found that from kemper itself I can clone just fine from the local git-daemon:

cworth@kemper:~$ git clone git://
Cloning into 'common'...
remote: Counting objects: 3690, done.
remote: Compressing objects: 100% (1951/1951), done.
remote: Total 3690 (delta 2487), reused 2564 (delta 1729)
Receiving objects: 100% (3690/3690), 571.64 KiB, done.
Resolving deltas: 100% (2487/2487), done.

So this smells like some network problem to me.

The machine and filesystem seem healthy enough, (disk isn't full, CPU isn't loaded, etc.).

I don't really have a clue as to how to go about debugging the network problem, (nor what might have changed).

Comment 4 Carl Worth 2014-11-03 19:38:20 UTC
(In reply to Carl Worth from comment #3)
> I tried poking around a bit on kemper (anongit.freedesktop.org) today.

Ignore the above. kemper is git.freedesktop.org. For anongit.freedesktop.org I should have been looking at molly.freedesktop.org.

Comment 5 Mark Janes 2014-11-03 23:40:24 UTC
seems like it is working at the moment
Comment 6 Tim Müller 2014-11-04 23:21:24 UTC
Looks like things are working again.

Many thanks for investigating and fixing!
Comment 7 Ehsan Azar 2016-11-30 22:39:11 UTC
It seems git://anongit.freedesktop.org/gstreamer/gstreamer is down or unusable.

Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.