Bug 8594 - [i965] Xv causes ring lockups with v1.7.0 intel driver
[i965] Xv causes ring lockups with v1.7.0 intel driver
Status: RESOLVED FIXED
Product: xorg
Classification: Unclassified
Component: Driver/intel
7.1 (2006.05)
x86 (IA32) Linux (All)
: high normal
Assigned To: Keith Packard
:
: 8702 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-10 13:46 UTC by Jack Lloyd
Modified: 2006-11-15 02:58 UTC (History)
8 users (show)

See Also:


Attachments
xv hang fix (1.05 KB, patch)
2006-10-27 00:03 UTC, Wang Zhenyu
no flags Details | Splinter Review
server log (65.49 KB, application/octet-stream)
2006-11-04 15:29 UTC, Nicolas George
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jack Lloyd 2006-10-10 13:46:13 UTC
Running any Xv application causes a complete lockup of the X server ("i830 ring
lockup") using the 1.7.0 driver. I also tried head (as of a couple of days ago),
same results. Using the 1.6.5 driver, Xv works (GL is another story, but that
seems to be a Mesa problem)

This is on a Gentoo 64-bit system with xorg-x11 7.1, mesa 6.5.1, video BIOS
1371. I can send a full logfile if that is of interest/possible use.
Comment 1 Jack Lloyd 2006-10-10 15:15:55 UTC
Some additional info I realized might be helpful:

By "any Xv app", I meant mplayer and ogle, which are the only two Xv
applications I use (with every DVD, MPEG2, or MPEG4 video I tried). With
mplayer, using -vo x11 or -vo gl worked just fine with the same files under
either driver (and also works with -vo xv with the 1.6.5 driver).

The output of `xvinfo` looks OK to me with either version of the driver, so no
hints there I guess.

Finally, the machine is running 2.6.19-rc1 with the in-kernel agpgart driver.
Comment 2 German Monroy 2006-10-11 13:17:52 UTC
I got the same problem here in rawhide (FC6test3 + yum updates) as of yesterday,
playing video with totem.  Also found the same problem on the head of the master
branch in git as of right now.

I used git-bisect and was able to find the offending commit:
1e6e288b8826789f3b2520d12426ff7852a67ccd (`Add a check for intel-gen4asm, and
rules to compile {wm,sf}_prog.h using it').

I reverted only that commit and video played fine.  Eric?
Comment 3 Eric Anholt 2006-10-11 13:29:54 UTC
Excellent, thanks for bisecting down to find the problem.  While I don't have
time to investigate at the moment, I will get to it at some point.
Comment 4 Eric Anholt 2006-10-19 06:23:02 UTC
*** Bug 8702 has been marked as a duplicate of this bug. ***
Comment 5 Wang Zhenyu 2006-10-27 00:03:26 UTC
Created attachment 7542 [details] [review]
xv hang fix

Jack, could you try with this patch to see if it fixes your problem? thanks
Comment 6 Peter Sääf 2006-10-27 09:30:10 UTC
The patch works for me. I was having the same problem as the reporter.
Comment 7 Jack Lloyd 2006-10-27 16:02:14 UTC
Works for me as well. Thanks.
Comment 8 Andrew Barr 2006-10-27 16:09:11 UTC
Yes it works here too. Updated Debian "sid" package here:
http://www.oakcourt.dyndns.org/apt/pool/main/x/xserver-xorg-video-i810/xserver-xorg-video-i810_1.7.2-1_i386.deb
Comment 9 Jack Lloyd 2006-10-29 14:53:15 UTC
Hi,

Just wanted to ask if this patch is going to go into git anytime soon? Gentoo is
blocking on it hitting the official tree before providing it to users (see
https://bugs.gentoo.org/show_bug.cgi?id=153101)
Comment 10 Wang Zhenyu 2006-10-29 22:14:12 UTC
I will push it to the master in a minute. 
Comment 11 Gordon Jin 2006-10-31 18:33:24 UTC
verified with the upstream master.
Comment 12 Nicolas George 2006-11-04 15:28:50 UTC
Hi.

I have a G965 chipset, a freshly compiled GIT X.org, and it hangs while running
Xv apps. So I guess, altough the last log for the driver I compiled was "Bug
8594: Fix Xv hang with G965", the bug is still there.

My setup: kernel 2.6.19-rc4 from kernel.org, motherboard Asus P5B-VM.

Surprisingly, it worked quite fine for a couple of days, and it suddenly started
hanging in the middle of a video; since that, it hangs immediatly every time.

Regards,

-- 
  Nicolas George
Comment 13 Nicolas George 2006-11-04 15:29:36 UTC
Created attachment 7650 [details]
server log
Comment 14 Andrew Barr 2006-11-04 16:05:11 UTC
Are you sure you have either:

a) the patch mentioned in this bug
or b) the git HEAD version of this driver, which includes this patch.

It's not clear from what you wrote that you are using the git HEAD version of
the _driver_, which is where the commit is that fixes this bug.
Comment 15 Nicolas George 2006-11-04 16:38:10 UTC
I am so sorry. I carefully checked that I had indeed a GIT checkout with the
patch applied, and I did not see that I was somehow again using Xorg from Debian
and not my build. Xv with my build works fine.

For my apology, after some thoughts about what happened in the last few days, I
am almost certain that the change to the Debian version of the server occurred
during a server crash caused by another bug. It seems to be a more evasive one,
I will try to get some backtrace as soon as it occurs again.

Regards, and apologies for the wasted time,

-- 
  Nicolas George