Bug 85958 - [i965gm] Render ring hung when watching youtube with Chrome
Summary: [i965gm] Render ring hung when watching youtube with Chrome
Status: RESOLVED DUPLICATE of bug 80568
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i965 (show other bugs)
Version: unspecified
Hardware: x86-64 (AMD64) Linux (All)
: medium major
Assignee: Ian Romanick
QA Contact: Intel 3D Bugs Mailing List
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-11-06 11:20 UTC by coladict
Modified: 2014-11-18 10:26 UTC (History)
2 users (show)

See Also:
i915 platform:
i915 features:


Attachments
the file that the logs said to send (25 bytes, text/plain)
2014-11-06 11:20 UTC, coladict
Details
gpu dump (847.12 KB, text/plain)
2014-11-15 13:05 UTC, Danilo Pianini
Details

Note You need to log in before you can comment on or make changes to this bug.
Description coladict 2014-11-06 11:20:29 UTC
Created attachment 109021 [details]
the file that the logs said to send

This was in my syslog:
Nov  6 12:55:58 localhost kernel: [185676.816028] [drm] stuck on render ring
Nov  6 12:55:58 localhost kernel: [185676.816037] [drm] GPU crash dump saved to /sys/class/drm/card0/error
Nov  6 12:55:58 localhost kernel: [185676.816040] [drm] GPU hangs can indicate a bug anywhere in the entire gfx stack, including userspace.
Nov  6 12:55:59 localhost kernel: [185676.816042] [drm] Please file a _new_ bug report on bugs.freedesktop.org against DRI -> DRM/Intel
Nov  6 12:55:59 localhost kernel: [185676.816045] [drm] drm/i915 developers can then reassign to the right component if it's not a kernel issue.
Nov  6 12:55:59 localhost kernel: [185676.816048] [drm] The gpu crash dump is required to analyze gpu hangs, so please always attach it.
Nov  6 12:55:59 localhost kernel: [185676.817093] [drm:i915_set_reset_status] *ERROR* render ring hung inside bo (0xcd1c000 ctx 0) at 0xcd1dd88
Nov  6 12:55:59 localhost kernel: [185677.328034] [drm:i915_reset] *ERROR* Failed to reset chip.
Nov  6 12:55:59 localhost kernel: [185678.176073] [drm] GMBUS [i915 gmbus vga] timed out, falling back to bit banging on pin 2


I've attached the file, but it won't be of any help. Only additional details I can offer was what I was had open and was doing at the time. I am using XFCE4. Updated all packages no more than a week ago.
Running: mysql 5.5, postgresql 9.3, apache httpd 2.4 with php5.5, netbeans, 3 terminal sessions, GIMP, Dropbox, Google Chrome.
I had just opened a 90-minute YouTube video to listen to in the background as I worked, as I had done many times in the past. First the video froze, while audio kept going, then the mouse pointer stopped moving, but buttons and links reacted to hovering when I moved it. I changed the page and everything else died as well.
Comment 1 Chris Wilson 2014-11-06 11:32:36 UTC
The error state is kept in RAM and so lost when you reboot, if you can reproduce the hang and capture that file before rebooting that will be useful.
Comment 2 Mika Kuoppala 2014-11-06 11:35:15 UTC
The error state is lost on reboot. If you manage to reproduce this and have possibility to ssh into the box, grab the error state before booting and
attach into this bug. Thanks in advance.
Comment 3 Danilo Pianini 2014-11-15 13:05:42 UTC
Created attachment 109518 [details]
gpu dump
Comment 4 Danilo Pianini 2014-11-15 13:06:45 UTC
I was able to reproduce the problem and ssh into the system. I attached the log already.

Steps to reproduce:
1) Open Google Chrome
2) Visit www.youtube.com
3) Open a random video, watch the first 10-20 seconds
4) If the problem does not happen, goto 3 (it normally takes 2-5 attempts)


relevant dmesg:
[40741.804076] [drm] GPU hangs can indicate a bug anywhere in the entire gfx stack, including userspace.
[40741.804079] [drm] Please file a _new_ bug report on bugs.freedesktop.org against DRI -> DRM/Intel
[40741.804081] [drm] drm/i915 developers can then reassign to the right component if it's not a kernel issue.
[40741.804084] [drm] The gpu crash dump is required to analyze gpu hangs, so please always attach it.
[40741.805166] [drm:i915_set_reset_status] *ERROR* render ring hung inside bo (0xe6bb000 ctx 0) at 0xe6bbe58
[40742.316064] [drm:i915_reset] *ERROR* Failed to reset chip.
Comment 5 coladict 2014-11-15 13:13:34 UTC
Also, any chance you could have it rename the old log, instead of overwriting it? That way people wouldn't need a second computer to get the log.
Comment 6 Danilo Pianini 2014-11-15 13:18:23 UTC
You may do the following: switch to a TTY, log in, and pre-type a command such as:

cat /your/dump/file/that/does/not/yet/exist /home/youruser/thedump && reboot

Do not type enter, reproduce the problem on the graphical TTY, then switch back and hit enter. Your pc should reboot, and you should be able to have your dump in your home folder.
Comment 7 Daniel Vetter 2014-11-18 10:15:14 UTC
Another version of gen4 dies on Chrome.
Comment 8 Daniel Vetter 2014-11-18 10:26:24 UTC

*** This bug has been marked as a duplicate of bug 80568 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct.