Bug 8610 - Ugly Dejavu Greek fonts in Fedora Core 6 (t1,t2,t3,devel)
Ugly Dejavu Greek fonts in Fedora Core 6 (t1,t2,t3,devel)
Status: RESOLVED FIXED
Product: freetype
Classification: Unclassified
Component: general
unspecified
x86 (IA32) Linux (All)
: high major
Assigned To: Werner Lemberg
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-11 17:10 UTC by Nikos Charonitakis
Modified: 2008-12-06 16:36 UTC (History)
2 users (show)

See Also:
i915 platform:
i915 features:


Attachments
shows the difference in quality (118.74 KB, image/gif)
2006-10-11 17:18 UTC, Nikos Charonitakis
Details
same picture from Fedora Core 5 + dejavu from extras (81.79 KB, image/png)
2006-10-12 07:36 UTC, Nikos Charonitakis
Details
omicron and ypsilon side by side (438.99 KB, image/png)
2006-10-12 09:09 UTC, Nikos Charonitakis
Details
Shot of default FC6 desktop's browser splash page (141.36 KB, image/png)
2006-10-25 17:34 UTC, Dimitris Glezos
Details
Abiword behaviour (189.14 KB, image/png)
2006-10-25 17:39 UTC, Dimitris Glezos
Details
Same as 7519, but with increased fonts -- yellow box on the right is OK now (138.50 KB, image/png)
2006-10-25 17:53 UTC, Dimitris Glezos
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Nikos Charonitakis 2006-10-11 17:10:12 UTC
I ve test various versions of the upcoming FC6 and all of them have the same
problem with Greek characters.
Fonts everywhere have different size, they appear blured and ugly.
I think that this is true only for the default size used by fedora core (10).
If someone increase the size of the font then the font start looking better...
In fedora core 5, dejavu installed from the extras repo showed a good quality
with Greek fonts. I think that maybe this is not dejavu  problem, but from where
it comes from?
Comment 1 Nikos Charonitakis 2006-10-11 17:18:12 UTC
Created attachment 7368 [details]
shows the difference in quality

this image shows difference between ubuntu 6.06 (dejavu fonts) and a fedora
core test release (dejavu fonts). Watch the blue headers to see the problem.
I can see such differences and in comparison between FC5 and FC6test but i have
not an image available.
Note:
this problem appears in all FC6 test releases and in FC6 devel
Comment 2 Nikos Charonitakis 2006-10-12 07:36:27 UTC
Created attachment 7381 [details]
same picture from Fedora Core 5 + dejavu from extras
Comment 3 Ben Laenen 2006-10-12 08:40:06 UTC
The screenshot of Fedora is not showing the latest DejaVu version. The problem 
was there that not all glyphs were hinted in that specific release of DejaVu. 
The Greek letters in Sans Bold are now fully hinted, so just updating your 
DejaVu fonts will fix this problem.
Comment 4 Nikos Charonitakis 2006-10-12 08:57:03 UTC
thanks for the quick reply but i have used latest rawhide version of FC6 with
dejavu 2.10 and the problem is still there...
Also there are problems with non bold fonts (different sizes and glitches)
Comment 5 Nikos Charonitakis 2006-10-12 09:09:17 UTC
Created attachment 7387 [details]
omicron and ypsilon side by side

see the second menu third from the top entry the last two letters (compare
their size)

Omicron and ypsilon have different size: see epexergastis keimenou (last two
letters). Also see alpha:it certainly looks inferior to a FC5+dejavu from
extras
compination
Comment 6 Ben Laenen 2006-10-12 09:12:46 UTC
If you get the same result as the first Fedora screenshot, you are using the 
bytecode interpreter in FreeType (you use the hinting from the font), but not 
the latest DejaVu. Resolution: update DejaVu.

If you get the same result as the second Fedora screenshot, you are using the 
autohinter in FreeType (you discard the hinting from the font, generally 
resulting in worse results, like the phi which doesn't have his vertical line 
centered). Resolution: enable the bytecode interpreter in FreeType and disable 
autohinting, and make sure to use the latest version of DejaVu. Fedora by 
default disables the bytecode interpreter because of patent issues.
Comment 7 Nikos Charonitakis 2006-10-12 09:32:36 UTC
ok ben i dont know much about font technology but i have one more question:
A)i use fc5+dejavu-fonts 2.10
B)i use fc6devel+dejavu-fonts 2.10

in the first system everything is fine
in the second system i report these problems.

i suppose that bytecode interpreter is disabled on both systems...

so where is the source of the problem?
Comment 8 Ben Laenen 2006-10-12 09:52:18 UTC
maybe you forgot to restart the programs after updating the fonts? (in case of 
Firefox, it will only restart if all windows in Firefox are closed). The main 
menus will only use the new fonts if you restart your desktop.
Comment 9 Nikos Charonitakis 2006-10-12 09:57:58 UTC
i think that i restarted my pc completely but i ll check it again once more (not
today, but i ll do it).
I will inform you as soon as possible...
Comment 10 Dimitris Glezos 2006-10-12 10:09:29 UTC
Ben,

do the autohinter developers study these kind of screenshots to improve the
autohinter in particular characters? For example, we see that ypsilon "υ" is
particularly big. Some other improvements might include somewhat big omega "ω"
and ni "ν" and the upper-right part of alpha "α" being too fuzzy.

Unfortunately, Fedora is pretty strict about patents etc, so I don't think
enabling the bytecode interpreter is a choice. Especially if we consider that
this affects all languages, then unless someone ensures somehow that they won't
get into trouble, then I see that as a WONTFIX.
Comment 11 Ben Laenen 2006-10-12 10:36:57 UTC
There is a person from FreeType we could assign this bug to. I don't have time 
anymore now to do that, maybe you could look it up? He has been assigned in a 
few other autohinter bugs in this bugzilla.

Indeed, Fedora would probably never switch to the bytecode interpreter. But 
all I can wish for is that the users switch to it as much as possible. We have 
no control at all about the behaviour of the autohinter, yet users will always 
think it's an error in the font.

Also, I'm coming back on the claim that the first screenshot from Fedora is 
showing an old version of DejaVu. After looking into it a bit better, the 
wrong glyphs are too big for that. The autohinter is being used in that 
screenshot, so I'm afraid that it's also an autohinter bug...
Comment 12 Nikos Charonitakis 2006-10-17 14:41:31 UTC
i have some news. After further testing on this problem i realized that bigger
and smaller font sizes (than the default 10) works good.
Also tiny fonts used in graphical boot (rhgb) are also fine. What is the problem
here?
Comment 13 Dimitris Glezos 2006-10-17 16:44:02 UTC
Nikos, can you give us a screenshot showing this behaviour of size-10 fonts in
various languages? You can grab some multilingual test from the DejaVu site I guess.
Comment 14 Dimitris Glezos 2006-10-25 17:34:50 UTC
Created attachment 7519 [details]
Shot of default FC6 desktop's browser splash page

Ben, Firefox and the Fedora menus seem not OK in default FC6 (see attached
shot).

Boxes in shot:
  * #2 : The bold Sans font is very ugly>
  * #3 : While in #4 the Serif is OK, in #3 where the font size is decreased,
it is ugly again.

Any ideas?
Comment 15 Dimitris Glezos 2006-10-25 17:39:49 UTC
Created attachment 7520 [details]
Abiword behaviour

Check out this Abiword shot.

On the bottom of the screen there are two titlebars that show ugly fonts.

I have no idea what's going wrong, we would really need some help...
Comment 16 Dimitris Glezos 2006-10-25 17:53:05 UTC
Created attachment 7521 [details]
Same as 7519, but with increased fonts -- yellow box on the right is OK now

Oh, and another observation. In attachment #7519 [details], in box #3, some of the
characters are not even Dejavu Sans (like "χ")!

This screenshot shows that when the font size is increased from the Firefox
menu, the text is not ugly any more and "χ" is displayed in DejaVu Sans.

The ugly headings seem to use the same font though in both shots.
Comment 17 Ben Laenen 2006-10-27 03:54:09 UTC
(In reply to comment #16)
> Oh, and another observation. In attachment #7519 [details] [edit], in box #3, some of 
> the characters are not even Dejavu Sans (like "χ")!

I presume you mean DejaVu Serif there. Anyway, the glyph looks like it's DV 
Serif to me, the autohinter just stretches some parts, while it doesn't 
stretch other parts, which makes the glyph look different. η has the same 
behaviour. Why it happens? I don't know, you should ask the Freetype people 
who are in charge of the autohinter.

I think the autohinter sees the height of the curved lines, which is a little 
higher than the straight lines, and interprets it as a significant difference 
at those sizes. That's the difference between manual hinting and autohinting: 
the autohinter has to guess all that with some clever algorithms, in manual 
hinting we tell how the glyph should look. With the effect that the autohinter 
guesses wrongly from time to time, and makes the glyphs look bad.

Anyway, I don't remember any reports about this earlier. Maybe try out an 
earlier Freetype version, to see if it's only in the latest versions of 
Freetype. You should really report this to the Freetype project.
Comment 18 Ben Laenen 2006-11-19 13:50:59 UTC
going to close this as NOTOURBUG as this is a Freetype autohinter bug.
Comment 19 Nicolas Mailhot 2008-12-06 11:25:15 UTC
Mass move of freetype bugs to the new freetype product
Comment 20 Nicolas Mailhot 2008-12-06 11:27:44 UTC
Reopen the NOTOURBUG reports now they're correctly affected
Comment 21 Werner Lemberg 2008-12-06 16:36:25 UTC
Looking at a recent DejaVuSans version, I can't see problems with Greek.
In case you still have issues, please test the affected font with a FreeType
demo program like ftview ftstring.  Providing just screenshots is of no
great help since it is hard to guess what exact parameters influence the
rendering process.