Bug 86133 - Graphics Driver Fails to Restart Post Suspend
Summary: Graphics Driver Fails to Restart Post Suspend
Status: RESOLVED DUPLICATE of bug 42960
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/Radeon (show other bugs)
Version: unspecified
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Default DRI bug account
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-11-11 00:03 UTC by Samuel Mercier
Modified: 2014-11-11 14:24 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
Dmesg file (149.35 KB, text/plain)
2014-11-11 00:03 UTC, Samuel Mercier
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Samuel Mercier 2014-11-11 00:03:57 UTC
Created attachment 109255 [details]
Dmesg file

I followed the instructions here (https://01.org/linuxgraphics/documentation/how-debug-suspend-resume-issues-0) and they told me to post stuff here asking for help. I included the DMESG record that they had me create within those instructions.
Comment 1 Michel Dänzer 2014-11-11 02:25:23 UTC
What are the symptoms of your problem?
Comment 2 Samuel Mercier 2014-11-11 03:22:33 UTC
(In reply to Michel Dänzer from comment #1)
> What are the symptoms of your problem?

The symptoms are that my computer's screen is completely black and non responsive, even when the rest of the system has completely woken up.
Comment 3 Michel Dänzer 2014-11-11 04:20:14 UTC
(In reply to Samuel Mercier from comment #2)
> The symptoms are that my computer's screen is completely black and non
> responsive, even when the rest of the system has completely woken up.

So the rest of the system is still responsive though? There are no obvious radeon driver related problems in dmesg, so it sounds like it just fails to light up the screen after resume.

Did this already happen with older kernels, or is it a regression?
Comment 4 Samuel Mercier 2014-11-11 04:27:50 UTC
(In reply to Michel Dänzer from comment #3)
> (In reply to Samuel Mercier from comment #2)
> > The symptoms are that my computer's screen is completely black and non
> > responsive, even when the rest of the system has completely woken up.
> 
> So the rest of the system is still responsive though? There are no obvious
> radeon driver related problems in dmesg, so it sounds like it just fails to
> light up the screen after resume.
> 
> Did this already happen with older kernels, or is it a regression?

About 2 years ago I think I got it to work with arch, but otherwise it's pretty much never worked.

Is there a way to get it to get the screen on and showing the pretty things?
Comment 5 Alex Deucher 2014-11-11 14:24:30 UTC

*** This bug has been marked as a duplicate of bug 42960 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct.