Bug 8637 - [radeon] Driver does not support GLX_SGI_make_current_read
[radeon] Driver does not support GLX_SGI_make_current_read
Status: RESOLVED FIXED
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/R100
git
x86 (IA32) Linux (All)
: high normal
Assigned To: Default DRI bug account
:
Depends on:
Blocks: xorg-7.2
  Show dependency treegraph
 
Reported: 2006-10-13 11:53 UTC by Ian Romanick
Modified: 2009-08-24 12:24 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ian Romanick 2006-10-13 11:53:36 UTC
Driver does not support GLX_SGI_make_current_read.  This extension is required
for GLX 1.3 and is therefore required to support compiz with AIGLX.
Comment 1 Joachim Frieben 2006-10-13 12:39:22 UTC
Hm, .. "compiz"/"AIGLX" works just fine with my "R100" based vido card using the
"radeon" driver. I am using "Xorg" release 7.1.1 on a "Fedora development"
system, and when I execute "glxinfo", then "GLX_SGI_make_current_read" is well
among both the server and client options.
However, "GLX version: 1.2" actually differs from version "1.3" that you require
above.
Comment 2 Ian Romanick 2006-11-10 10:54:34 UTC
Fix committed to Mesa CVS.  Will be included in 6.5.2 release.
Comment 3 ajax at nwnk dot net 2009-08-24 12:24:39 UTC
Mass version move, cvs -> git