Bug 86769 - [BSW]Piglit spec_glsl-1.50_execution_geometry_primitive-id-restart_GL_LINES_ffs fails
Summary: [BSW]Piglit spec_glsl-1.50_execution_geometry_primitive-id-restart_GL_LINES_f...
Status: VERIFIED DUPLICATE of bug 84777
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i965 (show other bugs)
Version: unspecified
Hardware: All Linux (All)
: medium normal
Assignee: Ben Widawsky
QA Contact: Intel 3D Bugs Mailing List
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-11-27 08:07 UTC by lu hua
Modified: 2014-12-16 05:51 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description lu hua 2014-11-27 08:07:59 UTC
System Environment:
--------------------------
Platform: BSW
Libdrm:		(master)libdrm-2.4.58-13-gfb4177046de19730a784c3c16e4b73aab0ec6e41
Mesa:		(master)531feec9dc4680046f21c517d13312c7df7b7619
Xserver:	(master)xorg-server-1.16.99.901-17-gc52a2b1ebad56820af932dfbc871701a8b04fd9c
Xf86_video_intel:(master)2.99.916-154-g0f15b8b45bb6de10ce1926db303247a5bd3c1c08
Libva:		(master)c095cc6cf08523cd0dffcfe5ac4bce9122527f22
Libva_intel_driver:	(master)edbb8cdada09cd116103e68f942b0889fd767391
Kernel:   (drm-intel-nightly)a834a782adf3ab4b508cd80e9082960263bcc4ed

Bug detailed description:
-----------------------------
It fails on bsw with mesa master branch. it was pass in earlier automation testing, but I am unable to reproduce the pass.
Following cases also fail:
spec_glsl-1.50_execution_geometry_primitive-id-restart_GL_LINES_other
spec_glsl-1.50_execution_geometry_primitive-id-restart_GL_LINE_LOOP_ffs
spec_glsl-1.50_execution_geometry_primitive-id-restart_GL_LINE_LOOP_other
spec_glsl-1.50_execution_geometry_primitive-id-restart_GL_LINE_STRIP_ffs
spec_glsl-1.50_execution_geometry_primitive-id-restart_GL_LINE_STRIP_other
spec_glsl-1.50_execution_geometry_primitive-id-restart_GL_POINTS_ffs
spec_glsl-1.50_execution_geometry_primitive-id-restart_GL_POINTS_other
spec_glsl-1.50_execution_geometry_primitive-id-restart_GL_TRIANGLES_ffs
spec_glsl-1.50_execution_geometry_primitive-id-restart_GL_TRIANGLES_other
spec_glsl-1.50_execution_geometry_primitive-types_GL_LINES
spec_glsl-1.50_execution_geometry_primitive-types_GL_LINE_STRIP
spec_glsl-1.50_execution_geometry_primitive-types_GL_TRIANGLE_FAN
spec_glsl-1.50_execution_geometry_primitive-types_GL_TRIANGLE_STRIP
spec_glsl-1.50_execution_geometry_tri-strip-ordering-with-prim-restart_GL_TRIANGLE_STRIP_ffs
spec_glsl-1.50_execution_geometry_tri-strip-ordering-with-prim-restart_GL_TRIANGLE_STRIP_other
spec_glsl-1.50_transform-feedback-type-and-size

output:
Expected primitive 1 to have gl_PrimitiveIDIn = 1, got 0 instead
Expected primitive 2 to have gl_PrimitiveIDIn = 2, got 0 instead
Expected primitive 6 to have gl_PrimitiveIDIn = 6, got 0 instead
Expected primitive 8 to have gl_PrimitiveIDIn = 8, got 16 instead
Expected primitive 9 to have gl_PrimitiveIDIn = 9, got 0 instead
Expected primitive 12 to have gl_PrimitiveIDIn = 12, got 14 instead
Expected primitive 14 to have gl_PrimitiveIDIn = 14, got 0 instead
Expected primitive 16 to have gl_PrimitiveIDIn = 16, got 0 instead
Expected primitive 18 to have gl_PrimitiveIDIn = 18, got 0 instead
Expected primitive 20 to have gl_PrimitiveIDIn = 20, got 0 instead
Expected primitive 22 to have gl_PrimitiveIDIn = 22, got 0 instead
Expected primitive 24 to have gl_PrimitiveIDIn = 24, got 0 instead
Expected primitive 25 to have gl_PrimitiveIDIn = 25, got 0 instead
Expected primitive 27 to have gl_PrimitiveIDIn = 27, got 0 instead
Expected primitive 29 to have gl_PrimitiveIDIn = 29, got 0 instead
Expected primitive 32 to have gl_PrimitiveIDIn = 32, got 0 instead
Expected primitive 34 to have gl_PrimitiveIDIn = 34, got 0 instead
PIGLIT: {"result": "fail" }

pass log:
Output:
 bin/glsl-1.50-geometry-primitive-id-restart GL_LINES ffs -auto -fbo
PIGLIT: {"result": "pass" }

Piglit
returncode: 0
result: pass
summary: Piglit/spec_glsl-1.50_execution_geometry_primitive-id-restart_GL_LINES_ffs    PASS

Reproduce steps:
---------------------------- 
1. xinit
2. ./bin/glsl-1.50-geometry-primitive-id-restart GL_LINES ffs -auto -fbo
Comment 1 Ben Widawsky 2014-12-04 02:49:18 UTC

*** This bug has been marked as a duplicate of bug 84777 ***
Comment 2 lu hua 2014-12-16 05:51:44 UTC
Verified.Fixed.
root@x-bsw01:/GFX/Test/Piglit/piglit# bin/glsl-1.50-geometry-primitive-id-restart GL_LINES ffs -auto -fbo
libGL: OpenDriver: trying /opt/X11R7/lib/dri/tls/i965_dri.so
libGL: OpenDriver: trying /opt/X11R7/lib/dri/i965_dri.so
PIGLIT: {"result": "pass" }


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.