Bug 86898 - often it appears as blurry things, it happens when memory is busy or full 4/5 applications opened
Summary: often it appears as blurry things, it happens when memory is busy or full 4/5...
Status: CLOSED DUPLICATE of bug 28813
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/Intel (show other bugs)
Version: unspecified
Hardware: x86-64 (AMD64) Linux (All)
: medium critical
Assignee: Intel GFX Bugs mailing list
QA Contact: Intel GFX Bugs mailing list
URL: https://drive.google.com/file/d/0Bzh8...
Whiteboard: intel-graphics
Keywords: NEEDINFO
Depends on:
Blocks:
 
Reported: 2014-12-01 10:52 UTC by Tofeeq
Modified: 2017-07-24 22:50 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Tofeeq 2014-12-01 10:52:48 UTC
I am using arch linux for quite a while but worried about its graphic rendering 
often it appears as blurry things, it happens when memory is busy or full 4/5 applications opened
any suggestion?
screenshot
https://drive.google.com/file/d/0Bzh8iiZ1gJr3eDRwdzlZRDB1OWs/view?usp=sharing
https://drive.google.com/file/d/0Bzh8iiZ1gJr3cXlEMnBkWVBwaU0/view?usp=sharing
Graphics
Processor: Mobile Intel® Graphics Media 
Accelerator 4500MHD with Intel® Clear Video 
Technology with Total Available Graphics 
Memory of 1340MB (max.)
Chipset: Intel® GM45 Express Chipset
Comment 1 Chris Wilson 2014-12-02 11:31:38 UTC
commit 656bfa3afc14e45e2d9e1624bf60d79b3beb12f2
Author: Daniel Vetter <daniel.vetter@ffwll.ch>
Date:   Thu Nov 20 09:26:30 2014 +0100

    drm/i915: Pin tiled objects for L-shaped configs
    
    Let's just throw in the towel on this one and take the cheap way out.
    
    Based on a patch from Chris Wilson, but checking for a different bit.
    Chris' patch checked for even bank layout, this one here for a magic
    bit. Given the evidence we've gathered (not much) both work I think,
    but checking for the magic bit might be more accurate.
    
    Anyway, works on my gm45 here.
    
    For paranoi restrict to gen4 (and mobile), since we've only ever seen
    this on gm45 and i965gm.
    
    Also add some debugfs output so that we can skip the tiled swapping
    tests properly in these cases.
    
    v2: Clean up the quirk'ed pin count in free_object to avoid upsetting
    the WARN_ON. Spotted by Chris.
    
    Cc: Chris Wilson <chris@chris-wilson.co.uk>
    Bugzilla: https://bugs.freedesktop.org/show_bug.cgi?id=28813
    Bugzilla: https://bugs.freedesktop.org/show_bug.cgi?id=45092
    Signed-off-by: Daniel Vetter <daniel.vetter@intel.com>
    Reviewed-by: Chris Wilson <chris@chris-wilson.co.uk>
    Signed-off-by: Daniel Vetter <daniel.vetter@ffwll.c
Comment 2 Chris Wilson 2014-12-02 11:32:00 UTC

*** This bug has been marked as a duplicate of bug 28813 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.