Bug 86972 - [gen4] GPU hang in Chrome
Summary: [gen4] GPU hang in Chrome
Status: RESOLVED DUPLICATE of bug 80568
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i965 (show other bugs)
Version: unspecified
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Ian Romanick
QA Contact: Intel 3D Bugs Mailing List
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-12-03 13:13 UTC by Christian Lohmaier
Modified: 2015-04-30 18:17 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments
gpu crash dump (849.49 KB, text/plain)
2014-12-03 13:13 UTC, Christian Lohmaier
Details
journalctl log from crash with traces and suspend/resume cycle (172.91 KB, text/plain)
2014-12-03 13:14 UTC, Christian Lohmaier
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Christian Lohmaier 2014-12-03 13:13:07 UTC
Created attachment 110408 [details]
gpu crash dump

easiest way to trigger the problem is by watching youtube videos with chromium browser in gnome3 - but also occurs when loading openstreetmap widget in the browser.

This is with a Fujitsu Esprimo Mobile U9200 notebook, Intel 965GM integrated graphics, using Mageia 4

Symptoms:
* Screen goes black, switching to different virtual consoles or attempt to switch brightness doesn't bring it back on.

* suspend to RAM and waking it up brings back the display
  although gnome-session fails to resume, shows the "cannot recover, log-out" screen. You can kill the gnome-session-failed process from a VT and launch metacity or some other window manager to clean up/save your documents though.
Comment 1 Christian Lohmaier 2014-12-03 13:14:03 UTC
Created attachment 110409 [details]
journalctl log from crash with traces and suspend/resume cycle
Comment 2 Christian Lohmaier 2014-12-03 14:16:54 UTC
the suggestion from bug#80568#c62 (setting always_flush_cache=true) seems to workaround my problem as well, so very likely duplicate.
Comment 3 Matt Turner 2015-03-06 23:27:25 UTC
I suspect this may be another duplicate of the bug 80568, fixed (worked-around) by this commit:

commit c4fd0c9052dd391d6f2e9bb8e6da209dfc7ef35b
Author: Kenneth Graunke <kenneth@whitecape.org>
Date:   Sat Jan 17 23:21:15 2015 -0800

    i965: Work around mysterious Gen4 GPU hangs with minimal state changes.
    
    Gen4 hardware appears to GPU hang frequently when using Chromium, and
    also when running 'glmark2 -b ideas'.  Most of the error states contain
    3DPRIMITIVE commands in quick succession, with very few state packets
    between them - usually VERTEX_BUFFERS/ELEMENTS and CONSTANT_BUFFER.
    
    I trimmed an apitrace of the glmark2 hang down to two draw calls with a
    glUniformMatrix4fv call between the two.  Either draw by itself works
    fine, but together, they hang the GPU.  Removing the glUniform call
    makes the hangs disappear.  In the hardware state, this translates to
    removing the CONSTANT_BUFFER packet between the two 3DPRIMITIVE packets.
    
    Flushing before emitting CONSTANT_BUFFER packets also appears to make
    the hangs disappear.  I observed a slowdown in glxgears by doing it all
    the time, so I've chosen to only do it when BRW_NEW_BATCH and
    BRW_NEW_PSP are unset (i.e. we haven't done a CS_URB_STATE change or
    already flushed the whole pipeline).
    
    I'd much rather understand the problem, but at this point, I don't see
    how we'd ever be able to track it down further.  We have no real tools,
    and the hardware people moved on years ago.  I've analyzed 20+ error
    states and read every scrap of documentation I could find.
    
    Bugzilla: https://bugs.freedesktop.org/show_bug.cgi?id=80568
    Bugzilla: https://bugs.freedesktop.org/show_bug.cgi?id=85367
    Signed-off-by: Kenneth Graunke <kenneth@whitecape.org>
    Acked-by: Matt Turner <mattst88@gmail.com>
    Cc: "10.4 10.3" <mesa-stable@lists.freedesktop.org>

It's in git, and backports are in Mesa 10.4.x for x > 3. Please try upgrading to >10.4.3. If it's resolved by such an upgrade, please mark as a duplicate of bug 80568.
Comment 4 Matt Turner 2015-04-30 18:17:12 UTC
No reply. Marking as duplicate.

*** This bug has been marked as a duplicate of bug 80568 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct.