Bug 87059 - [apitrace] Graphical glitches in This war of mine
Summary: [apitrace] Graphical glitches in This war of mine
Status: RESOLVED FIXED
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/Gallium/radeonsi (show other bugs)
Version: git
Hardware: Other All
: medium normal
Assignee: Default DRI bug account
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-12-06 23:09 UTC by Jarkko K
Modified: 2018-08-02 00:42 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments
glitches (1.88 MB, image/png)
2014-12-06 23:09 UTC, Jarkko K
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jarkko K 2014-12-06 23:09:11 UTC
Created attachment 110519 [details]
glitches

I just bought This war of mine and there is some animation at start and it has weird black boxes.
Comment 1 Jarkko K 2014-12-06 23:17:11 UTC
Actually those boxes are while playing the game. I just tried shortly.
Comment 2 smoki 2014-12-07 06:16:19 UTC
 I just got that game too, but can't reproduce this on Kabini - 3.18 kernel, mesa git 043b7946, llvm 3.6~svn223349

 So Jarkko i think more information is needed, so which card you use, kernel, mesa, llvm version...

 Also you might mention game version, because it is currently new game and frequently updated.
Comment 3 Jarkko K 2014-12-07 19:42:52 UTC
Can you provide me info how to get this info?

Linux 3.18.0-031800rc7-generic

DISTRIB_DESCRIPTION="Linux Mint 17 Qiana"

[Properties]
"opengl.version"="3.0 Mesa 10.5.0-devel (git-d8da6de 2014-12-06 trusty-oibaf-ppa)"
Comment 4 Jarkko K 2014-12-07 19:51:39 UTC
I think game version is 1.1.3

Also I noticed on second run that Some of those black boxes go away temporary and come back on next second.
Comment 5 smoki 2014-12-08 19:37:44 UTC
(In reply to Jarkko K from comment #3)
> 
> [Properties]
> "opengl.version"="3.0 Mesa 10.5.0-devel (git-d8da6de 2014-12-06
> trusty-oibaf-ppa)"

 That ppa still use llvm-3.5, OK. Yes i manage to reporuduce it now with llvm-3.5 and with GFX Quality high setted in game, but with low issue is not there.

 Anyway issue as i see is mostly fixed if current mesa is compiled against llvm-3.6 svn. 

 I don't use ubuntu but you might want to try some ppas which does that like this one - not day to day up to date, but hopefully should work at least for you to check if this issue still appear there for you?

 https://launchpad.net/~paulo-miguel-dias/+archive/ubuntu/mesa
Comment 6 Jarkko K 2014-12-08 19:52:50 UTC
I am not so keen on changing ppa, but I tried the graphic quality. I changed it from high to low and the boxes are gone.

Any idea what causes this?
Comment 7 smoki 2014-12-08 20:24:37 UTC
(In reply to Jarkko K from comment #6)
> 
> Any idea what causes this?

 Not sure probably what happens in some other games like in bug 86038 , major blackiness which came from lighting seems to gone using llvm-3.6 there too, but still not completely even if you use llvm-3.6, most likely this comment goes to the right track:

 https://bugs.freedesktop.org/show_bug.cgi?id=83510#c8

 It is discussed on mesa ml, so hopefully it will get fixed soon :)

 http://lists.freedesktop.org/archives/mesa-dev/2014-December/071973.html
Comment 8 Jarkko K 2014-12-08 23:40:48 UTC
I visited some place during night at the game, the black boxes game back on that map, but not on the starting map.
Comment 9 Jarkko K 2014-12-10 01:21:43 UTC
Empire total war came to linux (9.12) and I just shortly tried it. There are some flags in the game, from far distance they sometimes become white. The effect is similar to this.
Comment 10 Marek Olšák 2015-08-02 11:29:50 UTC
This looks like the issue with NaNs. NaNs are currently disabled in the driver. The glitches should either be gone or manifest in a different way. Can you re-test?
Comment 11 Timothy Arceri 2018-04-11 04:10:34 UTC
The black boxes are gone but there are other rendering issues. I've create an apitrace [1].

There is a shader that fails to compile due to a shader bug but thats not the problem as the trace runs fine on the Nvidia blob. 

Running on Nvidia also produces warnings:
"Texture state usage warning: Texture 0 is base level inconsistent. Check texture size."

[1] https://drive.google.com/open?id=1v94W9c_H9EAF4iWQYUXU9oux5RPt0vw_
Comment 12 Timothy Arceri 2018-08-02 00:42:07 UTC
(In reply to Timothy Arceri from comment #11)
> The black boxes are gone but there are other rendering issues. I've create
> an apitrace [1].
> 
> There is a shader that fails to compile due to a shader bug but thats not
> the problem as the trace runs fine on the Nvidia blob. 
> 
> Running on Nvidia also produces warnings:
> "Texture state usage warning: Texture 0 is base level inconsistent. Check
> texture size."
> 
> [1] https://drive.google.com/open?id=1v94W9c_H9EAF4iWQYUXU9oux5RPt0vw_

Nevermind, I think I have some kind of hardware (memory) fault with one of my gpus. I've retested and this game works fine.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.