Bug 87088 - [gen4] GPU hang when watching video (e.g. youtube)
Summary: [gen4] GPU hang when watching video (e.g. youtube)
Status: RESOLVED DUPLICATE of bug 80568
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i965 (show other bugs)
Version: unspecified
Hardware: x86 (IA32) Linux (All)
: medium normal
Assignee: Ian Romanick
QA Contact: Intel 3D Bugs Mailing List
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-12-08 03:14 UTC by Dan Streetman
Modified: 2015-03-10 17:06 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments
/sys/class/drm/card0/error (848.19 KB, text/plain)
2014-12-08 03:15 UTC, Dan Streetman
Details
/var/log/messages since boot (511.59 KB, text/plain)
2014-12-08 03:25 UTC, Dan Streetman
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Dan Streetman 2014-12-08 03:14:12 UTC
This is on a Panasonic Toughbook CF-30, running Fedora 19.

When I start a video, e.g. any youtube page, the screen turns off.  I have to either reboot, or I can suspend and resume, which turns the screen back on.
Comment 1 Dan Streetman 2014-12-08 03:15:46 UTC
Created attachment 110552 [details]
/sys/class/drm/card0/error
Comment 2 Dan Streetman 2014-12-08 03:25:45 UTC
Created attachment 110553 [details]
/var/log/messages since boot
Comment 3 Matt Turner 2015-03-06 23:27:13 UTC
I suspect this may be another duplicate of the bug 80568, fixed (worked-around) by this commit:

commit c4fd0c9052dd391d6f2e9bb8e6da209dfc7ef35b
Author: Kenneth Graunke <kenneth@whitecape.org>
Date:   Sat Jan 17 23:21:15 2015 -0800

    i965: Work around mysterious Gen4 GPU hangs with minimal state changes.
    
    Gen4 hardware appears to GPU hang frequently when using Chromium, and
    also when running 'glmark2 -b ideas'.  Most of the error states contain
    3DPRIMITIVE commands in quick succession, with very few state packets
    between them - usually VERTEX_BUFFERS/ELEMENTS and CONSTANT_BUFFER.
    
    I trimmed an apitrace of the glmark2 hang down to two draw calls with a
    glUniformMatrix4fv call between the two.  Either draw by itself works
    fine, but together, they hang the GPU.  Removing the glUniform call
    makes the hangs disappear.  In the hardware state, this translates to
    removing the CONSTANT_BUFFER packet between the two 3DPRIMITIVE packets.
    
    Flushing before emitting CONSTANT_BUFFER packets also appears to make
    the hangs disappear.  I observed a slowdown in glxgears by doing it all
    the time, so I've chosen to only do it when BRW_NEW_BATCH and
    BRW_NEW_PSP are unset (i.e. we haven't done a CS_URB_STATE change or
    already flushed the whole pipeline).
    
    I'd much rather understand the problem, but at this point, I don't see
    how we'd ever be able to track it down further.  We have no real tools,
    and the hardware people moved on years ago.  I've analyzed 20+ error
    states and read every scrap of documentation I could find.
    
    Bugzilla: https://bugs.freedesktop.org/show_bug.cgi?id=80568
    Bugzilla: https://bugs.freedesktop.org/show_bug.cgi?id=85367
    Signed-off-by: Kenneth Graunke <kenneth@whitecape.org>
    Acked-by: Matt Turner <mattst88@gmail.com>
    Cc: "10.4 10.3" <mesa-stable@lists.freedesktop.org>

It's in git, and backports are in Mesa 10.4.x for x > 3. Please try upgrading to >10.4.3. If it's resolved by such an upgrade, please mark as a duplicate of bug 80568.
Comment 4 Dan Streetman 2015-03-10 12:46:03 UTC
I updated to fedora 21, which has mesa 10.4.3 plus whatever patches the fedora team added (maybe including the above patch), and everything seems to work now, so we can close this.
Comment 5 Matt Turner 2015-03-10 17:06:48 UTC
Thanks for confirming!

*** This bug has been marked as a duplicate of bug 80568 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct.