Bug 87276 - u_atomic_test.c:108:1: error: implicit declaration of function 'test_atomic_cmpxchg_int16_t'
Summary: u_atomic_test.c:108:1: error: implicit declaration of function 'test_atomic_c...
Status: RESOLVED MOVED
Alias: None
Product: Mesa
Classification: Unclassified
Component: Mesa core (show other bugs)
Version: 10.5
Hardware: x86-64 (AMD64) NetBSD
: medium blocker
Assignee: mesa-dev
QA Contact:
URL:
Whiteboard:
Keywords: bisected, regression
Depends on:
Blocks:
 
Reported: 2014-12-13 09:05 UTC by Vinson Lee
Modified: 2019-09-18 20:23 UTC (History)
2 users (show)

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Vinson Lee 2014-12-13 09:05:32 UTC
mesa: 23caba862a001f82ef352307a79bebf7ef910959 (master 10.5.0-devel)

Build error on NetBSD.

  CC       u_atomic_test.o
u_atomic_test.c: In function 'test_atomic_int16_t':
u_atomic_test.c:108:1: error: implicit declaration of function 'test_atomic_cmpxchg_int16_t'
u_atomic_test.c: In function 'test_atomic_uint16_t':
u_atomic_test.c:109:1: error: implicit declaration of function 'test_atomic_cmpxchg_uint16_t'
u_atomic_test.c: In function 'test_atomic_int32_t':
u_atomic_test.c:110:1: error: implicit declaration of function 'test_atomic_cmpxchg_int32_t'
u_atomic_test.c: In function 'test_atomic_uint32_t':
u_atomic_test.c:111:1: error: implicit declaration of function 'test_atomic_cmpxchg_uint32_t'
u_atomic_test.c: In function 'test_atomic_int64_t':
u_atomic_test.c:112:1: error: implicit declaration of function 'test_atomic_cmpxchg_int64_t'
u_atomic_test.c: In function 'test_atomic_uint64_t':
u_atomic_test.c:113:1: error: implicit declaration of function 'test_atomic_cmpxchg_uint64_t'
u_atomic_test.c: At top level:
u_atomic_test.c:108:1: warning: 'test_atomic_cmpxchg___int16_t' defined but not used
u_atomic_test.c:109:1: warning: 'test_atomic_cmpxchg___uint16_t' defined but not used
u_atomic_test.c:110:1: warning: 'test_atomic_cmpxchg___int32_t' defined but not used
u_atomic_test.c:111:1: warning: 'test_atomic_cmpxchg___uint32_t' defined but not used
u_atomic_test.c:112:1: warning: 'test_atomic_cmpxchg___int64_t' defined but not used
u_atomic_test.c:113:1: warning: 'test_atomic_cmpxchg___uint64_t' defined but not used
Comment 1 Vinson Lee 2014-12-15 20:10:39 UTC
a208e9b520ae2d854ae588fea309763b2eaad616 is the first bad commit
commit a208e9b520ae2d854ae588fea309763b2eaad616
Author: Matt Turner <mattst88@gmail.com>
Date:   Sun Dec 7 14:08:58 2014 -0800

    util: Wire up u_atomic_test.

:040000 040000 bb54dc6d0dab5ca451dfa9c9998fb558199659b6 bcda7dca581d9c6bb6f61094769f3c94bb8d0205 M      src
bisect run success
Comment 2 Jose Fonseca 2014-12-15 20:24:04 UTC
hmm.. It looks like NetBSD has some sort of weird defines like

#define int32_t __int32_t


which is making the u_atomic_test.c macro magic go nuts. 

Not sure what's the best way of fixing this.


I feel tempted to merely put #if ! defined(__NetBSD__) ... #endif around everything.
Comment 3 GitLab Migration User 2019-09-18 20:23:27 UTC
-- GitLab Migration Automatic Message --

This bug has been migrated to freedesktop.org's GitLab instance and has been closed from further activity.

You can subscribe and participate further through the new bug through this link to our GitLab instance: https://gitlab.freedesktop.org/mesa/mesa/issues/982.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.