Bug 87770 - [gen4] GPU hang in Chrome
Summary: [gen4] GPU hang in Chrome
Status: RESOLVED DUPLICATE of bug 80568
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i965 (show other bugs)
Version: unspecified
Hardware: x86-64 (AMD64) Linux (All)
: medium major
Assignee: Ian Romanick
QA Contact: Intel 3D Bugs Mailing List
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-12-27 18:06 UTC by Gianguido Sora`
Modified: 2015-04-30 18:15 UTC (History)
3 users (show)

See Also:
i915 platform:
i915 features:


Attachments
/sys/class/drm/card0/error output (845.07 KB, text/plain)
2014-12-27 18:06 UTC, Gianguido Sora`
Details
dmesg after the error (56.50 KB, text/plain)
2014-12-27 18:07 UTC, Gianguido Sora`
Details
Xorg logs (20.72 KB, text/plain)
2014-12-27 18:08 UTC, Gianguido Sora`
Details
GM965 error state after youtube in Chrome (844.36 KB, text/plain)
2014-12-31 19:19 UTC, Paul Hollensen
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Gianguido Sora` 2014-12-27 18:06:00 UTC
Created attachment 111401 [details]
/sys/class/drm/card0/error output

While playing a YouTube video, either via mpv or directly into Google Chrome Stable, the compositor Compton stops working.

If I try to restart it, or even play something again with mpv, I get this error:

[vo/opengl/x11] X11 error: GLXBadFBConfig
[vo/opengl] Could not create GL3 context. Retrying with legacy context.
intel_do_flush_locked failed: Input/output error

Google Chrome Stable instead seems to fall back to CPU decoding.

I have to reboot to turn on the compositor again, play videos with mpv.
Comment 1 Gianguido Sora` 2014-12-27 18:07:06 UTC
Created attachment 111402 [details]
dmesg after the error
Comment 2 Gianguido Sora` 2014-12-27 18:08:15 UTC
Created attachment 111403 [details]
Xorg logs
Comment 3 Paul Hollensen 2014-12-31 19:12:56 UTC
I have precisely the same issue. Supplementing Gianguido's attachment's with my i915_error_state.

I'm currently running the 3.14.27 LTS kernel on Arch, but I only switched to that from 3.17 in the hopes that it would resolve this issue.  I'm running KDE with kwin (4.11.14) and chromium 39.0.2171.95.  My screen goes black when the gpu hangs but I can get back my desktop with just sleep/resume, though like Gianguido I can't use gl or xv until I reboot.
Comment 4 Paul Hollensen 2014-12-31 19:19:44 UTC
Created attachment 111595 [details]
GM965 error state after youtube in Chrome
Comment 5 stecklars 2015-01-13 16:58:34 UTC
Same problem here, can confirm this bug.
Comment 6 Matt Turner 2015-03-06 23:26:15 UTC
I suspect this may be another duplicate of the bug 80568, fixed (worked-around) by this commit:

commit c4fd0c9052dd391d6f2e9bb8e6da209dfc7ef35b
Author: Kenneth Graunke <kenneth@whitecape.org>
Date:   Sat Jan 17 23:21:15 2015 -0800

    i965: Work around mysterious Gen4 GPU hangs with minimal state changes.
    
    Gen4 hardware appears to GPU hang frequently when using Chromium, and
    also when running 'glmark2 -b ideas'.  Most of the error states contain
    3DPRIMITIVE commands in quick succession, with very few state packets
    between them - usually VERTEX_BUFFERS/ELEMENTS and CONSTANT_BUFFER.
    
    I trimmed an apitrace of the glmark2 hang down to two draw calls with a
    glUniformMatrix4fv call between the two.  Either draw by itself works
    fine, but together, they hang the GPU.  Removing the glUniform call
    makes the hangs disappear.  In the hardware state, this translates to
    removing the CONSTANT_BUFFER packet between the two 3DPRIMITIVE packets.
    
    Flushing before emitting CONSTANT_BUFFER packets also appears to make
    the hangs disappear.  I observed a slowdown in glxgears by doing it all
    the time, so I've chosen to only do it when BRW_NEW_BATCH and
    BRW_NEW_PSP are unset (i.e. we haven't done a CS_URB_STATE change or
    already flushed the whole pipeline).
    
    I'd much rather understand the problem, but at this point, I don't see
    how we'd ever be able to track it down further.  We have no real tools,
    and the hardware people moved on years ago.  I've analyzed 20+ error
    states and read every scrap of documentation I could find.
    
    Bugzilla: https://bugs.freedesktop.org/show_bug.cgi?id=80568
    Bugzilla: https://bugs.freedesktop.org/show_bug.cgi?id=85367
    Signed-off-by: Kenneth Graunke <kenneth@whitecape.org>
    Acked-by: Matt Turner <mattst88@gmail.com>
    Cc: "10.4 10.3" <mesa-stable@lists.freedesktop.org>

It's in git, and backports are in Mesa 10.4.x for x > 3. Please try upgrading to >10.4.3. If it's resolved by such an upgrade, please mark as a duplicate of bug 80568.
Comment 7 Matt Turner 2015-04-30 18:15:24 UTC
No reply. Marking as duplicate.

*** This bug has been marked as a duplicate of bug 80568 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct.