Bug 88115 - Regression: New WebGL conformance test failuers (GLSL Functions) with latest Mesa master
Summary: Regression: New WebGL conformance test failuers (GLSL Functions) with latest ...
Status: RESOLVED DUPLICATE of bug 87887
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i965 (show other bugs)
Version: git
Hardware: x86 (IA32) Linux (All)
: medium normal
Assignee: Ian Romanick
QA Contact: Intel 3D Bugs Mailing List
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-01-06 15:39 UTC by kalyank
Modified: 2015-01-07 01:40 UTC (History)
3 users (show)

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description kalyank 2015-01-06 15:39:44 UTC
I was checking WebGL conformance test results with latest Mesa master and Chromium (using GLES backend). I see that the following tests fail now:

https://www.khronos.org/registry/webgl/sdk/tests/conformance/glsl/functions/glsl-function-ceil.html
https://www.khronos.org/registry/webgl/sdk/tests/conformance/glsl/functions/glsl-function-clamp-float.html
https://www.khronos.org/registry/webgl/sdk/tests/conformance/glsl/functions/glsl-function-clamp-gentype.html
https://www.khronos.org/registry/webgl/sdk/tests/conformance/glsl/functions/glsl-function-cos.html
https://www.khronos.org/registry/webgl/sdk/tests/conformance/glsl/functions/glsl-function-floor.html
https://www.khronos.org/registry/webgl/sdk/tests/conformance/glsl/functions/glsl-function-normalize.html
https://www.khronos.org/registry/webgl/sdk/tests/conformance/glsl/functions/glsl-function-sign.html
https://www.khronos.org/registry/webgl/sdk/tests/conformance/glsl/functions/glsl-function-sin.html
https://www.khronos.org/registry/webgl/sdk/tests/conformance/glsl/functions/glsl-function-step-float.html
https://www.khronos.org/registry/webgl/sdk/tests/conformance/glsl/functions/glsl-function-step-gentype.html

I could track down the regression to this commit:

commit 44573458bdc52acc304fb75d6df502312b8e149c
Author: Matt Turner <mattst88@gmail.com>
Date:   Sat Dec 20 11:50:31 2014 -0800

    i965/vec4: Add pass to gather constants into a vector-float MOV.
    
    Currently only handles consecutive instructions with the same
    destination that collectively write all channels.
    
    total instructions in shared programs: 5879798 -> 5869011 (-0.18%)
    instructions in affected programs:     465236 -> 454449 (-2.32%)
    
    Reviewed-by: Ian Romanick <ian.d.romanick@intel.com>

Steps to reproduce the issue:
1) Launch Chrome and force it to use GLES backend(i.e. One can force Chrome to use GLES backend as following: chrome --use-gl=egl).  I am not sure if its necessary to use GLES backend to replicate the above mentioned issues but I haven't tested them with GL backend.
2)Open any of the above mentioned URLS in the browser.
Comment 1 lu hua 2015-01-07 01:40:45 UTC

*** This bug has been marked as a duplicate of bug 87887 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.